[问题]安装过程中出现"没有检测到cd-rom"之类对话,怎么解决?

为当前最终发行版之前的所有版本提供支持
回复
m425
帖子: 28
注册时间: 2005-09-03 11:00
送出感谢: 0
接收感谢: 0

[问题]安装过程中出现"没有检测到cd-rom"之类对话,怎么解决?

#1

帖子 m425 » 2005-09-03 11:27

我的电脑无光驱,无软驱,有两块硬盘,第一块40G,4个NTFS分区,装有windows xp系统;第二块10G,两个fat32分区,刚format 过的.
现在我想在第二块硬盘上安装ubuntu系统.于是从网上下载了ubuntu-5.04-install-i386.iso放在第二块硬盘的第一个分区上,很严格地按照http://www.ubuntu.org.cn/support/documentation/doc/installformxp的方法进行安装。
1.下载所需的文件到C:\,并确认后缀名正确.
2.修改boot.ini,追加C:\GRLDR="GRUB"
3.重启机器
4.选择grub启动,屏幕出现"grub>"字样
5.依次输入
grub>kernel (hd0,0)/vmlinuz root=/dev/ram ramdisk_size=20000 devfs=mount,dall
grub>initrd (hd0,0)/initrd.gz
grub>boot
6.根据屏幕的提示,依次选择"简体中文","中国","美式键盘"
7.屏幕提示"查找并挂载cd-rom"(我只是大概记得是这个意思)
8.显示"挂载失败,是否手动选择CD-ROM
......

但我不会手动挂载,于是我无法安装下去了.请问这样的问题怎么解决呀?
谢谢.
m425
帖子: 28
注册时间: 2005-09-03 11:00
送出感谢: 0
接收感谢: 0

#2

帖子 m425 » 2005-09-03 11:31

在线等待回复.........希望知道的达人帮帮忙~
头像
oneleaf
论坛管理员
帖子: 10208
注册时间: 2005-03-27 0:06
系统: Ubuntu 12.04
送出感谢: 7 次
接收感谢: 99 次

#3

帖子 oneleaf » 2005-09-03 11:38

如果内核不是从ISO中解压缩出来的,那么应该是没有找到 iso 文件,直接使用纯网络安装吧。
当净其意如虚空,远离妄想及诸取,令心所向皆无碍
m425
帖子: 28
注册时间: 2005-09-03 11:00
送出感谢: 0
接收感谢: 0

#4

帖子 m425 » 2005-09-03 11:49

但我试过了,即使启动的那些文件全部使用从ubuntu-5.04-install-i386.iso解出来的.但情况还是一样,
纯网络安装我觉得有点不可行,因为我现在用的是教育网,十分不稳定....
yongyi
帖子: 3025
注册时间: 2005-05-07 23:57
送出感谢: 0
接收感谢: 0
联系:

#5

帖子 yongyi » 2005-09-03 11:52

m425 写了:但我试过了,即使启动的那些文件全部使用从ubuntu-5.04-install-i386.iso解出来的.但情况还是一样,
纯网络安装我觉得有点不可行,因为我现在用的是教育网,十分不稳定....

启动的文件要从网络下载。不能iso提取
独自看一看大海
总想起身边走在路上的朋友
Lenovo E290-420[Celeron-M420/256M/60G/Intel GMA950]
头像
firehare
论坛版主
帖子: 2625
注册时间: 2005-04-10 16:54
来自: 温州大学
送出感谢: 0
接收感谢: 2 次
联系:

#6

帖子 firehare » 2005-09-03 13:14

请根据本站首页的新手指引进行安装
我心无畏,源自于我心无知。
图片
zpyin
帖子: 5
注册时间: 2005-09-03 21:41
送出感谢: 0
接收感谢: 0

#7

帖子 zpyin » 2005-09-05 10:08

yongyi 写了:
m425 写了:但我试过了,即使启动的那些文件全部使用从ubuntu-5.04-install-i386.iso解出来的.但情况还是一样,
纯网络安装我觉得有点不可行,因为我现在用的是教育网,十分不稳定....

启动的文件要从网络下载。不能iso提取

我的机器也存在类似问题,提示光驱加载失败。刚开始我用的文件是从网络上下载的,结果提示出错,安装难以进行,后从iso中提取,才开始的,但是后来就出现了光驱问题。期待回复。 :cry:
头像
oneleaf
论坛管理员
帖子: 10208
注册时间: 2005-03-27 0:06
系统: Ubuntu 12.04
送出感谢: 7 次
接收感谢: 99 次

#8

帖子 oneleaf » 2005-09-05 10:18

如果使用内核安装的内核一定不能从iso中提取,iso中的内核只支持从光盘安装,请使用我们网站的说明链接的地址。那个才是支持硬盘安装的内核。
当净其意如虚空,远离妄想及诸取,令心所向皆无碍
yongyi
帖子: 3025
注册时间: 2005-05-07 23:57
送出感谢: 0
接收感谢: 0
联系:

#9

帖子 yongyi » 2005-09-05 10:23

zpyin 写了:我的机器也存在类似问题,提示光驱加载失败。刚开始我用的文件是从网络上下载的,结果提示出错,安装难以进行,后从iso中提取,才开始的,但是后来就出现了光驱问题。期待回复。 :cry:

报什么错?
独自看一看大海
总想起身边走在路上的朋友
Lenovo E290-420[Celeron-M420/256M/60G/Intel GMA950]
zpyin
帖子: 5
注册时间: 2005-09-03 21:41
送出感谢: 0
接收感谢: 0

#10

帖子 zpyin » 2005-09-05 12:46

具体的错误当时没有记下,主要是e 文不行。等晚上我回家再从硬盘安装试验一次。先谢了。
yongyi
帖子: 3025
注册时间: 2005-05-07 23:57
送出感谢: 0
接收感谢: 0
联系:

#11

帖子 yongyi » 2005-09-05 14:56

还有,你所有非ntfs根分区下不要有其它以.iso 为后缀名的文件。
独自看一看大海
总想起身边走在路上的朋友
Lenovo E290-420[Celeron-M420/256M/60G/Intel GMA950]
m425
帖子: 28
注册时间: 2005-09-03 11:00
送出感谢: 0
接收感谢: 0

#12

帖子 m425 » 2005-09-05 17:44

安装问题已解决,原因是我的vmlinuz等文件是从iso解压出来的,后来用了网上下载的那些,就可以顺利安装了.但安装进去后,为什么我的屏幕分辩率只有640*480,刷新率只有60,在屏幕设置那也找不到更高的选项了,是不是要装驱程呢?我的显卡很老,是gf2,mx400,需要另装驱程吗?谢谢yongyi,
yongyi
帖子: 3025
注册时间: 2005-05-07 23:57
送出感谢: 0
接收感谢: 0
联系:

#13

帖子 yongyi » 2005-09-05 18:15

m425 写了:安装问题已解决,原因是我的vmlinuz等文件是从iso解压出来的,后来用了网上下载的那些,就可以顺利安装了.但安装进去后,为什么我的屏幕分辩率只有640*480,刷新率只有60,在屏幕设置那也找不到更高的选项了,是不是要装驱程呢?我的显卡很老,是gf2,mx400,需要另装驱程吗?谢谢yongyi,

这跟我的一样老。。。
http://www.ubuntu.org.cn/support/docume ... 8%E7%8E%87

可以直接修改 /etc/X11/xorg.conf
(注意备份!)

也可以
sudo dpkg-reconfigure xserver-xorg
独自看一看大海
总想起身边走在路上的朋友
Lenovo E290-420[Celeron-M420/256M/60G/Intel GMA950]
回复

回到 “老旧版本支持”