[问题]关于内核编译的问题!

为当前最终发行版之前的所有版本提供支持
回复
zhqd
帖子: 7
注册时间: 2006-09-18 10:05
送出感谢: 0
接收感谢: 0

[问题]关于内核编译的问题!

#1

帖子 zhqd » 2006-09-28 13:58

最近在Ubuntu6.06内核编译过程中进行到make xconfig时出现提示如下:

root@henry-laptop:/usr/src/linux# make xconfig
CHECK qt
*
* Unable to find the QT installation. Please make sure that
* the QT development package is correctly installed and
* either install pkg-config or set the QTDIR environment
* variable to the correct location.
*
make[1]: *** 没有规则可以创建“scripts/kconfig/qconf.o”需要的目标“scripts/kconfig/.tmp_qtcheck”。 停止。
make: *** [xconfig] 错误 2
zhqd
帖子: 7
注册时间: 2006-09-18 10:05
送出感谢: 0
接收感谢: 0

#2

帖子 zhqd » 2006-09-28 14:00

经过查询,知道是QT库没有安装,就执行sudo apt-get install libqt3-dev出现提示如下:

root@henry-laptop:/usr/src/linux# apt-get install libqt3-dev
正在读取软件包列表... 完成
正在分析软件包的依赖关系树... 完成
现在没有可用的软件包 libqt3-dev,但是它被其它的软件包引用了。
这可能意味着这个缺失的软件包可能已被废弃,
或者只能在其他发布源中找到
可是下列的软件包取代了它:
qt3-dev-tools qt3-apps-dev libqt3-mt-dev libqt3-headers
libqt3-compat-headers
E: 软件包 libqt3-dev 还没有可供安装的候选者
zhqd
帖子: 7
注册时间: 2006-09-18 10:05
送出感谢: 0
接收感谢: 0

#3

帖子 zhqd » 2006-09-28 14:02

然后又执行apt-get install libqt3-mt-dev出现提示如下:


root@henry-laptop:/usr/src/linux# apt-get install libqt3-mt-dev
正在读取软件包列表... 完成
正在分析软件包的依赖关系树... 完成
有一些软件包无法被安装。如果您用的是不稳定(unstable)发行版,这也许是
因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件
包尚未被创建或是它们还在新到(incoming)目录中。

您仅要求对单一软件包进行操作,这极有可能是因为该软件包安装不上,同时,
您最好提交一个针对这个软件包的故障报告。
下列的信息可能会对解决问题有所帮助:

下列的软件包有不能满足的依赖关系:
libqt3-mt-dev: 依赖: libxext-dev (>= 4.3.0.dfsg.1-4) 但却无法安装它
依赖: libxrandr-dev (>= 4.3.0.dfsg.1-4) 但却无法安装它
依赖: x-dev (>= 4.3.0.dfsg.1-4) 但却无法安装它
依赖: libsm-dev (>= 4.3.0.dfsg.1-4) 但却无法安装它
依赖: libxmu-dev (>= 4.3.0.dfsg.1-4) 但却无法安装它
依赖: libice-dev (>= 4.3.0.dfsg.1-4) 但却无法安装它
依赖: libx11-dev (>= 4.3.0.dfsg.1-4) 但却无法安装它
依赖: libxt-dev (>= 4.3.0.dfsg.1-4) 但却无法安装它
依赖: libxrender-dev 但却无法安装它
依赖: libxcursor-dev 但却无法安装它
依赖: libxinerama-dev 但却无法安装它
依赖: libxi-dev 但却无法安装它
依赖: libmng-dev (>= 1.0.3) 但却无法安装它
依赖: libpng12-0-dev 但却无法安装它
依赖: libjpeg62-dev 但却无法安装它
依赖: zlib1g-dev 但却无法安装它
依赖: libfreetype6-dev 但是它将不会被安装
依赖: xlibmesa-gl-dev 但却无法安装它 或
libgl-dev 但却无法安装它
依赖: libglu1-xorg-dev 但却无法安装它 或
libglu1-mesa-dev 但却无法安装它 或
libglu-dev 但却无法安装它
依赖: libxft-dev 但却无法安装它
依赖: libaudio-dev 但却无法安装它
E: 无法安装的软件包
zhqd
帖子: 7
注册时间: 2006-09-18 10:05
送出感谢: 0
接收感谢: 0

#4

帖子 zhqd » 2006-09-28 14:03

我真晕死了,到底应该怎么办?那位兄弟指教一下?谢谢!!!
newx
帖子: 146
注册时间: 2006-02-28 19:05
送出感谢: 0
接收感谢: 0

#5

帖子 newx » 2006-09-28 14:28

:lol: 换个完整的源再试试 :lol:
头像
SuperWar3Fan
帖子: 1263
注册时间: 2006-05-20 6:25
来自: 山东淄博
送出感谢: 0
接收感谢: 0
联系:

#6

帖子 SuperWar3Fan » 2006-09-28 16:34

1、更新一下apt源
2、安装lib-qt
zhqd
帖子: 7
注册时间: 2006-09-18 10:05
送出感谢: 0
接收感谢: 0

#7

帖子 zhqd » 2006-10-09 13:23

通过更换新的源已经解决了上述问题,新利得真的很好用啊!呵呵!
谢谢各位的帮助!

另:
请问最新的linux内核是否支持Adsl usb modem?谢谢!
回复

回到 “老旧版本支持”