[分享]用debfoster帮你管理软件包

为当前最终发行版之前的所有版本提供支持
回复
leo_tzao
帖子: 157
注册时间: 2005-11-15 11:28
送出感谢: 0
接收感谢: 0
联系:

[分享]用debfoster帮你管理软件包

#1

帖子 leo_tzao » 2006-09-28 14:05

debfoster是一个很好用的软件包管理辅助软件,它能侦测系统内新安装的deb包,并提示你选择是保留该包还是删除它,当我们为了编译软件等目的而不得不安装了大量deb包来解决依赖问题的情况下,这个软件变得十分有用处。

众所周知,在debian/ubuntu中,软件的代码包和开发代码包是分开的,比如gaim是著名IM软件gaim的包,而gaim-dev则是gaim 的开发包,当自己从源码编译安装或者打包新软件的时候,很多名为-dev的开发包就需要被安装,久而久之,系统里就积累了非常非常多的开发包,而这写包基本上只在编译某个软件的时候才会有用──更为可气的是,相信很多“酷爱”自己编译的朋友都和我一样,有过这样的经历:当你辛辛苦苦装了N多个-dev的开发包以后,软件却仍无论如何不能编译通过,使得你不得不放弃,又或者编译成功了才发现这个软件并不合你的需要,不得不又删掉。这种时候,当初为了编译这软件而辛辛苦苦安装的若干-dev包却早已记不清楚,只能留它们在系统里充当“废物”了。

用debfoster就可以很好的解决您这样的苦恼。

首先 aptitude install debfoster
然后 sudo debfoster
此时 debfoster 会依次提示您系统内所有以安装的软件包,如果您确认此前所有软件都是您所需要的,只需要一路按Y就可以了。

在此以后,当您编译软件安装一大堆不常用的开发包之后,再次运行sudo debfoster,所有您未确认的软件包会再次提示,只需按p,就可以将您不需要的软件包撤的清除。

对于像我一样喜欢从server模式自定义安装ubuntu的朋友,推荐在安装好所有常用软件,打造成您自己的平台以后,安装并运行debfoster,这样就可以确认基本系统所有的包,此后编译安装都可以放心的进行了,只要对您觉得有用的包按y,其它都可以轻松删除:)

<原文URL http://my.opera.com/leo_tzao/blog/show.dml/489484>
回复

回到 “老旧版本支持”