当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 2 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 怎么把某个软件降级?
帖子发表于 : 2010-03-10 12:15 

注册: 2005-05-01 12:54
帖子: 920
送出感谢: 0 次
接收感谢: 0 次
想装firefox-smooth-scaling项目的xulrunner,这个版本的xulrunner是1.9.1.8的,但是系统内的xulrunner已经被升级到1.9.1.9了。现在firefox-smooth-scaling的版本就没法装了。如果卸载当前版本的,会一起卸载掉一堆的东西。如果在外面单独下载软件包强制安装,系统就管不到了。有没有什么办法,可以在apt命令本身的范围内解决它?


页首
 用户资料  
 
2 楼 
 文章标题 : Re: 怎么把某个软件降级?
帖子发表于 : 2010-03-10 12:46 
头像

注册: 2007-10-23 12:54
帖子: 1750
送出感谢: 3
接收感谢: 28
降级用 aptitude install xulrunner-1.9.1=版本号
具体的版本号从这个地址查看
http://packages.ubuntu.com/search?keywo ... nner-1.9.1
找你系统版本对应的,可能是下面几个值
1.9.1.8+build1+nobinonly-0ubuntu0.9.04.1
1.9.1.8+build1+nobinonly-0ubuntu0.9.10.1
1.9.1.8+build1+nobinonly-0ubuntu1

然后要单独锁定这个包不升级,有多种方法
1. dpkg 用 hold
2.preferences 中用 Pin-Priority
http://wiki.debian.org/AptPreferences
3.新立得中的选项

最后,这个版本冲突一定是你引入外部源造成的,因为官方源里面根本没有 1.9.1.9。去掉外部源会减少很多不必要的麻烦。


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 2 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译