[问题]ubuntu下如何使用一些以rpm各式发布的软件?

为当前最终发行版之前的所有版本提供支持
回复
ieo2008
帖子: 25
注册时间: 2006-09-28 20:56
送出感谢: 0
接收感谢: 0
联系:

[问题]ubuntu下如何使用一些以rpm各式发布的软件?

#1

帖子 ieo2008 » 2006-09-28 21:06

如题,请大虾指教!
头像
alpha.gu
帖子: 1456
注册时间: 2006-09-10 16:06
送出感谢: 0
接收感谢: 0
联系:

#2

帖子 alpha.gu » 2006-09-28 22:38

查找alias关键字,好像要装这个东西,然后把rpm包转成deb包,具体我没用过,因为我也是新手。
头像
stlxv
论坛版主
帖子: 8273
注册时间: 2006-05-03 0:39
来自: المريخ
送出感谢: 0
接收感谢: 1 次

#3

帖子 stlxv » 2006-09-29 0:06

代码: 全选

apt-get install rpm
然后就可以用rpm了。有的rpm直接解压就可以了,有些还带有设置脚本,直接运行rpm来安装,安装的时候要加上--no-deps参数,不考虑依赖问题。
PHP是最好的语言!不服来战!
wxcxyz
帖子: 13
注册时间: 2006-09-27 9:28
送出感谢: 0
接收感谢: 0

#4

帖子 wxcxyz » 2006-09-29 10:49

sudo apt-get install rpm
头像
SuperWar3Fan
帖子: 1263
注册时间: 2006-05-20 6:25
来自: 山东淄博
送出感谢: 0
接收感谢: 0
联系:

#5

帖子 SuperWar3Fan » 2006-09-29 15:02

需要安装alien
用alien把rpm转换成为deb包。
然后用dpkg -i deb包的名称来安装
头像
stlxv
论坛版主
帖子: 8273
注册时间: 2006-05-03 0:39
来自: المريخ
送出感谢: 0
接收感谢: 1 次

#6

帖子 stlxv » 2006-09-29 19:46

wxcxyz 写了:sudo apt-get install rpm
习惯了用的时候先su了……
PHP是最好的语言!不服来战!
回复

回到 “老旧版本支持”