当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 7 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 晕死,这g++怎么搞?求救~~~
帖子发表于 : 2010-03-19 8:50 

注册: 2010-03-18 13:25
帖子: 3
送出感谢: 0 次
接收感谢: 0 次
tony@tony-laptop:~$ sudo apt-get install g++
[sudo] password for tony:
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
正在读取状态信息... 完成
有一些软件包无法被安装。如果您用的是不稳定(unstable)发行版,这也许是
因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件
包尚未被创建或是它们还在新到(incoming)目录中。
下列的信息可能会对解决问题有所帮助:

下列的软件包有不能满足的依赖关系:
g++: 依赖: g++-4.4 (>= 4.4.1-1) 但是它将不会被安装
E: 无法安装的软件包
tony@tony-laptop:~$ sudo apt-get install g++
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
正在读取状态信息... 完成
有一些软件包无法被安装。如果您用的是不稳定(unstable)发行版,这也许是
因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件
包尚未被创建或是它们还在新到(incoming)目录中。
下列的信息可能会对解决问题有所帮助:

下列的软件包有不能满足的依赖关系:
g++: 依赖: g++-4.4 (>= 4.4.1-1) 但是它将不会被安装
E: 无法安装的软件包
tony@tony-laptop:~$ sudo apt-get install libstdc++6-4.4-dev
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
正在读取状态信息... 完成
有一些软件包无法被安装。如果您用的是不稳定(unstable)发行版,这也许是
因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件
包尚未被创建或是它们还在新到(incoming)目录中。
下列的信息可能会对解决问题有所帮助:

下列的软件包有不能满足的依赖关系:
libstdc++6-4.4-dev: 依赖: gcc-4.4-base (= 4.4.1-4ubuntu8) 但是 4.4.1-4ubuntu9 正要被安装
依赖: g++-4.4 (= 4.4.1-4ubuntu8) 但是它将不会被安装
E: 无法安装的软件包
=============================
确定有软件包的呀,就是装不上……


页首
 用户资料  
 
2 楼 
 文章标题 : Re: 晕死,这g++怎么搞?求救~~~
帖子发表于 : 2010-03-19 8:52 
头像

注册: 2008-11-21 20:26
帖子: 36913
送出感谢: 1
接收感谢: 36
10.04?

代码:
sudo aptitude install build-essential


_________________
讨厌我的人可以试着点一下
浏览全部ubuntu技巧


页首
 用户资料  
 
3 楼 
 文章标题 : Re: 晕死,这g++怎么搞?求救~~~
帖子发表于 : 2010-03-19 13:23 

注册: 2010-03-18 13:25
帖子: 3
送出感谢: 0 次
接收感谢: 0 次
这个是为什么捏?


页首
 用户资料  
 
4 楼 
 文章标题 : Re: 晕死,这g++怎么搞?求救~~~
帖子发表于 : 2010-03-19 21:07 
头像

注册: 2006-04-05 18:12
帖子: 474
送出感谢: 0 次
接收感谢: 0 次
引用:
如果您用的是不稳定(unstable)发行版,这也许是
因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件
包尚未被创建或是它们还在新到(incoming)目录中。


10.04把,人家说了,g++-4.4没有在10.04的源里面,所以不能通过源来安装。
换成904把


_________________
Fedora Notes


页首
 用户资料  
 
5 楼 
 文章标题 : Re: 晕死,这g++怎么搞?求救~~~
帖子发表于 : 2010-03-19 23:34 

注册: 2010-03-18 13:25
帖子: 3
送出感谢: 0 次
接收感谢: 0 次
是9.10的……


页首
 用户资料  
 
6 楼 
 文章标题 : Re: 晕死,这g++怎么搞?求救~~~
帖子发表于 : 2010-03-19 23:46 
头像

注册: 2006-04-05 18:12
帖子: 474
送出感谢: 0 次
接收感谢: 0 次
代码:
sudo apt-get -f install g++


ref:http://ubuntuforums.org/showthread.php?p=8946842


_________________
Fedora Notes


页首
 用户资料  
 
7 楼 
 文章标题 : Re: 晕死,这g++怎么搞?求救~~~
帖子发表于 : 2010-12-09 21:00 

注册: 2010-12-09 20:56
帖子: 1
送出感谢: 0 次
接收感谢: 0 次
:em05 终于解决了,二楼正解,谢谢!!~~


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 7 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译