新打包的 Auacious 1.1.2 最新稳定版

为当前最终发行版之前的所有版本提供支持
chenyu
帖子: 80
注册时间: 2006-02-27 18:06
来自: FZU
送出感谢: 0
接收感谢: 0

新打包的 Auacious 1.1.2 最新稳定版

#1

帖子 chenyu » 2006-10-01 12:45

首先向leo_tzao兄弟致敬,感谢他一直为大家带来新版本的打包。

刚参加工作,一直很忙,难得碰到国庆,就想升级一下我上次打包的1.1.1版Auacious,好像上次这个版本大家没反映什么问题,所以今天制作了Auacious 1.1.2 stable,大家可以试用一下。如果大家是用我上次打包的1.1.1版,应该可以直接升级,不需要卸载。

看了帖子:“[Audacious] 最新上传9月27日svn deb包”我也很奇怪为何会有很多人反映问题,我使用他的打包好像也没碰到什么问题。今天也顺便整理一下打包过程,和leo_tzao兄弟探讨一下。

首先

代码: 全选

export DEBEMAIL=your@email
export DEBFULLNAME="Your Name"
然后在

代码: 全选

cd audacious-1.1.2
dh_make -e your@email -f ../audacious-1.1.2.tar.gz
将debian目录下的那些文件进行修改
(dh_make只要作一次,以后升级版本,直接拷上一个版本的过来修改一下就成了,而且debian下很多不需要的文件我都删了)
修改过的创建规则见附件debian-1.1.2.tar.gz

接下去是我也没搞懂的地方,我在rules里面设置的configure参数根本没起作用,好像rules只对没用autoconf打包的软件有用,debuild直接用默认参数调用configure了。

因此我就修改了Audacious代码目录下的configure.ac文件,修改了默认参数设置,比如prefix=/usr,chardet默认开启,fluidsynth我把它关了。(修改过的configure.ac也在debian-1.1.2.tar.gz里面)

代码: 全选

最后就是编译打包了
首先运行autoconf生成新的configure脚本
然后运行debulid -us -us,等一会儿就打包完成了
这次打包1.1.2,我同样开启了chardet,编译了除FluidSynth和AdPlug之外的所有自带插件。

FluidSynth是一个MIDI软件合成器,很奇怪,我编译后用它加载了几个SoundFont(.sf2)放MIDI,效果很差,断断续续,看来我还是用我的Live!自带的合成器吧:)所以我就把它禁掉了。

AdPlug是一个用来放古董音频文件格式的插件(比如世界上最早的声卡Adlib用的文件。。。)leo_tzao兄要编译的话,可以装上一个名为libadplug-dev的开发包(源里就有),我觉得使用几率极小,就不编译了。这样可以减少几个依赖。
附件
debian-1.1.2.tar.gz
debuild rules
(10.24 KiB) 下载 86 次
audacious_1.1.2-0ubuntu1_i386.deb
Auacious 1.1.2 stable
(1.73 MiB) 下载 1839 次
上次由 chenyu 在 2006-10-04 21:11,总共编辑 2 次。
头像
zhuqin_83
帖子: 10606
注册时间: 2006-05-13 4:02
送出感谢: 0
接收感谢: 7 次
联系:

#2

帖子 zhuqin_83 » 2006-10-01 12:53

试试哦。不知edgy下有没有问题。
HP Pavilion DV6-2064CA: AMD Turion II Ultra Dual-Core Mobile M640, HD4650, 2GBx2 DDR2-800, Seagate 500GB 7200RPM SATA, BD-ROM
DELL UltraSharp 2209WA
Arch64, Testing repo
chenyu
帖子: 80
注册时间: 2006-02-27 18:06
来自: FZU
送出感谢: 0
接收感谢: 0

#3

帖子 chenyu » 2006-10-01 15:25

zhuqin_83 写了:试试哦。不知edgy下有没有问题。
faint...大家真喜欢追新哦,我只是在livecd上跑了跑edgy,没感觉太大的变化,决定不玩了,等以后版本吧。

这次是在dapper 6.06-1下编译的,所用的开发包都是官方的,应该在edgy下也能满足依赖关系吧
头像
Beetle
帖子: 1637
注册时间: 2005-10-14 16:55
系统: OS X
来自: 江苏
送出感谢: 0
接收感谢: 0
联系:

#4

帖子 Beetle » 2006-10-04 17:31

报告LZ,edgy下一切正常! :em11
头像
爱国者黑客
帖子: 608
注册时间: 2006-10-01 14:34
送出感谢: 0
接收感谢: 0

#5

帖子 爱国者黑客 » 2006-10-04 17:49

ls@ls-desktop:/var/tmp$ sudo dpkg -i audacious_1.1.2-0ubuntu1_i386.deb
选中了曾被取消选择的软件包 audacious。
(正在读取数据库 ... 系统当前总共安装有 76455 个文件和目录。)
正在解压缩 audacious (从 audacious_1.1.2-0ubuntu1_i386.deb) ...
dpkg:依赖关系问题使得 audacious 的配置工作不能继续:
audacious 依赖于 libartsc0 (>= 1.5.2-0);然而:
软件包 libartsc0还没有被安装。
audacious 依赖于 libmodplug0c2 (>= 1:0.7-4.1);然而:
软件包 libmodplug0c2还没有被安装。
audacious 依赖于 libmpcdec3;然而:
软件包 libmpcdec3还没有被安装。
audacious 依赖于 libtagc0 (>= 1.4);然而:
软件包 libtagc0还没有被安装。
dpkg:处理 audacious (--install)时出错:
依赖关系问题 - 仍未被配置
在处理时有错误发生:
audacious
ls@ls-desktop:/var/tmp$
chenyu
帖子: 80
注册时间: 2006-02-27 18:06
来自: FZU
送出感谢: 0
接收感谢: 0

#6

帖子 chenyu » 2006-10-04 21:06

爱国者黑客 写了:ls@ls-desktop:/var/tmp$ sudo dpkg -i audacious_1.1.2-0ubuntu1_i386.deb
选中了曾被取消选择的软件包 audacious。
(正在读取数据库 ... 系统当前总共安装有 76455 个文件和目录。)
正在解压缩 audacious (从 audacious_1.1.2-0ubuntu1_i386.deb) ...
dpkg:依赖关系问题使得 audacious 的配置工作不能继续:
audacious 依赖于 libartsc0 (>= 1.5.2-0);然而:
软件包 libartsc0还没有被安装。
audacious 依赖于 libmodplug0c2 (>= 1:0.7-4.1);然而:
软件包 libmodplug0c2还没有被安装。
audacious 依赖于 libmpcdec3;然而:
软件包 libmpcdec3还没有被安装。
audacious 依赖于 libtagc0 (>= 1.4);然而:
软件包 libtagc0还没有被安装。
dpkg:处理 audacious (--install)时出错:
依赖关系问题 - 仍未被配置
在处理时有错误发生:
audacious
ls@ls-desktop:/var/tmp$
正常啊,可以自己把缺的补上
apt-get install libartsc0 libmodplug0c2 libmpcdec3 libtagc0
头像
allstar
帖子: 165
注册时间: 2006-08-25 8:16
来自: NEU
送出感谢: 0
接收感谢: 0
联系:

#7

帖子 allstar » 2006-10-05 11:05

libaudacious3 出了什么问题~ 怎么回事阿?
头像
leewtao
帖子: 179
注册时间: 2005-12-09 15:33
来自: 云南.昆明
送出感谢: 0
接收感谢: 0
联系:

#8

帖子 leewtao » 2006-10-08 8:49

爱国者黑客 写了:ls@ls-desktop:/var/tmp$ sudo dpkg -i audacious_1.1.2-0ubuntu1_i386.deb
选中了曾被取消选择的软件包 audacious。
(正在读取数据库 ... 系统当前总共安装有 76455 个文件和目录。)
正在解压缩 audacious (从 audacious_1.1.2-0ubuntu1_i386.deb) ...
dpkg:依赖关系问题使得 audacious 的配置工作不能继续:
audacious 依赖于 libartsc0 (>= 1.5.2-0);然而:
软件包 libartsc0还没有被安装。
audacious 依赖于 libmodplug0c2 (>= 1:0.7-4.1);然而:
软件包 libmodplug0c2还没有被安装。
audacious 依赖于 libmpcdec3;然而:
软件包 libmpcdec3还没有被安装。
audacious 依赖于 libtagc0 (>= 1.4);然而:
软件包 libtagc0还没有被安装。
dpkg:处理 audacious (--install)时出错:
依赖关系问题 - 仍未被配置
在处理时有错误发生:
audacious
ls@ls-desktop:/var/tmp$
sudo apt-get -f --install
茶叶棍儿
帖子: 34
注册时间: 2006-10-27 9:58
来自: 北京
送出感谢: 0
接收感谢: 0

#9

帖子 茶叶棍儿 » 2006-11-03 15:16

请问这个版本的audacious应该用哪个APE插件呢?安装了0.1.1和0.1.2两个版本的插件,都不起作用。。。在插件清单中找不到,但确认了插件的文件是在插件目录中的。
gdou
帖子: 73
注册时间: 2006-06-19 0:46
送出感谢: 0
接收感谢: 0

#10

帖子 gdou » 2006-11-06 18:35

我的现在乱码,在哪里改呢?好像和1.00版不一样了
Quan_
帖子: 8
注册时间: 2006-11-04 22:20
送出感谢: 0
接收感谢: 0

#11

帖子 Quan_ » 2006-11-12 13:27

茶叶棍儿 写了:请问这个版本的audacious应该用哪个APE插件呢?安装了0.1.1和0.1.2两个版本的插件,都不起作用。。。在插件清单中找不到,但确认了插件的文件是在插件目录中的。
我这里也是这个问题,到底该用哪个插件呢?
if
帖子: 62
注册时间: 2006-09-12 1:25
送出感谢: 0
接收感谢: 0

#12

帖子 if » 2006-11-12 15:08

放不了ape的请看这里
viewtopic.php?t=19630

关于中文文件名的问题
面板上点右键-首选项-插件-decoder-mpeg音频插件-首选项-标题
两个钩都挑上,框里填%f-%g
这样中文就正常了
前提是你的中文文件名本身就没乱码

还有问题,用audacious开大文件非常不爽阿,硬盘狂转,尤其ape,bmp就没这毛病,why?
头像
jarlyyn
论坛版主
帖子: 4671
注册时间: 2006-04-12 18:54
送出感谢: 0
接收感谢: 6 次
联系:

#13

帖子 jarlyyn » 2006-11-12 22:02

用了

音质真的不错
fuhuizn
帖子: 752
注册时间: 2006-01-06 22:55
系统: ubuntu
送出感谢: 0
接收感谢: 15 次
联系:

#14

帖子 fuhuizn » 2006-11-14 13:03

wma 插件不能用
附件
Screenshot-audacious.png
Screenshot-audacious.png (9.56 KiB) 查看 2405 次
shukae
帖子: 16
注册时间: 2006-11-15 23:21
送出感谢: 0
接收感谢: 0

#15

帖子 shukae » 2006-11-15 23:47

如果 MP3 的 tag 是 Unicode 編碼, tag 顯示會不正常喔
回复

回到 “老旧版本支持”