[分享]pppoeconf error in edgy beta after clean install

为当前最终发行版之前的所有版本提供支持
回复
newlad
帖子: 258
注册时间: 2005-09-28 12:01
送出感谢: 0
接收感谢: 0

[分享]pppoeconf error in edgy beta after clean install

#1

帖子 newlad » 2006-10-01 22:56

i find a bug in ubuntu edgy beta,the pppoeconf can not been run,i find in ubuntuforums, and get a
method to fix this bug,this bug happed because the script /usr/sbin/pppoeconf,and you install the zenity
package, but this package is not use now,

sudo gedit /usr/sbin/pppoeconf

and then comment the sentens:
you should comment the comment in you pppoeconf script

export XDIALOG_HIGH_DIALOG_COMPAT
if [ -n "$DISPLAY" ] ; then
if [ -x /usr/bin/Xdialog ] ; then
DIALOG="Xdialog"
X11="-X"
#elif [ -x /usr/bin/zenity ] ; then
# DIALOG="zenity"
# X11="-X"
fi
fi





there a direct method to ppp:

sudo gedit /etc/ppp/peers/dsl-provider

add these to the last

user "you ppp user name"

password "password"

plugin rp-pppoe.so eth0
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#2

帖子 eexpress » 2006-10-01 23:04

zenity怎么会废弃呢。蛮好的阿。
● 鸣学
回复

回到 “老旧版本支持”