为什么把ISO dd到U盘后不能启动

为当前最终发行版之前的所有版本提供支持
头像
leetom
帖子: 296
注册时间: 2009-01-23 19:28
送出感谢: 0
接收感谢: 0

为什么把ISO dd到U盘后不能启动

#1

帖子 leetom » 2010-03-27 20:59

以前好像看过直接用dd把镜像写到U盘,但是我试了几次都不行。那么写镜像应该用什么,像ultraISO那样的?好像unetbootin不是直接写入的。
头像
smallapple
论坛版主
帖子: 7867
注册时间: 2009-03-28 15:12
送出感谢: 0
接收感谢: 19 次

Re: 为什么把ISO dd到U盘后不能启动

#2

帖子 smallapple » 2010-03-27 21:09

试过 desktop 版的 dd 后可以启动
Alternative 的不行
头像
leetom
帖子: 296
注册时间: 2009-01-23 19:28
送出感谢: 0
接收感谢: 0

Re: 为什么把ISO dd到U盘后不能启动

#3

帖子 leetom » 2010-03-27 21:16

smallapple 写了:试过 desktop 版的 dd 后可以启动
Alternative 的不行
我这个是debian-503-i386,应该是liveCD, 不能启动。
头像
smallapple
论坛版主
帖子: 7867
注册时间: 2009-03-28 15:12
送出感谢: 0
接收感谢: 19 次

Re: 为什么把ISO dd到U盘后不能启动

#4

帖子 smallapple » 2010-03-27 21:18

大便没用过,不清楚

怎么用的 dd ?
头像
leetom
帖子: 296
注册时间: 2009-01-23 19:28
送出感谢: 0
接收感谢: 0

Re: 为什么把ISO dd到U盘后不能启动

#5

帖子 leetom » 2010-03-27 21:29

smallapple 写了:大便没用过,不清楚

怎么用的 dd ?
就是sudo dd if=iso-path of=/dev/sdb1
里面的文件都正常,但是不能启动,现在格式是iso9660
头像
smallapple
论坛版主
帖子: 7867
注册时间: 2009-03-28 15:12
送出感谢: 0
接收感谢: 19 次

Re: 为什么把ISO dd到U盘后不能启动

#6

帖子 smallapple » 2010-03-27 21:31

要用
sudo dd if=iso-path of=/dev/sdb
U盘的文件和分区会清空,有其分区先备份文件。
头像
leetom
帖子: 296
注册时间: 2009-01-23 19:28
送出感谢: 0
接收感谢: 0

Re: 为什么把ISO dd到U盘后不能启动

#7

帖子 leetom » 2010-03-27 22:18

smallapple 写了:要用
sudo dd if=iso-path of=/dev/sdb
U盘的文件和分区会清空,有其分区先备份文件。
哦,谢了。我再试一次。

用ultraISO做了一次,可以启动但是不能安装。
debian安装过程会挂载cdrom,然后提示不能挂载...
可能要用光盘。
头像
smallapple
论坛版主
帖子: 7867
注册时间: 2009-03-28 15:12
送出感谢: 0
接收感谢: 19 次

Re: 为什么把ISO dd到U盘后不能启动

#8

帖子 smallapple » 2010-03-27 22:37

大便安装好象要挂载 iso 的,可能不支持 用U盘做的镜像
头像
adam8157
帖子: 2794
注册时间: 2009-03-05 16:31
送出感谢: 0
接收感谢: 8 次
联系:

Re: 为什么把ISO dd到U盘后不能启动

#9

帖子 adam8157 » 2010-03-27 23:39

debian的不是livecd...debian的想U盘启动

1, 可以用hd-media, 加businesscard或者netinst或者cd或者dvd的iso启动
2, 可以用netboot, 只有5MB, 全网络安装
头像
leetom
帖子: 296
注册时间: 2009-01-23 19:28
送出感谢: 0
接收感谢: 0

Re: 为什么把ISO dd到U盘后不能启动

#10

帖子 leetom » 2010-03-28 17:45

多谢ls两位。
debian不能装,我又去下了个centOS的DVD,刻了盘装好了。
没有安装grub。
进入ubuntu后update-grub找到了centOS的启动项,但是启动不了。
提示

代码: 全选

VFS: cannot open root device "/dev/sda10" or unknown-block(0,0)
please append a correct "root=" boot option
kernel panic not syncing: VFS: unable to mount root fs on unknown-block (0,0)
把root=后边改为UUID后还是这个错误。
是grub2配置的问题还是centOS安装的问题?
头像
smallapple
论坛版主
帖子: 7867
注册时间: 2009-03-28 15:12
送出感谢: 0
接收感谢: 19 次

Re: 为什么把ISO dd到U盘后不能启动

#11

帖子 smallapple » 2010-03-28 19:04

ls的看看这个
viewtopic.php?f=77&t=263083
头像
冲浪板
论坛版主
帖子: 7467
注册时间: 2007-05-06 8:19
送出感谢: 0
接收感谢: 5 次

Re: 为什么把ISO dd到U盘后不能启动

#12

帖子 冲浪板 » 2010-03-28 19:11

启动、使用是可以的,但是不用dd
头像
onshoestring
论坛版主
帖子: 4666
注册时间: 2009-09-06 5:53
送出感谢: 0
接收感谢: 108 次

Re: 为什么把ISO dd到U盘后不能启动

#13

帖子 onshoestring » 2010-03-28 19:14

不知对你有帮助没有,这个是我的centos在ubuntu中grub2的菜单。
menuentry "CentOS (2.6.18-164.el5)" {
insmod ext2
set root=(hd0,10)
linux /vmlinuz-2.6.18-164.el5 ro root=/dev/VolGroup00/LogVol00 rhgb quiet
initrd /initrd-2.6.18-164.el5.img
}
头像
leetom
帖子: 296
注册时间: 2009-01-23 19:28
送出感谢: 0
接收感谢: 0

Re: 为什么把ISO dd到U盘后不能启动

#14

帖子 leetom » 2010-03-28 19:34

smallapple 写了:ls的看看这个
viewtopic.php?f=77&t=263083
我的应该不是这个问题,显卡我只有一个...
头像
leetom
帖子: 296
注册时间: 2009-01-23 19:28
送出感谢: 0
接收感谢: 0

Re: 为什么把ISO dd到U盘后不能启动

#15

帖子 leetom » 2010-03-28 19:56

onshoestring 写了:不知对你有帮助没有,这个是我的centos在ubuntu中grub2的菜单。
menuentry "CentOS (2.6.18-164.el5)" {
insmod ext2
set root=(hd0,10)
linux /vmlinuz-2.6.18-164.el5 ro root=/dev/VolGroup00/LogVol00 rhgb quiet
initrd /initrd-2.6.18-164.el5.img
}
虽然有些看不明白,等一下还是试一下吧。谢谢了
回复

回到 “老旧版本支持”