硬盘安装的时候把grub没有装起来

为当前最终发行版之前的所有版本提供支持
回复
头像
desper
帖子: 95
注册时间: 2006-10-03 4:28
送出感谢: 0
接收感谢: 0

硬盘安装的时候把grub没有装起来

#1

帖子 desper » 2006-10-03 4:42

看着网上的指导把ubuntu硬盘安装上去了,现在的问题是不知道怎么用grub引导已经安装上去的ubuntu,自己想想也很汗!啊!
我的硬盘现在是这个样子 [C:/winxp ntfs] [hd0,1? ubuntu] [D:/fat32 我的grub在上面] [swap]
vfloppy-dos-grub 然后就不知道怎么办了,应该可以引导吧

另外,
硬盘安装的时候把grub没有装起来,结果是一个系统都没有了,
尝试了一下用xp的修复控制台fixmbr和fixboot,没有成功。
winxp是通过xp安装盘重新安装 半 遍修复的,结果在xp下面pqmagic报错打不开了。
安装了一个wingrub才看到了ubuntu的安装位置

请教具体怎么操作才能进ubuntu?
死也要见ubuntu的尸体才行吧 呵呵 谢谢了
CN.Tink
帖子: 13
注册时间: 2006-10-01 2:18
送出感谢: 0
接收感谢: 0

#2

帖子 CN.Tink » 2006-10-03 5:53

用Live CD修复吧,附我的/boot/grub/menu.lst一部分内容
title Ubuntu, kernel 2.6.15-27-386
root (hd0,7)
kernel /boot/vmlinuz-2.6.15-27-386 root=/dev/hda8 ro quiet splash
initrd /boot/initrd.img-2.6.15-27-386
savedefault
boot

title Ubuntu, kernel 2.6.15-27-386 (recovery mode)
root (hd0,7)
kernel /boot/vmlinuz-2.6.15-27-386 root=/dev/hda8 ro single
initrd /boot/initrd.img-2.6.15-27-386
boot

title Ubuntu, kernel 2.6.15-26-386
root (hd0,7)
kernel /boot/vmlinuz-2.6.15-26-386 root=/dev/hda8 ro quiet splash
initrd /boot/initrd.img-2.6.15-26-386
savedefault
boot

title Ubuntu, kernel 2.6.15-26-386 (recovery mode)
root (hd0,7)
kernel /boot/vmlinuz-2.6.15-26-386 root=/dev/hda8 ro single
initrd /boot/initrd.img-2.6.15-26-386
boot

title Ubuntu, memtest86+
root (hd0,7)
kernel /boot/memtest86+.bin
boot

### END DEBIAN AUTOMAGIC KERNELS LIST

# This is a divider, added to separate the menu items below from the Debian
# ones.
title Other operating systems:
root


# This entry automatically added by the Debian installer for a non-linux OS
# on /dev/hda1
title Windows NT/2000/XP (loader)
root (hd0,0)
savedefault
makeactive
chainloader +1

不要照抄,要对照你的情况来改下。
PS:我WIN下的PQ也用不了,一启动就报错,不过不管他了,才两天,我已经快习惯在UBUNTU下工作了!
头像
millenniumdark
论坛版主
帖子: 4159
注册时间: 2005-07-02 14:41
系统: Ubuntu 14.04 (Kylin)
送出感谢: 42 次
接收感谢: 9 次
联系:

#3

帖子 millenniumdark » 2006-10-03 13:32

硬盘安装?没有cd?

没有live cd的话不太好弄。刻一张吧。

viewtopic.php?t=2461&highlight=
2楼是用live cd恢复
5楼是用grub4dos恢复(无需安装盘或livecd)
头像
desper
帖子: 95
注册时间: 2006-10-03 4:28
送出感谢: 0
接收感谢: 0

#4

帖子 desper » 2006-10-03 18:40

...主要是有点不方便刻盘啊。
再来一个问题,那么我的(hd0,2)就是/dev/hda3吗?
:roll:
头像
gnix_oag
帖子: 1994
注册时间: 2005-05-19 18:38
来自: 湖南永州
送出感谢: 0
接收感谢: 1 次
联系:

#5

帖子 gnix_oag » 2006-10-03 18:45

回复

回到 “老旧版本支持”