Ubuntu如何安装程序。比如RPM包

为当前最终发行版之前的所有版本提供支持
回复
jata
帖子: 14
注册时间: 2006-10-03 10:23
送出感谢: 0
接收感谢: 0

Ubuntu如何安装程序。比如RPM包

#1

帖子 jata » 2006-10-04 3:18

谢谢。我一直没有学会很苦脑

rpm -ivh 也没有用。怎么办哦。请f指教
yulewang
帖子: 154
注册时间: 2006-08-12 22:00
送出感谢: 0
接收感谢: 0

#2

帖子 yulewang » 2006-10-04 3:23

rpm是redhat等发行版使用的安装管理方式,
对于debian体系而言,使用了更为优雅的deb安装模式(事实上我最近被这种优雅折腾得够呛)
如果一定要使用rpm包,清sudo apt-get install alien以后再使用rpm包。
现在软件仓库的包够多了,没有必要使用redhat的东西(而且可能存在兼容性问题)
jata
帖子: 14
注册时间: 2006-10-03 10:23
送出感谢: 0
接收感谢: 0

#3

帖子 jata » 2006-10-04 3:32

原来这样,但我是想安装播放器呢。自带的都放不出来。好像要解码类似的东西。谢谢~
gzd900
帖子: 176
注册时间: 2005-12-14 4:37
来自: 十堰
送出感谢: 0
接收感谢: 0
联系:

#4

帖子 gzd900 » 2006-10-04 4:24

没有播放不出来的。建议你自己先在论坛上搜索你想播放的格式,如果不明白可以在这里提问,会有人回答你的提问的。
yulewang
帖子: 154
注册时间: 2006-08-12 22:00
送出感谢: 0
接收感谢: 0

#5

帖子 yulewang » 2006-10-04 5:27

I recommanded that you should use hiweed desktop final 1.0 which was based on Xubuntu instead.
It seems that you do not understand how this things worked.
After a short term you will know something about the configuration:)
头像
drivel
帖子: 1917
注册时间: 2006-07-08 9:21
来自: University of Science and Technology Beijing
送出感谢: 1 次
接收感谢: 0
联系:

#6

帖子 drivel » 2006-10-04 8:03

先安装alien,然后用alien XX.rpm将安装包转换成deb文件再安装
jata
帖子: 14
注册时间: 2006-10-03 10:23
送出感谢: 0
接收感谢: 0

#7

帖子 jata » 2006-10-04 11:09

谢谢.谢谢大家.本来还想再问的,我想,我先看一下论坛,比较好.
头像
stlxv
论坛版主
帖子: 8273
注册时间: 2006-05-03 0:39
来自: المريخ
送出感谢: 0
接收感谢: 1 次

#8

帖子 stlxv » 2006-10-04 16:56

要用什么软件就用synaptic吧,synaptica找不到再去上网找,找到了尽量不要rpm包的(要找deb包的),装rpm包之前要先装rpm:

代码: 全选

apt-get install rpm
而且安装的时候要加上--nodeps。没有这些包的话下载了根据说明安装就行了,不外乎是编译源码或者运行安装程序。
PHP是最好的语言!不服来战!
回复

回到 “老旧版本支持”