正确升级到edgy的办法

为当前最终发行版之前的所有版本提供支持
回复
头像
oneleaf
论坛管理员
帖子: 10234
注册时间: 2005-03-27 0:06
系统: Ubuntu 12.04
送出感谢: 7 次
接收感谢: 106 次

正确升级到edgy的办法

#1

帖子 oneleaf » 2006-10-04 9:35

打开终端运行:

gksu "update-manager -c -d"

选择发行版升级。

需要先安装

sudo apt-get install ubuntu-desktop

sudo apt-get install kubuntu-desktop

sudo apt-get install xubuntu-desktop
上次由 oneleaf 在 2006-10-04 10:21,总共编辑 1 次。
头像
FFFrog
帖子: 621
注册时间: 2006-05-12 23:28
来自: 江西乐平
送出感谢: 0
接收感谢: 1 次
联系:

#2

帖子 FFFrog » 2006-10-04 9:53

代码: 全选

Can't install 'ubuntu-desktop'

无法安装要求的软件包。请汇报这个bug。

代码: 全选

无法计算升级

在计算升级时遇到一个无法解决的问题。

请汇报这个有关 'update-manager' 的错误,并且将 /var/log/dist-upgrade/ 中的文件包含在错误报告中。
汇报版主,我用了之后仍然不行。
我的系统是已经升级到6.10了的,但每次更新时都会提示说“没有更新可供安装”,要我运行发行升级什么的。但点发行升级之后又是上面那两个错误提示。
系统中现在有几十个包,每次更新时都看到它们在那里,但复选框是灰的,无法选中。

[/code]
头像
内存不足
论坛版主
帖子: 3277
注册时间: 2005-08-18 18:43
送出感谢: 0
接收感谢: 1 次
联系:

#3

帖子 内存不足 » 2006-10-04 10:04

新立德软件包-编辑-修正(依赖关系)损坏的软件包
然后再点-标记全部软件包以便升级-应用
应该是你系统里某个包被强制限定版本,连带他的依赖关系的包不能升级。
໌→ iCookie Gtk Theme
໌→DropPlusBluetheme
กรัก กรัก`菠萝
头像
FFFrog
帖子: 621
注册时间: 2006-05-12 23:28
来自: 江西乐平
送出感谢: 0
接收感谢: 1 次
联系:

#4

帖子 FFFrog » 2006-10-04 14:19

找你说的方法做之后,“应用”按钮是灰色的,无法点击。

现在每次升级时都有30个包保持不变……
头像
FFFrog
帖子: 621
注册时间: 2006-05-12 23:28
来自: 江西乐平
送出感谢: 0
接收感谢: 1 次
联系:

似乎可以解决了……

#5

帖子 FFFrog » 2006-10-04 14:29

代码: 全选

shiwl@ShiWL-TC4200:~$ sudo apt-get upgrade
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
Reading state information... 完成
下列的软件包的版本将保持不变:
  gnome-utils hpijs libggi2 mplayer python-adns python-clientcookie python-crypto python-gadfly python-htmlgen
  python-htmltmpl python-imaging python-imaging-sane python-jabber python-kde3 python-kjbuckets python-ldap python-mysqldb
  python-pam python-pexpect python-pgsql python-pylibacl python-pyopenssl python-pyxattr python-qt3 python-reportlab
  python-simpletal python-soappy python-sqlite python-syck python-xmpp
共升级了 0 个软件包,新安装了 0 个软件包,要卸载 0 个软件包,有 30 个软件未被升级。

代码: 全选

shiwl@ShiWL-TC4200:~$ sudo apt-get install gnome-utils hpijs libggi2 mplayer python-adns python-clientcookie python-crypto python-gadfly python-htmlgen python-htmltmpl python-imaging python-imaging-sane python-jabber python-kde3 python-kjbuckets python-ldap python-mysqldb python-pam python-pexpect python-pgsql python-pylibacl python-pyopenssl python-pyxattr python-qt3 python-reportlab python-simpletal python-soappy python-sqlite python-syck python-xmpp
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
Reading state information... 完成
The following packages were automatically installed and are no longer required:
  python2.4-pexpect python2.4-kjbuckets baobab python2.4-clientcookie python2.4-adns python2.4-mysqldb python2.4-pam
  python2.4-pyxattr python2.4-qt3 python2.4-htmlgen python2.4-gadfly python2.4-soappy python2.4-pyopenssl python2.4-syck
  python2.4-imaging python2.4-sqlite python2.4-sip4-qt3 libgii0 python2.4-jabber python2.4-xmpp python2.4-kde3
  python2.4-reportlab python2.4-simpletal python2.4-ldap python2.4-pylibacl python2.4-crypto libgii0-target-x
  foomatic-filters-ppds hplip-ppds python2.4-imaging-sane python2.4-pgsql python2.4-htmltmpl
Use 'apt-get autoremove' to remove them.
将会安装下列额外的软件包:
  libgii1 libgii1-target-x python-sip4
建议安装的软件包:
  hpijs-ppds hplip-doc libggi-target-emu libggi-target-monotext libggimisc2 libdvdcss mplayer-doc python-imaging-doc
  python2.3-xml python-ldap-doc pyopenssl-doc python2.3-qt3-gl python-qt3-doc libqt3-mt-mysql libqt3-mt-odbc
  libqt3-mt-psql python-reportlab-doc
推荐安装的软件包:
  libggi-target-x libggi-target python2.3-imaging
下列软件包将被【卸载】:
  baobab foomatic-filters-ppds hplip-ppds libgii0 libgii0-target-x python2.4-adns python2.4-clientcookie python2.4-crypto
  python2.4-gadfly python2.4-htmlgen python2.4-htmltmpl python2.4-imaging python2.4-imaging-sane python2.4-jabber
  python2.4-kde3 python2.4-kjbuckets python2.4-ldap python2.4-mysqldb python2.4-pam python2.4-pexpect python2.4-pgsql
  python2.4-pylibacl python2.4-pyopenssl python2.4-pyxattr python2.4-qt3 python2.4-reportlab python2.4-simpletal
  python2.4-sip4-qt3 python2.4-soappy python2.4-sqlite python2.4-syck python2.4-xmpp
下列【新】软件包将被安装:
  libgii1 libgii1-target-x python-sip4
下列的软件包将被升级:
  gnome-utils hpijs libggi2 mplayer python-adns python-clientcookie python-crypto python-gadfly python-htmlgen
  python-htmltmpl python-imaging python-imaging-sane python-jabber python-kde3 python-kjbuckets python-ldap python-mysqldb
  python-pam python-pexpect python-pgsql python-pylibacl python-pyopenssl python-pyxattr python-qt3 python-reportlab
  python-simpletal python-soappy python-sqlite python-syck python-xmpp
共升级了 30 个软件包,新安装了 3 个软件包,要卸载 32 个软件包,有 0 个软件未被升级。
需要下载 18.0MB 的软件包。
解压缩后将会空出 25.1MB 的空间。
获取:1 http://ubuntu.cn99.com edgy/universe libggi2 1:2.2.1-4ubuntu1 [482kB]
获取:2 http://ubuntu.cn99.com edgy/universe libgii1-target-x 1:1.0.1-2 [15.9kB]
获取:3 http://ubuntu.cn99.com edgy/universe libgii1 1:1.0.1-2 [234kB]
现在正在下载中,似乎可以了…………
——————————————————————————————————————

的确解决了,现在更新程序不再出现错误提示了~ :D
mifly
帖子: 86
注册时间: 2006-09-05 20:44
来自: china
送出感谢: 0
接收感谢: 0
联系:

#6

帖子 mifly » 2006-10-07 1:29

没看到这个贴,看到wiki.ubuntu.com的升级说明,用方法二升级出了很多问题,等下试试这个方法
请问国外源跟国内的有什么区别?除了速度外
国内的更新实效性如何?我想了解下源里面的包应该不是手动更新的吧?
HadesEnduos
帖子: 193
注册时间: 2005-12-27 14:05
来自: 中国
送出感谢: 0
接收感谢: 0
联系:

#7

帖子 HadesEnduos » 2006-10-09 10:24

我是上海网通,用这个办法升级速度实在是太慢了。
看了看源文件,发现里面就是改了个源,我把Wiki里的源都加进去改成Edgy,手动sudo apt-get dist-upgrade不知道可以不可以,正在实验中。
..::Outstanding people always stand out::..

AMD Athlon(tm) 64 Processor 3200+
Kinston DDR400 512MB SS * 2
ASUS A8V Deluxe Wireless Edition - VIA K8T800PRO
Dataland AIW 9800SE - ATI Technologies Inc R350 AH [Radeon 9800]
头像
Jeff-cao
帖子: 370
注册时间: 2006-01-02 0:12
送出感谢: 0
接收感谢: 0

#8

帖子 Jeff-cao » 2006-10-19 12:08

代码: 全选

无法计算升级

在计算升级时遇到一个无法解决的问题。

请汇报这个有关 'update-manager' 的错误,并且将 /var/log/dist-upgrade/ 中的文件包含在错误报告中。
我也遇到这个问题,不知道该怎么办阿?版主大人现一下身吧。
potteryhy
帖子: 5
注册时间: 2006-06-10 2:46
送出感谢: 0
接收感谢: 0

#9

帖子 potteryhy » 2006-10-19 13:15

sudo aptitude dist-upgrade
头像
Jeff-cao
帖子: 370
注册时间: 2006-01-02 0:12
送出感谢: 0
接收感谢: 0

#10

帖子 Jeff-cao » 2006-10-20 10:35

Jeff-cao 写了:

代码: 全选

无法计算升级

在计算升级时遇到一个无法解决的问题。

请汇报这个有关 'update-manager' 的错误,并且将 /var/log/dist-upgrade/ 中的文件包含在错误报告中。
还是这个问题阿。哪位大哥帮帮忙?先谢谢了。
lvscar
帖子: 59
注册时间: 2005-08-21 0:41
来自: 北京
送出感谢: 0
接收感谢: 0
联系:

#11

帖子 lvscar » 2006-10-21 11:59

提醒一下:

遇到同一个文件在两个包内存在的情况。
需要用
dpkg --force-overwrite --install sth.deb
搞定。


升级前最好先把grub 启动列表里的
root 参数记下来。

我这里升级后,grub启动root 参数被识别错误。 根分区也采用了新的UUID 标记法。但用老的/dev/hd* 替换还是可以的。
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#12

帖子 eexpress » 2006-10-21 18:00

使用cn99的源,升级edgy。全部都下载完了。包括upstar的那2个。

sudo aptitude dist-upgrade
.........
.........
.........
正在编辑扩展状态信息... 完成
正在从软件包中解出模板:100%
正在预设定软件包 ...
(正在读取数据库 ... 系统当前总共安装有 127128 个文件和目录。)
正预备替换 x11-common 7.0.0-0ubuntu45 (使用 .../x11-common_1%3a7.1.1ubuntu5_i386.deb) ...
正在解压缩将用于更替的包文件 x11-common ...
dpkg:处理 /var/cache/apt/archives/x11-common_1%3a7.1.1ubuntu5_i386.deb (--unpack)时出错:
正试图覆盖“/usr/share/man/man5/Xsession.5.gz”,它属于软件包 xinit
dpkg-deb: 子进程 paste 被信号(Broken pipe)终止了
在处理时有错误发生:
/var/cache/apt/archives/x11-common_1%3a7.1.1ubuntu5_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
软件包安装失败。正在试图恢复:
dpkg:依赖关系问题使得 xutils-dev 的配置工作不能继续:
xutils-dev 依赖于 x11-common (>= 1:7.0.0);然而:
系统里的 x11-common 的版本是 7.0.0-0ubuntu45.
dpkg:处理 xutils-dev (--configure)时出错:
依赖关系问题 - 仍未被配置
dpkg:依赖关系问题使得 xutils 的配置工作不能继续:
xutils 依赖于 xutils-dev;然而:
软件包 xutils-dev还没有被配置。
dpkg:处理 xutils (--configure)时出错:
依赖关系问题 - 仍未被配置
在处理时有错误发生:
xutils-dev
xutils
● 鸣学
linuxp
帖子: 43
注册时间: 2006-02-28 8:57
送出感谢: 0
接收感谢: 0

#13

帖子 linuxp » 2006-10-22 20:46

我郁闷死了。告诉我需要23天的时间下载升级文件。
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#14

帖子 eexpress » 2006-10-22 22:33

linuxp 写了:我郁闷死了。告诉我需要23天的时间下载升级文件。
是先改源到edgy,下载了包,再按照1楼的办法搞。
● 鸣学
头像
Mr.T
帖子: 126
注册时间: 2006-07-22 14:41
来自: 火星
送出感谢: 0
接收感谢: 0
联系:

#15

帖子 Mr.T » 2006-10-23 23:08

HadesEnduos 写了:我是上海网通,用这个办法升级速度实在是太慢了。
看了看源文件,发现里面就是改了个源,我把Wiki里的源都加进去改成Edgy,手动sudo apt-get dist-upgrade不知道可以不可以,正在实验中。
这方法我试了3次.
3次的结果都一样.
无法启动x-window :cry:
回复

回到 “老旧版本支持”