[问题]在安装deb软件是出现问题。

为当前最终发行版之前的所有版本提供支持
回复
meladet
帖子: 18
注册时间: 2006-08-27 19:32
送出感谢: 0
接收感谢: 0
联系:

[问题]在安装deb软件是出现问题。

#1

帖子 meladet » 2006-10-07 12:43

安装一个deb软件是。没能安装成功。现在重新安装也不行,想把它卸载了系统也提示最好重新安装,可是装不上。
apt 源也不能用了。要怎么办。
头像
zhan
帖子: 1880
注册时间: 2005-08-15 0:04
来自: 南7技校
送出感谢: 0
接收感谢: 0
联系:

#2

帖子 zhan » 2006-10-07 13:56

怎么安装的,出现什么问题?
请楼主描述清楚
要删除的话 sudo apt-get --purge remove packages
或者 sudo dpkg --purge packages
packages 是安装的那个包的名字
飞得高,飞得低,学习再学习,多少大秘密!
http://zhan.blog.ubuntu.org.cn
meladet
帖子: 18
注册时间: 2006-08-27 19:32
送出感谢: 0
接收感谢: 0
联系:

#3

帖子 meladet » 2006-10-07 16:52

安装的是 jedit.deb 用 dpkg -i jedit.deb安装的 ,安装是出现这样的 错误提示 :
选中了曾被取消选择的软件包 jedit。
(正在读取数据库 ...
dpkg:严重警告:无法找到软件包“jedit”的文件名列表文件,现假定该软件包目前没有任 何文件被安装在系统里。
系统当前总共安装有 141347 个文件和目录。)
正预备替换 jedit 4:04.03.06.00 (使用 jedit.deb) ...
正在解压缩将用于更替的包文件 jedit ...
dpkg:处理 jedit.deb (--install)时出错:
无法创建“./usr/share/doc/jEdit/Apache.LICENSE.txt”: No such file or directory
dpkg (子进程):无法执行新的 post-removal script: No such file or directory
dpkg: 作下列清理工作时发生错误:
子进程·post-removal script·返回了错误号·2
dpkg-deb: 子进程 paste 被信号(Broken pipe)终止了
在处理时有错误发生:
jedit.deb

然后想删除是提示:
sudo dpkg --purge jedit
Password:
dpkg:处理 jedit (--purge)时出错:
该软件包现在的状态极为不妥 - 您最好能
在删除它之前再重新安装一次。
在处理时有错误发生:
jedit
头像
Junalbert
帖子: 20
注册时间: 2006-05-21 11:33
来自: 上海
送出感谢: 0
接收感谢: 0

#4

帖子 Junalbert » 2006-10-07 18:34

先试试2楼的办法,如果不行的话试试 手工删除:

1. whereis <package name>
找到路径后,删除对应的文件

2. rm /var/cache/apt/achive/下的<package name>相关deb

3. rm /var/lib/dpkg/info下的<package name>相关文件
2、3两步注意不要把其他包的文件删了

4. sudo dpkg -r --force-remove-reinstreq <package name>
sudo dpkg --purge <package name>
之前是不能删的,现在会给你一个warning

5.sudo apt-get update
meladet
帖子: 18
注册时间: 2006-08-27 19:32
送出感谢: 0
接收感谢: 0
联系:

#5

帖子 meladet » 2006-10-08 11:59

楼上两位兄弟的 方法都试过了还是不行, 在 /var/lib/dpkg/info /var/cache/apt/archive 中都没有jedit相关的文件。 在系统文件中查找发现根本就没有装上 jedit ,与其相 关的文件就只有两个图标文件,按你们提供的删除方法都还是一样的提示:
dpkg:处理 jedit (--purge)时出错:
该软件包现在的状态极为不妥 - 您最好能
在删除它之前再重新安装一次。
在处理时有错误发生:
jedit

真不知道怎么办。 不会要从装才能解决吧 。
回复

回到 “老旧版本支持”