新立得安装更新出现的问题,强制安装不能修复,急盼高手指点,在线等!

为当前最终发行版之前的所有版本提供支持
回复
bianshaoxin
帖子: 5
注册时间: 2006-10-06 17:09
送出感谢: 0
接收感谢: 0

新立得安装更新出现的问题,强制安装不能修复,急盼高手指点,在线等!

#1

帖子 bianshaoxin » 2006-10-07 19:10

我装的系统是amd64版本,新立得自动检测到更新,然后下载安装,在下载前提示有未通过认证的软件,但我还是安装了,最后导致新立得总是发现错误,重新打开新立得时,总是提示有13个软件包依赖关系错误。在编辑菜单里,执行“修复依赖关系”,提示修复成功,然后执行“实施标记更新”,但是提示无法完成。最后在终端执行强制安装,也不能修复成功,终端执行过程如下。急盼高手指点!!


bianshaoxin@bianshaoxin:~$ sudo apt-get -f install
Password:
正在读取软件包列表... 完成
正在分析软件包的依赖关系树... 完成
正在更正依赖关系... 完成
将会安装下列额外的软件包:
openoffice.org-common openoffice.org-core openoffice.org-impress
下列【新】软件包将被安装:
openoffice.org-core
下列的软件包将被升级:
openoffice.org-common openoffice.org-impress
共升级了 2 个软件包,新安装了 1 个软件包,要卸载 0 个软件包,有 4 个软件未被升级 。
有 11 个软件包没有被完全安装或卸载。
需要下载 0B/55.7MB 的软件包。
解压缩后会消耗掉 81.1MB 的额外空间。
您希望继续执行吗?[Y/n]y
(正在读取数据库 ... 系统当前总共安装有 76371 个文件和目录。)
正预备替换 openoffice.org-impress 2.0.2-2ubuntu12.1-1 (使用 .../openoffice.org-i mpress_2.0.3-6dapper1-1_amd64.deb) ...
正在解压缩将用于更替的包文件 openoffice.org-impress ...
dpkg:处理 /var/cache/apt/archives/openoffice.org-impress_2.0.3-6dapper1-1_amd64 .deb (--unpack)时出错:
正试图覆盖“/usr/lib/openoffice/share/registry/modules/org/openoffice/TypeDetect ion/Filter/fcfg_impressgraphics_filters.xcu”,它属于软件包 openoffice.org-common
dpkg:关于含有 openoffice.org-common 的 .../openoffice.org-common_2.0.3-6dapper3 _all.deb:
openoffice.org-common 冲突于 openoffice.org-impress (<< 2.0.3)
openoffice.org-impress (版本为 2.0.2-2ubuntu12.1-1)现在 已安装完毕。
dpkg:处理 /var/cache/apt/archives/openoffice.org-common_2.0.3-6dapper3_all.deb (--unpack)时出错:
软件包相互冲突 - 将不安装 openoffice.org-common
dpkg:关于含有 openoffice.org-core 的 .../openoffice.org-core_2.0.3-6dapper1-1_a md64.deb:
openoffice.org-core 冲突于 openoffice.org-impress (<< 2.0.3)
openoffice.org-impress (版本为 2.0.2-2ubuntu12.1-1)现在 已安装完毕。
dpkg:处理 /var/cache/apt/archives/openoffice.org-core_2.0.3-6dapper1-1_amd64.de b (--unpack)时出错:
软件包相互冲突 - 将不安装 openoffice.org-core
在处理时有错误发生:
/var/cache/apt/archives/openoffice.org-impress_2.0.3-6dapper1-1_amd64.deb
/var/cache/apt/archives/openoffice.org-common_2.0.3-6dapper3_all.deb
/var/cache/apt/archives/openoffice.org-core_2.0.3-6dapper1-1_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
bianshaoxin
帖子: 5
注册时间: 2006-10-06 17:09
送出感谢: 0
接收感谢: 0

#2

帖子 bianshaoxin » 2006-10-07 19:17

难道没有人知道吗?
aBiNg
帖子: 1331
注册时间: 2006-07-09 12:22
来自: 南京
送出感谢: 0
接收感谢: 2 次

#3

帖子 aBiNg » 2006-10-07 19:17

$sudo apt-get remove openoffice.org-common
如果不能删除,可试着用新得利解决依赖关系问题.
基本思路是:依赖什么就去装什么,与什么冲突就删除什么,可能需要层层安装和删除,除非有伤系统稳定的...
bianshaoxin
帖子: 5
注册时间: 2006-10-06 17:09
送出感谢: 0
接收感谢: 0

#4

帖子 bianshaoxin » 2006-10-07 19:29

能不能说具体点,我应该删除那些软件?怎么删除?
Charles.T
帖子: 88
注册时间: 2006-09-20 21:38
送出感谢: 0
接收感谢: 0
联系:

#5

帖子 Charles.T » 2006-10-07 21:01

试试dpkg -P openoffice.org-common
头像
nobrain
帖子: 808
注册时间: 2005-08-25 13:58
来自: ustc
送出感谢: 0
接收感谢: 0
联系:

#6

帖子 nobrain » 2006-10-07 21:21

dpkg 有个--ignore-depends=package_name,忽略package_name的依赖关系。
dpkg -P --ignore-depends=package_name package_name来删package_name包。
爱喝真猪奶茶的夜鸣猪
回复

回到 “老旧版本支持”