求助,无法安装Mplayer

为当前最终发行版之前的所有版本提供支持
回复
浪漫萤火虫
帖子: 9
注册时间: 2006-10-08 0:28
送出感谢: 0
接收感谢: 0

求助,无法安装Mplayer

#1

帖子 浪漫萤火虫 » 2006-10-08 13:12

新手求助,安装MPlayer时,用了./configure之后,出现
Detected operating system: Linux
Detected host architecture: i386
Checking for gcc version ... not found
Checking for gcc-3.1 version ... not found
Checking for gcc3 version ... not found
Checking for gcc-3.0 version ... not found
Checking for cc version ... not found

*** Please downgrade/upgrade C compiler to version gcc-2.95.x or gcc-3.x! ***

You are not using a supported compiler. We do not have the time to make sure
everything works with compilers other than the ones we use. Use either the
same compiler as we do, or use --disable-gcc-checking but DO *NOT* REPORT BUGS
unless you can reproduce them after recompiling with a 2.95.x or 3.x version!

Note for gcc 2.96 users: Some versions of this compiler are known to miscompilemplayer and lame (which is used for mencoder). If you get compile errors,
first upgrade to the latest 2.96 release (minimum 2.96-85) and try again.
If the problem still exists, try with gcc 3.x (or 2.95.x) *BEFORE* reporting
bugs!

GCC 2.96 IS NOT AND WILL NOT BE SUPPORTED BY US !

*** For details please read DOCS/users_against_developers.html ***


Error: Bad gcc version

Check "configure.log" if you do not understand why it failed.
该怎么处理啊?就没办法安装 感觉好像是缺少安装必须的什么东西吧 但是不知道怎么处理 请各位高手帮忙
aBiNg
帖子: 1331
注册时间: 2006-07-09 12:22
来自: 南京
送出感谢: 0
接收感谢: 2 次

#2

帖子 aBiNg » 2006-10-08 13:44

先查看一下你的gcc版本:
$gcc -v

不够的话再升级:
$sudo apt-get update
$sudo apt-get install gcc
fmying
帖子: 71
注册时间: 2006-10-05 8:16
来自: 福建 厦门
送出感谢: 0
接收感谢: 0
联系:

#3

帖子 fmying » 2006-10-08 14:58

apt-get install gcc-3.4
或者
apt-get install gcc-3.3

然后 ./configure --cc=gcc-3.3(gcc-3.4)
MPlayer编译需要使用3.x 的 gcc
上善若水
回复

回到 “老旧版本支持”