[原创]解决libc6升级失败的方法

为当前最终发行版之前的所有版本提供支持
回复
aBiNg
帖子: 1331
注册时间: 2006-07-09 12:22
来自: 南京
送出感谢: 0
接收感谢: 2 次

[原创]解决libc6升级失败的方法

#1

帖子 aBiNg » 2006-10-09 14:22

申明:本帖只是此帖:Debugging Dpkg Problems的一个简化.

问题描述:

代码: 全选

$sudo apt-get update
$sudo dpkg -i /var/cache/apt/archives/libc6_2.4-1ubuntu10_i386.deb
>Preparing to replace libc6 2.4-1ubuntu6 (using .../libc6_2.4-1ubuntu10_i386.deb) ...
>Matching libraries: /usr/lib/libpthread.so.20 /lib/ld-linux.so.2
>A copy of glibc was found in an unexpected directory.
>...
>dpkg: error processing /var/cache/apt/archives/libc6_2.4-1ubuntu10_i386.deb (--install)...
解决简化:
//据引用帖知,问题与libpthread包有关联
1.查看libpthread:

代码: 全选

$sudo dpkg -l | grep libpthread
>ii libpthread20 2.0.7-2ubuntu2 The GNU Portable Threads (pthread emulation)
2.卸载libpthread:

代码: 全选

$sudo apt-get remove --purge libpthread
//若能顺利删除则可执行(然后第4步):

代码: 全选

$sudo apt-get update && sudo apt-get dist-upgrade
//若不能卸载libpthread,则须进行下一步

3.手动mv掉libpthread,然后再尝试升级:

代码: 全选

$sudo mkdir /usr/lib/temp
$sudo mv /usr/lib/libpthread* /usr/lib/temp/
$sudo apt-get update && sudo apt-get dist-upgrade
4.最后得将libpthread复原,否则系统会出问题:

代码: 全选

$sudo mv /usr/lib/libpthread* /usr/lib/
$sudo rm -r /usr/lib/temp
回复

回到 “老旧版本支持”