gcc安装不了,n天了,n次了,郁闷阿!请教各位了!

为当前最终发行版之前的所有版本提供支持
回复
snowy
帖子: 1
注册时间: 2006-10-13 10:14
送出感谢: 0
接收感谢: 0

gcc安装不了,n天了,n次了,郁闷阿!请教各位了!

#1

帖子 snowy » 2006-10-13 10:22

root@snowy:/home/snowy# sudo apt-get install build-essential
E: 无法获得锁 /var/lib/dpkg/lock - open (11 Resource temporarily unavailable)
E: Unable to lock the administration directory (/var/lib/dpkg/), is another proc ess using it?
root@snowy:/home/snowy# sudo apt-get install build-essential
正在读取软件包列表... 完成
正在分析软件包的依赖关系树... 完成
您可能需要运行“apt-get -f install”来纠正下列错误:
下列的软件包有不能满足的依赖关系:
build-essential: 依赖: libc6-dev 但是它将不会被安装 或
libc-dev
依赖: gcc (>= 4:4.0) 但是它将不会被安装
依赖: g++ (>= 4:4.0) 但是它将不会被安装
依赖: make 但是它将不会被安装
依赖: dpkg-dev (>= 1.13.5) 但是它将不会被安装
openoffice.org-gtk: 依赖: openoffice.org-core (> 2.0.3) 但是 2.0.2-2ubuntu12-1 正要被安装
openoffice.org-writer: 依赖: openoffice.org-core (> 2.0.3) 但是 2.0.2-2ubuntu1 2-1 正要被安装
E: 有未能满足的依赖关系。

用新立得也装不了。郁闷阿。 :(
头像
zhuqin_83
帖子: 10606
注册时间: 2006-05-13 4:02
送出感谢: 0
接收感谢: 7 次
联系:

#2

帖子 zhuqin_83 » 2006-10-13 10:37

你是不是一边开着新立得一边用apt-get 阿?
HP Pavilion DV6-2064CA: AMD Turion II Ultra Dual-Core Mobile M640, HD4650, 2GBx2 DDR2-800, Seagate 500GB 7200RPM SATA, BD-ROM
DELL UltraSharp 2209WA
Arch64, Testing repo
头像
goldfox_79
帖子: 1937
注册时间: 2005-10-16 8:26
来自: 地球
送出感谢: 0
接收感谢: 1 次
联系:

#3

帖子 goldfox_79 » 2006-10-13 10:48

zhuqin_83 写了:你是不是一边开着新立得一边用apt-get 阿?
他调用了两次sudo apt-get install build-essential

第一次是apt和新利得冲突,问题出在第二次调用
头像
zhuqin_83
帖子: 10606
注册时间: 2006-05-13 4:02
送出感谢: 0
接收感谢: 7 次
联系:

#4

帖子 zhuqin_83 » 2006-10-13 12:05

换个源吧。
附件
dzh.jpg
HP Pavilion DV6-2064CA: AMD Turion II Ultra Dual-Core Mobile M640, HD4650, 2GBx2 DDR2-800, Seagate 500GB 7200RPM SATA, BD-ROM
DELL UltraSharp 2209WA
Arch64, Testing repo
头像
fiftymetre
帖子: 37
注册时间: 2006-09-29 15:06
送出感谢: 0
接收感谢: 0
联系:

#5

帖子 fiftymetre » 2006-10-13 16:43

首先,你把新立得关闭了。在终端里先输入sudo apt-get install build-essential 如果出现了。

root@snowy:/home/snowy# sudo apt-get install build-essential
正在读取软件包列表... 完成
正在分析软件包的依赖关系树... 完成
您可能需要运行“apt-get -f install”来纠正下列错误:


------------------------
这样的错误你就把命令改成sudo apt-get -f install build-essential 这样来试试看吧。呵呵 :)
咆哮女郎的淘宝小店:http://shop33443787.taobao.com/
头像
internet
帖子: 11
注册时间: 2006-09-12 16:24
送出感谢: 0
接收感谢: 0
联系:

#6

帖子 internet » 2006-10-19 13:04

fiftymetre 写了:首先,你把新立得关闭了。在终端里先输入sudo apt-get install build-essential 如果出现了。

root@snowy:/home/snowy# sudo apt-get install build-essential
正在读取软件包列表... 完成
正在分析软件包的依赖关系树... 完成
您可能需要运行“apt-get -f install”来纠正下列错误:


------------------------
这样的错误你就把命令改成sudo apt-get -f install build-essential 这样来试试看吧。呵呵 :)
还是装不了
头像
SuperWar3Fan
帖子: 1263
注册时间: 2006-05-20 6:25
来自: 山东淄博
送出感谢: 0
接收感谢: 0
联系:

#7

帖子 SuperWar3Fan » 2006-10-19 15:48

尝试一下:
sudo aptitude install build-essential
头像
dogfox
论坛版主
帖子: 5309
注册时间: 2006-09-02 14:18
来自: 汉桑城
送出感谢: 1 次
接收感谢: 1 次
联系:

#8

帖子 dogfox » 2006-10-19 19:38

把系统盘插入光驱调用包管理装
回复

回到 “老旧版本支持”