路径中文件的问题???

为当前最终发行版之前的所有版本提供支持
回复
wyd
帖子: 19
注册时间: 2006-09-16 16:18
送出感谢: 0
接收感谢: 0

路径中文件的问题???

#1

帖子 wyd » 2006-10-15 19:39

为什么我有时候在某个网站或者教程上看的文章中的一模一样的路径下的文件在我的ubunt中不存在了? 是版本的问题吗?

例:我在一个帖子上看到这样的路径 /etc/apt/preferences,而我的unbunt中却找不到?
jimmin
论坛版主
帖子: 2138
注册时间: 2006-09-24 4:37
送出感谢: 0
接收感谢: 1 次

#2

帖子 jimmin » 2006-10-15 21:58

我也遇到过。。。。。。等答案。。。。。。。。
头像
goldfox_79
帖子: 1937
注册时间: 2005-10-16 8:26
来自: 地球
送出感谢: 0
接收感谢: 1 次
联系:

#3

帖子 goldfox_79 » 2006-10-15 22:34

/etc/apt/preferences文件是用来将用户指定的软件包限定在某个或某些特定版本上。

比如,源中gaim的版本升级到了2.0,但是我想继续使用1.5版。那么就在preferences文件中添加

Package: gaim
Pin: version 1.5*
Priority: 989

这样在执行apt-get upgrade命令时就不会把gaim升级到2.0了。

系统默认设置是把软件包升级到最新版本,因此perferences在系统安装好后是不存在的。当用户希望对某个软件包进行版本限制时请自行创建这个文件。
回复

回到 “老旧版本支持”