无法安装java!?

为当前最终发行版之前的所有版本提供支持
回复
dorice
帖子: 94
注册时间: 2006-06-22 1:52
送出感谢: 0
接收感谢: 0

无法安装java!?

#1

帖子 dorice » 2006-10-15 23:49

用sudo apt-get install sun-java5-jdk的时候,出现下面错误:
正在设置 sun-java5-bin (1.5.0-06-1) ...
Error: could not find libjava.so
Error: could not find Java 2 Runtime Environment.
dpkg:处理 sun-java5-bin (--configure)时出错:
子进程·post-installation script·返回了错误号·2
正在设置 sun-java5-demo (1.5.0-06-1) ...

正在设置 sun-java5-jdk (1.5.0-06-1) ...

在处理时有错误发生:
sun-java5-bin
E: Sub-process /usr/bin/dpkg returned an error code (1)
怎么办?
头像
qiang_liu8183
论坛版主
帖子: 10691
注册时间: 2006-09-10 22:36
来自: 北京
送出感谢: 2 次
接收感谢: 6 次

#2

帖子 qiang_liu8183 » 2006-10-16 0:36

只要你严格按照Wiki里快速设置指南的步骤做就肯定没问题,检查你的步骤吧!
看破、放下、自在、随缘、念佛
真诚、清净、平等、正觉、慈悲
头像
SuperWar3Fan
帖子: 1263
注册时间: 2006-05-20 6:25
来自: 山东淄博
送出感谢: 0
接收感谢: 0
联系:

#3

帖子 SuperWar3Fan » 2006-10-16 11:30

我的没有问题啊!
头像
qiang_liu8183
论坛版主
帖子: 10691
注册时间: 2006-09-10 22:36
来自: 北京
送出感谢: 2 次
接收感谢: 6 次

#4

帖子 qiang_liu8183 » 2006-10-16 17:17

那你就试试直接在新利得里装,不要在终端下,我以前也出现过这种问题,直接用新利得就解决了
看破、放下、自在、随缘、念佛
真诚、清净、平等、正觉、慈悲
dorice
帖子: 94
注册时间: 2006-06-22 1:52
送出感谢: 0
接收感谢: 0

#5

帖子 dorice » 2006-10-16 19:34

在新利得里也一样!我这里另外一台ubuntu也是这样!
lucker6666
帖子: 27
注册时间: 2006-10-27 10:54
送出感谢: 0
接收感谢: 0

#6

帖子 lucker6666 » 2006-11-01 8:33

我的也是啊 郁闷死
头像
stlxv
论坛版主
帖子: 8274
注册时间: 2006-05-03 0:39
来自: المريخ
送出感谢: 0
接收感谢: 1 次

#7

帖子 stlxv » 2006-11-01 9:30

到sun的网站下载吧
PHP是最好的语言!不服来战!
silon212
帖子: 16
注册时间: 2006-11-01 8:41
送出感谢: 0
接收感谢: 0
联系:

#8

帖子 silon212 » 2006-11-01 9:50

你既然选择了商业的jdk包 sun-java5-jdk,没有选择gnu的jdk包(好想叫 gij )
就去 java.sun.com 下载吧。到今天为止(2006-11-1),sun 的 j2se 级jdk的版本是JDK 5.0 Update 9。
我就在自己的ubuntu上把gij卸了,装的这个,上面可以跑lumaQQ :-)
而且使用sun.com的bin版安装程序,不会向/bin,usr/bin,/usr/share,/usr/lib下分开拷一大堆东西,只会解压到本地一个目录下,之后想把这个文件夹放那里都可以,不过这样的话不要忘了在~/.bashrc中添加更改PATH,CLASSPATH环境变量。
luo.ze.neptune
帖子: 28
注册时间: 2006-11-10 16:44
送出感谢: 0
接收感谢: 0

解决办法

#9

帖子 luo.ze.neptune » 2006-11-19 13:49

大家好,我也出了这个问题,在论坛上找了一段时间的解决办法,发现出这个问题的基本上都是用LiveCD或者是采用论坛上gnix_oag兄提供的在硬盘上直接引导LiveCD ISO+unionfs保存设置的方法来运行ubuntu。后来论坛上另一哥们也怀疑是unionfs的问题,他说他自己试了一下,将JDK安装在非unionfs的文件系统(FAT32或ext2或ext3)中,就没有问题了。我自己尝试了一下,确实能够解决这个问题。以下是我的步骤:
1、下载JDK,直接到sun的网站下载(注意下载Linux self-extracting file版本的那个,文件名是jdk-1_5_0_09-linux-i586.bin)
2、将下载到的JDK移动到非unionfs的文件系统上,例如我的windows的E盘是FAT32的,我将下载的JDK拷贝到E盘(假设下载JDK的目录是/tmp,那么执行命令sudo cp /tmp/jdk-1_5_0_09-linux-i586.bin /media/e_win,这里/media/e_win是我windows E盘的路径)
3、在E盘下执行这个JDK(如果不能执行,可能要给jdk-1_5_0_09-linux-i586.bin加上x),执行下面两个命令:(1)sudo cd /media/e_win;(2)sudo ./jdk-1_5_0_09-linux-i586.bin;这将会把该JDK在当前目录下展开到jdk1.5.0_09目录下。
4、到解压出来的JDK的bin目录下,执行以下./java,怎么样,发现直接就可以执行了吧。
5、然后执行sudo update-alternatives --verbose --install /usr/bin/java java /media/e_win/jdk1.5.0_09/bin/java 500 --slave /usr/share/man/man1/java.1 java.1 /media/e_win/jdk1.5.0_09/man/man1/java.1(注意,这里/media/e_win/jdk1.5.0_09是我自己的路径,你可能需要根据自己的路径进行修改)
6、然后执行sudo update-alternatives --config java,选择我们安装的java。执行java -version,怎么样,没问题了吧。
7、设置环境变量JAVA_HOME,CLASSPATH等。ok

总结:出现这个问题可能是unionfs的问题,我也只是猜测,因为对unionfs本身没有什么太多了解。
回复

回到 “老旧版本支持”