who can help me?

为当前最终发行版之前的所有版本提供支持
回复
头像
feizhoulaobo
帖子: 40
注册时间: 2006-02-25 17:12
来自: ShangHai.China
送出感谢: 0
接收感谢: 0
联系:

who can help me?

#1

帖子 feizhoulaobo » 2006-10-17 15:11

what's matter?
E: dpkg was interrupted, you must manually run 'dpkg --configure -a' to correct the problem.

Then I put into 'dpkg --configure -a' it print :'dpkg: requested operation requires superuser privilege'


please help me!

代码: 全选

coke@coke-laptop:~$ uname -a
Linux coke-laptop 2.6.28-15-generic #49-Ubuntu SMP Tue Aug 18 18:40:08 UTC 2009 i686 GNU/Linux
头像
goldfox_79
帖子: 1937
注册时间: 2005-10-16 8:26
来自: 地球
送出感谢: 0
接收感谢: 1 次
联系:

#2

帖子 goldfox_79 » 2006-10-17 19:49

运行dpkg这样的命令需要root权限,所以请输入

sudo dpkg
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#3

帖子 eexpress » 2006-10-17 20:17

从新利得里面进去,在左下角选择破损的包,彻底删除。应该可以修复。
sudo dpkg --configure -a也可以试试。

如果还不行,估计需要重装apt-get。或者把/var/cache/apt下面的全部删除,再sudo dpkg-reconfigure all
● 鸣学
回复

回到 “老旧版本支持”