edgy 编译安装beryl最新的svn版本

为当前最终发行版之前的所有版本提供支持
回复
头像
karron
帖子: 6226
注册时间: 2005-06-11 14:03
来自: 不明真相的群众
送出感谢: 0
接收感谢: 0
联系:

edgy 编译安装beryl最新的svn版本

#1

帖子 karron » 2006-10-19 8:49

今天感觉之前的beryl有点不爽了,已经很久没有升级了,于是想编译最新的svn的试试。安装之后发现确实有大的改变,起码设置界面是中文的了,不怕看不懂了。也增加不少特效。推荐试用。

这里我假定大家的环境已经可以运行beryl了,如果还不知道怎么安装的话,可以参考我的这篇文章

我也假定大家机器上有基本的编译环境。如果不知道怎么安装这些,我建议不要自己编译,直接用上面的连接安装已经发布的版本。

在你的源里面添加如下源:

代码: 全选

deb http://www.beerorkid.com/compiz edgy main-edgy
deb http://media.blutkind.org/xgl/ edgy main-edgy
deb http://compiz-mirror.lupine.me.uk/ edgy main-edgy
deb http://ubuntu.compiz.net/ edgy main-edgy

deb-src http://www.beerorkid.com/compiz edgy main-edgy
deb-src http://media.blutkind.org/xgl/ edgy main-edgy
deb-src http://compiz-mirror.lupine.me.uk/ edgy main-edgy
deb-src http://ubuntu.compiz.net/ edgy main-edgy

然后照例 sudo apt-get update & sudo apt-get dist-upgrade

获取最新的源代码:

svn co http://svn.beryl-project.org/trunk beryl

cd beryl

然后 分别 sudo apt-get build-dep 每个目录名 。安装依赖库.

再执行以下语句

代码: 全选

sudo apt-get build-dep compiz
sudo apt-get install fakeroot automake1.9
sudo update-alternatives --config automake
sudo apt-get install libtool
sudo apt-get install librsvg2-dev
sudo apt-get install libglitz-glx1-dev libglitz1-dev
sudo apt-get install libneon25-dev libapr0-dev libsvn0-dev
完成之后就可以开始编译了。
编译的方法是

代码: 全选

./makeall

注意这条命令会自动编译所有的包以及自动安装。如果出现什么问题,一般是有相应的包没有安装,自己apt-get安装即可。

等一切ok之后,建议重启机器。特别是你目前已经开启了beryl的时候。以防万一,建议重启。我开始只是注销了一下,结果登录系统后发现控制台都很难打开。重启之后一切ok。

重启之后运行 beryl-manager,启动之后会最小化到托盘,你可以选择设置器或者theme进行配置。默认的最小化,最大化的特效实在是太惊人了。
我的blog,关于技术,软件,linux,vim <---- 所有博客均被河蟹.
aBiNg
帖子: 1331
注册时间: 2006-07-09 12:22
来自: 南京
送出感谢: 0
接收感谢: 2 次

#2

帖子 aBiNg » 2006-10-19 10:21

好帖!

顺便问:beryl设置管理器的中文包是?
头像
zhuqin_83
帖子: 10606
注册时间: 2006-05-13 4:02
送出感谢: 0
接收感谢: 7 次
联系:

#3

帖子 zhuqin_83 » 2006-10-20 4:51

k太强悍了阿。留名便查。
HP Pavilion DV6-2064CA: AMD Turion II Ultra Dual-Core Mobile M640, HD4650, 2GBx2 DDR2-800, Seagate 500GB 7200RPM SATA, BD-ROM
DELL UltraSharp 2209WA
Arch64, Testing repo
回复

回到 “老旧版本支持”