chm安装问题,请帮忙!谢谢!

为当前最终发行版之前的所有版本提供支持
回复
littleUbuntu
帖子: 1103
注册时间: 2006-10-19 9:02
送出感谢: 0
接收感谢: 0

chm安装问题,请帮忙!谢谢!

#1

帖子 littleUbuntu » 2006-10-19 9:11

我用新立得安装的chmsee但是安装后不能运行,出现以下提示,请问怎么解决,谢谢!
$ chmsee
chmsee: error while loading shared libraries: libgnutls.so.11: cannot open shared object file: No such file or directory
头像
goldfox_79
帖子: 1937
注册时间: 2005-10-16 8:26
来自: 地球
送出感谢: 0
接收感谢: 1 次
联系:

#2

帖子 goldfox_79 » 2006-10-19 9:15

打开终端,输入下面两行命令

$cd /usr/lib

$ls libgnutls*

看输出结果是什么
littleUbuntu
帖子: 1103
注册时间: 2006-10-19 9:02
送出感谢: 0
接收感谢: 0

如下

#3

帖子 littleUbuntu » 2006-10-19 9:21

libgnutls-extra.so.12
libgnutls-extra.so.12.3.6
libgnutls-openssl.so.12
libgnutls-openssl.so.12.3.6
libgnutls.so.12
libgnutls.so.12.3.6
头像
goldfox_79
帖子: 1937
注册时间: 2005-10-16 8:26
来自: 地球
送出感谢: 0
接收感谢: 1 次
联系:

Re: 如下

#4

帖子 goldfox_79 » 2006-10-19 9:27

littleUbuntu 写了:libgnutls-extra.so.12
libgnutls-extra.so.12.3.6
libgnutls-openssl.so.12
libgnutls-openssl.so.12.3.6
libgnutls.so.12
libgnutls.so.12.3.6
chm要求使用lignutls.so.11的库,但是新系统里面这个库升级到12了。名字一变chm就说找不到库了

我们可以假造一个11的库来蒙骗chm,在终端中输入命令

$sudo ln libgnutls.so.12 libgnutls.so.11

创建一个指向12的链接,文件名取成11的就OK了
上次由 goldfox_79 在 2006-10-19 9:37,总共编辑 2 次。
littleUbuntu
帖子: 1103
注册时间: 2006-10-19 9:02
送出感谢: 0
接收感谢: 0

Re: 如下

#5

帖子 littleUbuntu » 2006-10-19 9:36

goldfox_79 写了:
littleUbuntu 写了:libgnutls-extra.so.12
libgnutls-extra.so.12.3.6
libgnutls-openssl.so.12
libgnutls-openssl.so.12.3.6
libgnutls.so.12
libgnutls.so.12.3.6
chm要求使用lignutls.so.11的库,但是新系统里面这个库升级到12了,所以找不到

我们可以假造一个11的库来蒙骗chm,在终端中输入命令

$sudo ln libgnutls.so.12 libgnutls.so.11

创建一个指向12的链接,文件名取成11的就OK了
3q very much,我试试!
littleUbuntu
帖子: 1103
注册时间: 2006-10-19 9:02
送出感谢: 0
接收感谢: 0

#6

帖子 littleUbuntu » 2006-10-19 9:37

hoho~~~~~~~~~~~~~~~~~~~~~``

搞定了,多谢了!呵呵!
头像
SuperWar3Fan
帖子: 1263
注册时间: 2006-05-20 6:25
来自: 山东淄博
送出感谢: 0
接收感谢: 0
联系:

#7

帖子 SuperWar3Fan » 2006-10-19 9:45

缺少库文件,安装以下!
回复

回到 “老旧版本支持”