[问题]软件为什么装不上啊

为当前最终发行版之前的所有版本提供支持
回复
头像
yehyun
帖子: 179
注册时间: 2006-10-11 23:29
送出感谢: 0
接收感谢: 0

[问题]软件为什么装不上啊

#1

帖子 yehyun » 2006-10-20 18:47

请问怎么在Ubuntu下安装.rpm和.tar.gz类型的软件包啊?
为何我用Make的时候说没有这个文件啊?
请帮助新手,谢谢了
dbzhang800
帖子: 3182
注册时间: 2006-03-10 15:10
来自: xi'an China
送出感谢: 0
接收感谢: 2 次
联系:

#2

帖子 dbzhang800 » 2006-10-20 19:03

没有make你就先装make

相撞 .rpm要用alien 或者rpm
头像
JangMunho
帖子: 1347
注册时间: 2006-01-18 12:55
来自: 也许真的没有人理解
送出感谢: 0
接收感谢: 1 次

#3

帖子 JangMunho » 2006-10-20 21:16

代码: 全选

sudo apt-get install gcc g++ make
sudo apt-get install alien
.tar.gz软件包安装:

代码: 全选

cd 目录所在地
sudo ./configure
sudo make
sudo make install
rpm安装:

代码: 全选

sudo alien XXXX.rpm
sudo dpkg -i XXXX.deb
MacBook Pro 15" User
Cocoa Programmer
头像
SuperWar3Fan
帖子: 1263
注册时间: 2006-05-20 6:25
来自: 山东淄博
送出感谢: 0
接收感谢: 0
联系:

#4

帖子 SuperWar3Fan » 2006-10-21 9:03

楼上的正解!
头像
stlxv
论坛版主
帖子: 8274
注册时间: 2006-05-03 0:39
来自: المريخ
送出感谢: 0
接收感谢: 1 次

#5

帖子 stlxv » 2006-10-21 10:19

JangMunho 写了:

代码: 全选

sudo apt-get install gcc g++ make
sudo apt-get install alien
.tar.gz软件包安装:

代码: 全选

cd 目录所在地
sudo ./configure
sudo make
sudo make install
rpm安装:

代码: 全选

sudo alien XXXX.rpm
sudo dpkg -i XXXX.deb

代码: 全选

apt-get install ^build
把一些常用的开发工具给安装上。

如果是.tar.gz,解压,然后看看里面的INSTALL、README或者名称类似的文件,里面会告诉你是怎么装的。./configure && make && make install不一定是对的。

rpm的安装:

代码: 全选

apt-get install rpm
装上rpm,然后再用rpm来安装。
PHP是最好的语言!不服来战!
头像
yehyun
帖子: 179
注册时间: 2006-10-11 23:29
送出感谢: 0
接收感谢: 0

#6

帖子 yehyun » 2006-10-21 12:22

谢谢楼上各位,新手入门问题太多了
plasma2006
帖子: 466
注册时间: 2006-10-19 9:17
送出感谢: 0
接收感谢: 0

#7

帖子 plasma2006 » 2006-10-21 16:06

i can not do that in this way
头像
yehyun
帖子: 179
注册时间: 2006-10-11 23:29
送出感谢: 0
接收感谢: 0

#8

帖子 yehyun » 2006-10-21 20:16

hehe,try it again
palalala
帖子: 23
注册时间: 2006-09-06 0:21
送出感谢: 0
接收感谢: 0

#9

帖子 palalala » 2006-10-26 15:48

i'll try how to install software that way.
回复

回到 “老旧版本支持”