[教学]最近看许多人还在问有关rpm软件包的安装问题。请在提问之前先进来看一下。

为当前最终发行版之前的所有版本提供支持
回复
头像
JangMunho
帖子: 1347
注册时间: 2006-01-18 12:55
来自: 也许真的没有人理解
送出感谢: 0
接收感谢: 1 次

[教学]最近看许多人还在问有关rpm软件包的安装问题。请在提问之前先进来看一下。

#1

帖子 JangMunho » 2006-10-21 19:39

Ubuntu下rpm软件包的安装:
要分以下几步:
1、安装Alien转换器,用于将rpm转成deb。
2、装换rpm包。
3、安装deb包。

分布代码说明(以下将以安装一个名为abc.rpm的包为例,例如abc.rpm被放在桌面上):

代码: 全选

sudo apt-get install alien
cd ~/Desktop/
sudo alien abc.rpm
sudo dpkg -i abc.deb
说明:
rpm在Ubuntu中的安装不能保证完美,有时甚至出现不能完成软件包转换的问题,还是建议在安装之前先寻找该软件的deb包,或者下载源码自己编译安装。
MacBook Pro 15" User
Cocoa Programmer
头像
JangMunho
帖子: 1347
注册时间: 2006-01-18 12:55
来自: 也许真的没有人理解
送出感谢: 0
接收感谢: 1 次

#2

帖子 JangMunho » 2006-10-22 17:01

无语,还在有人问,我顶上来~
MacBook Pro 15" User
Cocoa Programmer
plasma2006
帖子: 466
注册时间: 2006-10-19 9:17
送出感谢: 0
接收感谢: 0

#3

帖子 plasma2006 » 2006-10-22 18:42

thanks......................
头像
stlxv
论坛版主
帖子: 8273
注册时间: 2006-05-03 0:39
来自: المريخ
送出感谢: 0
接收感谢: 1 次

#4

帖子 stlxv » 2006-10-22 19:40

无法转换就用rpm来装就行了,装的时候加上参数--nodeps使得不检测依赖性。
rpm需要安装:

代码: 全选

apt-get install rpm
另外,既然用了debian体系的,那就用deb包就行了,一般不要用rpm包。

P.S. 装了rpm,有些rpm包直接解压也可以使用(双击然后解压就行了,最好解压在/,也就是所谓的“文件系统”)。
PHP是最好的语言!不服来战!
johninn
帖子: 14
注册时间: 2006-06-11 10:34
送出感谢: 0
接收感谢: 0
联系:

#5

帖子 johninn » 2006-10-22 22:01

说真的这个问题困惑我有一阵子了,谢谢.
头像
JangMunho
帖子: 1347
注册时间: 2006-01-18 12:55
来自: 也许真的没有人理解
送出感谢: 0
接收感谢: 1 次

#6

帖子 JangMunho » 2006-10-27 19:08

还有人在问?!
我再顶!
MacBook Pro 15" User
Cocoa Programmer
qwong
帖子: 3
注册时间: 2006-10-27 16:34
送出感谢: 0
接收感谢: 0

还是 有问题啊...................

#7

帖子 qwong » 2006-10-27 19:12

我装好了alien 在把rpm转换成deb 时出现如下问题:
root@xiaoq-desktop:/home/xiaoq# alien libccscript2_0_4-2.4.4-1mdk.i586.rpm libccscript2_0_4-2.4.4-1mdk.i586.deb
Can't exec "822-date": No such file or directory at /usr/local/share/perl/5.8.7/Alien/Package.pm line 465, <GETPERMS> line 15.
Use of uninitialized value in scalar chomp at /usr/local/share/perl/5.8.7/Alien/Package/Deb.pm line 650, <GETPERMS> line 15.
822-date did not return a valid result. You probably need to install the dpkg-dev debian package at /usr/local/share/perl/5.8.7/Alien/Package/Deb.pm line 652, <GETPERMS> line 15.


帮忙 看 下 谢谢 !!!
lucker6666
帖子: 27
注册时间: 2006-10-27 10:54
送出感谢: 0
接收感谢: 0

#8

帖子 lucker6666 » 2006-10-28 9:27

这个问题对新手很有用 谢谢
yifabanshi
帖子: 55
注册时间: 2006-10-19 22:31
送出感谢: 0
接收感谢: 0
联系:

#9

帖子 yifabanshi » 2006-10-28 9:29

请问如何编译?
头像
JangMunho
帖子: 1347
注册时间: 2006-01-18 12:55
来自: 也许真的没有人理解
送出感谢: 0
接收感谢: 1 次

#10

帖子 JangMunho » 2006-10-28 16:49

yifabanshi 写了:请问如何编译?
1、解压。
2、进入目录。
3、(1)、sudo ./configure
(2)、sudo make
(3)、sudo make install
MacBook Pro 15" User
Cocoa Programmer
alvan
帖子: 5
注册时间: 2008-08-12 23:19
送出感谢: 0
接收感谢: 0

#11

帖子 alvan » 2008-08-18 20:08

说实话,对菜鸟来说,装alien也是问题啊,sudo apt-get install alien,根本就找不到这个包,郁闷ing。我这个机器不能直接上网,必须要装好dr-com软件后才能上网,可是dr-com是rpm的,更郁闷ing!
菜鸟捣乱Y
alvan
帖子: 5
注册时间: 2008-08-12 23:19
送出感谢: 0
接收感谢: 0

Re: 还是 有问题啊...................

#12

帖子 alvan » 2008-08-18 22:02

qwong 写了:我装好了alien 在把rpm转换成deb 时出现如下问题:
root@xiaoq-desktop:/home/xiaoq# alien libccscript2_0_4-2.4.4-1mdk.i586.rpm libccscript2_0_4-2.4.4-1mdk.i586.deb
Can't exec "822-date": No such file or directory at /usr/local/share/perl/5.8.7/Alien/Package.pm line 465, <GETPERMS> line 15.
Use of uninitialized value in scalar chomp at /usr/local/share/perl/5.8.7/Alien/Package/Deb.pm line 650, <GETPERMS> line 15.
822-date did not return a valid result. You probably need to install the dpkg-dev debian package at /usr/local/share/perl/5.8.7/Alien/Package/Deb.pm line 652, <GETPERMS> line 15.


帮忙 看 下 谢谢 !!!

哎,我也是这个问题,就是不知道怎么弄!光一个命令有什么用,源文件都没有!
菜鸟捣乱Y
回复

回到 “老旧版本支持”