请各位帮帮忙 我更新系统到一半停电了,接下来如何处理?

为当前最终发行版之前的所有版本提供支持
saman
帖子: 42
注册时间: 2005-09-10 12:13
送出感谢: 0
接收感谢: 0
联系:

请各位帮帮忙 我更新系统到一半停电了,接下来如何处理?

#1

帖子 saman » 2005-09-10 12:20

我用 sudo apt-get update 更新系统到一半停电了,接下来如何处理?

saman6@saman:~$ sudo apt-get update
获取:1 http://archive.ubuntu.org.cn hoary Release.gpg [189B]
获取:2 http://archive.ubuntu.org.cn hoary-security Release.gpg [189B]
获取:3 http://archive.ubuntu.org.cn hoary-updates Release.gpg [189B]
忽略 http://archive.ubuntu.org.cn ubuntu.org.cn Release.gpg
忽略 http://archive.ubuntu.org.cn hoary-backports Release.gpg
忽略 http://archive.ubuntu.org.cn hoary-extras Release.gpg
命中 http://archive.ubuntu.org.cn hoary Release
命中 http://archive.ubuntu.org.cn hoary-security Release
命中 http://archive.ubuntu.org.cn hoary-updates Release
忽略 http://archive.ubuntu.org.cn ubuntu.org.cn Release
忽略 http://archive.ubuntu.org.cn hoary-backports Release
忽略 http://archive.ubuntu.org.cn hoary-extras Release
命中 http://archive.ubuntu.org.cn hoary/main Packages
命中 http://archive.ubuntu.org.cn hoary/restricted Packages
命中 http://archive.ubuntu.org.cn hoary/universe Packages
命中 http://archive.ubuntu.org.cn hoary/multiverse Packages
命中 http://archive.ubuntu.org.cn hoary-security/main Packages
命中 http://archive.ubuntu.org.cn hoary-security/restricted Packages
命中 http://archive.ubuntu.org.cn hoary-security/universe Packages
命中 http://archive.ubuntu.org.cn hoary-security/multiverse Packages
命中 http://archive.ubuntu.org.cn hoary-updates/main Packages
命中 http://archive.ubuntu.org.cn hoary-updates/restricted Packages
命中 http://archive.ubuntu.org.cn hoary-updates/universe Packages
命中 http://archive.ubuntu.org.cn hoary-updates/multiverse Packages
忽略 http://archive.ubuntu.org.cn ubuntu.org.cn/main Packages
忽略 http://archive.ubuntu.org.cn ubuntu.org.cn/universe Packages
忽略 http://archive.ubuntu.org.cn ubuntu.org.cn/multiverse Packages
忽略 http://archive.ubuntu.org.cn ubuntu.org.cn/restricted Packages
忽略 http://archive.ubuntu.org.cn hoary-backports/main Packages
忽略 http://archive.ubuntu.org.cn hoary-backports/universe Packages
忽略 http://archive.ubuntu.org.cn hoary-backports/multiverse Packages
忽略 http://archive.ubuntu.org.cn hoary-backports/restricted Packages
忽略 http://archive.ubuntu.org.cn hoary-extras/main Packages
忽略 http://archive.ubuntu.org.cn hoary-extras/universe Packages
忽略 http://archive.ubuntu.org.cn hoary-extras/multiverse Packages
忽略 http://archive.ubuntu.org.cn hoary-extras/restricted Packages
命中 http://archive.ubuntu.org.cn ubuntu.org.cn/main Packages
命中 http://archive.ubuntu.org.cn ubuntu.org.cn/universe Packages
命中 http://archive.ubuntu.org.cn ubuntu.org.cn/multiverse Packages
命中 http://archive.ubuntu.org.cn ubuntu.org.cn/restricted Packages
命中 http://archive.ubuntu.org.cn hoary-backports/main Packages
命中 http://archive.ubuntu.org.cn hoary-backports/universe Packages
命中 http://archive.ubuntu.org.cn hoary-backports/multiverse Packages
命中 http://archive.ubuntu.org.cn hoary-backports/restricted Packages
命中 http://archive.ubuntu.org.cn hoary-extras/main Packages
命中 http://archive.ubuntu.org.cn hoary-extras/universe Packages
命中 http://archive.ubuntu.org.cn hoary-extras/multiverse Packages
命中 http://archive.ubuntu.org.cn hoary-extras/restricted Packages
下载 3B,耗时 5s (1B/s)
saman6@saman:~$ sudo apt-get dist-upgrade
E: dpkg was interrupted, you must manually run 'dpkg --configure -a' to correct the problem.

我是新手,好多命令都不会,在ubuntu里面无法用中文输入,只能切换到xp里发贴,请各位大哥帮忙解决。
头像
gnix_oag
帖子: 1994
注册时间: 2005-05-19 18:38
来自: 湖南永州
送出感谢: 0
接收感谢: 1 次
联系:

#2

帖子 gnix_oag » 2005-09-10 12:27

重新 sudo apt-get update 下载软件包信息

再 sudo apt-get dist-upgrade 升级
saman
帖子: 42
注册时间: 2005-09-10 12:13
送出感谢: 0
接收感谢: 0
联系:

就像上面的最后一句

#3

帖子 saman » 2005-09-10 12:29

重来一次后,就提示如上面的显示,什么E…………的错误,无法继续
头像
gnix_oag
帖子: 1994
注册时间: 2005-05-19 18:38
来自: 湖南永州
送出感谢: 0
接收感谢: 1 次
联系:

#4

帖子 gnix_oag » 2005-09-10 12:31

中文输入法安装 见新手指引,

建议用自动脚本

全自动设计,

http://www.ubuntu.org.cn/support/docume ... install_sh
头像
oneleaf
论坛管理员
帖子: 10218
注册时间: 2005-03-27 0:06
系统: Ubuntu 12.04
送出感谢: 7 次
接收感谢: 102 次

#5

帖子 oneleaf » 2005-09-10 16:15

dpkg --configure -a

手工配置一下就好。

这样要发一些时间,

如果知道哪个有问题,就重新配置哪一个就行了
当净其意如虚空,远离妄想及诸取,令心所向皆无碍
saman
帖子: 42
注册时间: 2005-09-10 12:13
送出感谢: 0
接收感谢: 0
联系:

#6

帖子 saman » 2005-09-10 23:44

saman6@saman:~$ sudo dpkg --configure -a
dpkg: 解析错误,在“/var/lib/dpkg/updates/0048”文件的第“1”行附近:
字段名“essed”后必须紧跟冒号

why?
what i can do ?
saman
帖子: 42
注册时间: 2005-09-10 12:13
送出感谢: 0
接收感谢: 0
联系:

#7

帖子 saman » 2005-09-11 0:03

I can't edit this 0048 file,I cann't add :
what i can to do ?
头像
oneleaf
论坛管理员
帖子: 10218
注册时间: 2005-03-27 0:06
系统: Ubuntu 12.04
送出感谢: 7 次
接收感谢: 102 次

#8

帖子 oneleaf » 2005-09-11 0:23

用LiveCD启动后,检查硬盘。
当净其意如虚空,远离妄想及诸取,令心所向皆无碍
yongyi
帖子: 3025
注册时间: 2005-05-07 23:57
送出感谢: 0
接收感谢: 0
联系:

#9

帖子 yongyi » 2005-09-11 8:33

楼主的ubuntu分区是什么格式的?
如果想折腾着学多点东西的话,就继续想尽办法来搞搞。
如果不想折腾的话,重装吧。
独自看一看大海
总想起身边走在路上的朋友
Lenovo E290-420[Celeron-M420/256M/60G/Intel GMA950]
saman
帖子: 42
注册时间: 2005-09-10 12:13
送出感谢: 0
接收感谢: 0
联系:

#10

帖子 saman » 2005-09-11 9:52

我看我还是折腾一下先,实在不行再重装
saman
帖子: 42
注册时间: 2005-09-10 12:13
送出感谢: 0
接收感谢: 0
联系:

#11

帖子 saman » 2005-09-11 21:41

我删除了0048、0049两个文件后重新操作一次,可以了但安装时又出错了,转到ubuntu系统再贴给各位看。
哎,在ubuntu上无法用中文输入就是不爽。
saman
帖子: 42
注册时间: 2005-09-10 12:13
送出感谢: 0
接收感谢: 0
联系:

#12

帖子 saman » 2005-09-11 22:26

saman6@saman:~$ sudo apt-get -f install
正在读取软件包列表... 完成
正在分析软件包的依赖关系树... 完成
正在更正依赖关系... 完成
将会安装下列的额外的软件包:
firefox-gnome-support
下列【新】软件包将被安装:
firefox-gnome-support
共升级了 0 个软件包,新安装了 1 个软件包,要卸载 0 个软件包,有 32 个软件未被升级。
有 2 个软件包没有被完全安装或卸载。
需要下载 0B/80.2kB 的软件包。
解压缩后会消耗掉 152kB 的额外空间。
您希望继续执行吗?[Y/n]y
【警告】:下列的软件包不能通过认证!
firefox-gnome-support
不经验证就安装这些软件包么?[y/N] y

Preconfiguring packages ...
(正在读取数据库 ... dpkg:处理 /var/cache/apt/archives/gnome-btdownload_0.0.18-1ubuntu4_all.deb (--unpack)时出错:
软件包“gnome-btdownload”的文件名列表文件含有空的文件名
在处理时有错误发生:
/var/cache/apt/archives/gnome-btdownload_0.0.18-1ubuntu4_all.deb
由于出现了太多错误,处理过程被终止了。
E: Sub-process /usr/bin/dpkg returned an error code (1)

what i can to do?
saman
帖子: 42
注册时间: 2005-09-10 12:13
送出感谢: 0
接收感谢: 0
联系:

#13

帖子 saman » 2005-09-11 23:12

saman6@saman:~$ sudo apt-get dist-upgrade
正在读取软件包列表... 完成
正在分析软件包的依赖关系树... 完成
您也许需要运行“apt-get -f install”来纠正上面的错误。
下列的软件包有不能满足的依赖关系:
mozilla-firefox-gnome-support: 依赖: firefox-gnome-support 但是它还没有被安装
E: 不能满足依赖关系。不妨试一下 -f 选项。
saman6@saman:~$ sudo apt-get -f install
正在读取软件包列表... 完成
正在分析软件包的依赖关系树... 完成
正在更正依赖关系... 完成
将会安装下列的额外的软件包:
firefox-gnome-support
下列【新】软件包将被安装:
firefox-gnome-support
共升级了 0 个软件包,新安装了 1 个软件包,要卸载 0 个软件包,有 32 个软件未被升级。
有 2 个软件包没有被完全安装或卸载。
需要下载 0B/80.2kB 的软件包。
解压缩后会消耗掉 152kB 的额外空间。
您希望继续执行吗?[Y/n]y
【警告】:下列的软件包不能通过认证!
firefox-gnome-support
不经验证就安装这些软件包么?[y/N] y

Preconfiguring packages ...
(正在读取数据库 ... dpkg:处理 /var/cache/apt/archives/gnome-btdownload_0.0.18-1ubuntu4_all.deb (--unpack)时出错:
软件包“gnome-btdownload”的文件名列表文件含有空的文件名
在处理时有错误发生:
/var/cache/apt/archives/gnome-btdownload_0.0.18-1ubuntu4_all.deb
由于出现了太多错误,处理过程被终止了。
E: Sub-process /usr/bin/dpkg returned an error code (1)
saman
帖子: 42
注册时间: 2005-09-10 12:13
送出感谢: 0
接收感谢: 0
联系:

#14

帖子 saman » 2005-09-11 23:19

系统一直都是这个错误,有哪位高手指导一下,是不是我更新时没有更新到这个gnome-btdownload_0.0.18-1ubuntu4_all.deb,还是源上面出错了,再不行的话,我看来得重装了。

我的系统是装时,系统自动完成,swap好像是507还是多少M了,ext3格式是11G,是什么问题造成?请各位帮忙帮忙!
头像
oneleaf
论坛管理员
帖子: 10218
注册时间: 2005-03-27 0:06
系统: Ubuntu 12.04
送出感谢: 7 次
接收感谢: 102 次

#15

帖子 oneleaf » 2005-09-11 23:39

试试 启动新立得,选择 gnome-btdownload ,重新安装,试试。
当净其意如虚空,远离妄想及诸取,令心所向皆无碍
回复

回到 “老旧版本支持”