请教一个问题?很急!!!

为当前最终发行版之前的所有版本提供支持
回复
头像
longxj
帖子: 215
注册时间: 2006-10-07 15:17
送出感谢: 0
接收感谢: 0

请教一个问题?很急!!!

#1

帖子 longxj » 2006-10-23 10:45

您可能需要运行“apt-get -f install”来纠正下列错误:
下列的软件包有不能满足的依赖关系:
dirmngr: 依赖: libpth20 但是它将不会被安装
gnupg-agent: 依赖: libpth20 但是它将不会被安装
gpgsm: 依赖: libpth20 但是它将不会被安装
E: 有未能满足的依赖关系。请尝试不指明软件包的名字来运行“apt-get -f install”(也可以指定一个解决办法)。
$ sudo apt-get -f install
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
Reading state information... 完成
正在更正依赖关系... 完成
The following packages were automatically installed and are no longer required:
libgsf-gnome-1-114
使用 'apt-get autoremove' 来删除它们。
将会安装下列额外的软件包:
libpth20
下列【新】软件包将被安装:
libpth20
共升级了 0 个软件包,新安装了 1 个软件包,要卸载 0 个软件包,有 76 个软件未被升级。
有 388 个软件包没有被完全安装或卸载。
需要下载 0B/74.3kB 的软件包。
解压缩后会消耗掉 180kB 的额外空间。
您希望继续执行吗?[Y/n]y
(正在读取数据库 ... 系统当前总共安装有 171483 个文件和目录。)
正在解压缩 libpth20 (从 .../libpth20_2.0.7-2ubuntu2_i386.deb) ...
dpkg:处理 /var/cache/apt/archives/libpth20_2.0.7-2ubuntu2_i386.deb (--unpack)时出错:
正试图覆盖“/usr/lib/libpth.so.20”,它属于软件包 zhcon-dubuntu
在处理时有错误发生:
/var/cache/apt/archives/libpth20_2.0.7-2ubuntu2_i386.deb


怎么解决啊?
回复

回到 “老旧版本支持”