从dapper升级到了edgy,升级过程和一些问题

为当前最终发行版之前的所有版本提供支持
回复
jeffzhangfly
帖子: 4
注册时间: 2005-03-28 19:39
送出感谢: 0
接收感谢: 0

从dapper升级到了edgy,升级过程和一些问题

#1

帖子 jeffzhangfly » 2006-10-24 21:54

Laptop上的debian sid最近总是更新出问题来,打算换到ubuntu。手头有张dapper的光盘,装上了,确实不错,声卡显卡cpu变频等都自动配置好了,再把以前的字体配置弄过来,中文字体也正常了。很容易的一个系统就好了。不过dapper软件仓库中的软件没有debian全,我需要的slime就没有,而且scilab的版本是3.0的。去查了查edgy里有slime并且scilab版本也是4.0的。看看edgy也就要发布了,干脆升级到edgy吧。

下面是我的升级过程:
使用debian.ustc.edu.cn/ubuntu的源,另外还有ftp.sjtu.edu.cn/ubuntu-cn/。
修改成edgy的源后直接执行apt-get dist-upgrade,需要下载500多M。下载过程中在论坛上看帖子,看了看很多人说这种方法有问题,又跑去ubuntu网站看了看官方的升级说法。
说应该用gksu "update-manager -c -d"来升级,于是就等刚才的apt-get dist-upgrade执行到包下载完成后、包安装开始之前Ctrl-c终止了它。
然后gksu "update-manager -c -d",提示有很多不能升级的包,应该在随后再执行apt-get dist-upgrade。
于是等待update-manager执行完成,又执行了apt-get dist-upgrade。
完成了,面板通知区域的更新提示那里提示需要重新启动。不放心,就又执行了一次gksu "update-manager -c -d"。果然,这次出现了一个“升级ubuntu到6.10”的对话框,又下载了88个包。等待它完成。
终于完成了,还不放心,又来了一次gksu "update-manager -c -d",又更新了6个包。
重启,使用新内核2.6.17。


启动后基本正常,而且在edgy里glxgears的fps有500左右,而在debian sid只有390左右.我的显卡是intel 82852/82855GM的.

装了些其他需要用到的软件,基本都正常,不过utf8下emacs还是不能用fcitx输入汉字,还以为gnome2.16这个问题会解决。也可能我的配置有问题,一会再看看,是以前一直用的,直到gnome2.14不能用scim或fcitx输入汉字了。
gnome主菜单中有些图标不正常,显示的是缺省的窗口图标;游戏Wesnoth的界面乱码,英文游戏也乱码了.另外,这个贴子前面的内容我是用gedit写的,输入法用fcitx,在写的过程中发现cpu占用100%,风扇总是在转,切换到其他程序就好了,不清楚什么原因?

不知道有没有在edgy中utf8下emacs用fcitx/scim输入汉字的解决办法?请教各位兄第姐妹了.
jkzzh
帖子: 7
注册时间: 2006-10-25 9:41
送出感谢: 0
接收感谢: 0

#2

帖子 jkzzh » 2006-10-25 9:44

我的也是,从dapper升级到edgy之后标题栏和对话框的字体全部变成了方块了,我用的是英文的界面。后来进font设置,发现只有少数字体正常,大部分显示不出来,现在暂时换了个能显示的字体,桌面正常了,但是登录界面还是乱码。
jeffzhangfly
帖子: 4
注册时间: 2005-03-28 19:39
送出感谢: 0
接收感谢: 0

#3

帖子 jeffzhangfly » 2006-10-25 9:50

从http://3v1n0.tuxfamily.org/下载了edgy的包.然后全部安装.又用apt-get安装了compiz的几个包.不用设置.直接beryl-manager就起来beryl了.确实很炫.不过还有些问题,而且打开几个程序后机器的反应就慢下来了,目前还只能是感受下效果.
我的硬件配置:CPU P4 2.2; MEM 1G; 显卡 intel 82852/82855GM.
在写这个贴子时beryl crash了...
http://forum.ubuntu.org.cn/files/screenshot_10236.png
附件
Screenshot.png
jeffzhangfly
帖子: 4
注册时间: 2005-03-28 19:39
送出感谢: 0
接收感谢: 0

#4

帖子 jeffzhangfly » 2006-10-25 10:19

安装永中office2007正式试用版.
root执行./setup,出错,控制台输出很多说"cannot set permissions for ..."的信息.于是手动把Jre.zip解压,然后复制到/tmp,再执行./setup,好了.安装完成后一切正常.
回复

回到 “老旧版本支持”