HELP: LUMAQQ无法正常启动

为当前最终发行版之前的所有版本提供支持
回复
szsuj
帖子: 58
注册时间: 2006-10-22 10:57
送出感谢: 0
接收感谢: 0

HELP: LUMAQQ无法正常启动

#1

帖子 szsuj » 2006-10-26 23:19

这是屏幕打印出来信息,请大侠帮忙分析一下吧

sunnyroot@ubuntu:~/LumaQQ$ ./lumaqq
sunnyroot@ubuntu:~/LumaQQ$ Exception in thread "main" java.lang.NoClassDefFoundError: org.eclipse.emf.ecore.plugin.EcorePlugin
at java.lang.Class.initializeClass(libgcj.so.7)
at org.eclipse.emf.ecore.resource.impl.URIConverterImpl.<clinit>(URIConverterImpl.java:207)
at java.lang.Class.initializeClass(libgcj.so.7)
at org.eclipse.emf.ecore.resource.impl.ResourceSetImpl.getURIConverter(ResourceSetImpl.java:411)
at org.eclipse.emf.ecore.resource.impl.ResourceImpl.getURIConverter(ResourceImpl.java:835)
at org.eclipse.emf.ecore.resource.impl.ResourceImpl.load(ResourceImpl.java:865)
at edu.tsinghua.lumaqq.eutil.GlobalUtil.load(GlobalUtil.java:106)
at edu.tsinghua.lumaqq.LumaQQ.readGlobalSettingFile(LumaQQ.java:226)
at edu.tsinghua.lumaqq.LumaQQ.main(LumaQQ.java:119)
Caused by: java.lang.ClassNotFoundException: org.eclipse.core.runtime.jobs.ISchedulingRule not found in gnu.gcj.runtime.SystemClassLoader{urls=[file:./lib/xerces.jar,file:./lib/swt.jar,file:./lib/poifs.jar,file:./lib/org.eclipse.ui.workbench_3.2.0.I20051214-1200.jar,file:./lib/org.eclipse.osgi_3.2.0.v20051212a.jar,file:./lib/org.eclipse.jface_3.2.0.I20051214-0010.jar,file:./lib/org.eclipse.equinox.common_1.0.0.v20051205.jar,file:./lib/org.eclipse.emf.ecore.xmi_2.2.0.jar,file:./lib/org.eclipse.emf.ecore_2.2.0.jar,file:./lib/org.eclipse.emf.common_2.2.0.jar,file:./lib/org.eclipse.core.runtime_3.2.0.v20051208.jar,file:./lib/org.eclipse.core.resources_3.2.0.v20051208.jar,file:./lib/org.eclipse.core.commands_3.2.0.I20051212-2000.jar,file:./lib/lumaqq_xsd.jar,file:./lib/lumaqq_template.jar,file:./lib/lumaqq.jar,file:./lib/log4j-1.2.8.jar,file:./lib/jql_protocol.jar,file:./lib/jql_net.jar,file:./lib/je.jar,file:./lib/jdom.jar,file:./lib/commons-logging.jar,file:./lib/commons-codec.jar,file:./], parent=gnu.gcj.runtime.ExtensionClassLoader{urls=[], parent=null}}
at java.net.URLClassLoader.findClass(libgcj.so.7)
at java.lang.ClassLoader.loadClass(libgcj.so.7)
at java.lang.ClassLoader.loadClass(libgcj.so.7)
at java.lang.VMClassLoader.defineClass(libgcj.so.7)
at java.lang.ClassLoader.defineClass(libgcj.so.7)
at java.security.SecureClassLoader.defineClass(libgcj.so.7)
at java.net.URLClassLoader.findClass(libgcj.so.7)
at java.lang.ClassLoader.loadClass(libgcj.so.7)
at java.lang.ClassLoader.loadClass(libgcj.so.7)
at java.lang.VMClassLoader.defineClass(libgcj.so.7)
at java.lang.ClassLoader.defineClass(libgcj.so.7)
at java.security.SecureClassLoader.defineClass(libgcj.so.7)
at java.net.URLClassLoader.findClass(libgcj.so.7)
at java.lang.ClassLoader.loadClass(libgcj.so.7)
at java.lang.ClassLoader.loadClass(libgcj.so.7)
at java.lang.VMClassLoader.defineClass(libgcj.so.7)
at java.lang.ClassLoader.defineClass(libgcj.so.7)
at java.security.SecureClassLoader.defineClass(libgcj.so.7)
at java.net.URLClassLoader.findClass(libgcj.so.7)
at java.lang.ClassLoader.loadClass(libgcj.so.7)
at java.lang.ClassLoader.loadClass(libgcj.so.7)
at java.lang.Class.forName(libgcj.so.7)
at java.lang.Class.initializeClass(libgcj.so.7)
...8 more
szsuj
帖子: 58
注册时间: 2006-10-22 10:57
送出感谢: 0
接收感谢: 0

#2

帖子 szsuj » 2006-10-27 21:58

忘记说了,我是下载了LUMAQQ2006直接解压的
szsuj
帖子: 58
注册时间: 2006-10-22 10:57
送出感谢: 0
接收感谢: 0

#3

帖子 szsuj » 2006-10-28 10:25

郁闷!问问题从来没有人来解答!!!
dorice
帖子: 94
注册时间: 2006-06-22 1:52
送出感谢: 0
接收感谢: 0

#4

帖子 dorice » 2006-10-28 10:37

正确安装java了吗?
szsuj
帖子: 58
注册时间: 2006-10-22 10:57
送出感谢: 0
接收感谢: 0

#5

帖子 szsuj » 2006-10-28 10:43

安装了啊,装的最新的,1.6
yifabanshi
帖子: 55
注册时间: 2006-10-19 22:31
送出感谢: 0
接收感谢: 0
联系:

#6

帖子 yifabanshi » 2006-10-28 10:44

安装JAVA环境 然后装QQ 安WIKI的提示做 不行就再试一遍
szsuj
帖子: 58
注册时间: 2006-10-22 10:57
送出感谢: 0
接收感谢: 0

#7

帖子 szsuj » 2006-10-28 10:47

JAVA环境应该没有问题的,我的ECLIPSE工作的非常好的
szsuj
帖子: 58
注册时间: 2006-10-22 10:57
送出感谢: 0
接收感谢: 0

#8

帖子 szsuj » 2006-10-28 10:48

WIKI中有如何安装LUMAQQ的链接,可我点过去永远是

This page does not exist yet. You can create a new empty page, or use one of the page templates.
头像
alpha.gu
帖子: 1456
注册时间: 2006-09-10 16:06
送出感谢: 0
接收感谢: 0
联系:

#9

帖子 alpha.gu » 2006-10-28 16:56

export JAVA_HOME="你的java安装目录"
szsuj
帖子: 58
注册时间: 2006-10-22 10:57
送出感谢: 0
接收感谢: 0

#10

帖子 szsuj » 2006-10-29 23:13

alpha.gu 写了:export JAVA_HOME="你的java安装目录"
搞定了!多谢!
flashzs
帖子: 36
注册时间: 2006-06-03 22:28
送出感谢: 0
接收感谢: 0
联系:

#11

帖子 flashzs » 2006-10-31 15:07

alpha.gu 写了:export JAVA_HOME="你的java安装目录"
设置之后,每次可以用终端启动,点击应用程序中的图表就没有效果...
szsuj
帖子: 58
注册时间: 2006-10-22 10:57
送出感谢: 0
接收感谢: 0

#12

帖子 szsuj » 2006-10-31 16:47

我加在LUMAQQ的启动脚本里的!
silon212
帖子: 16
注册时间: 2006-11-01 8:41
送出感谢: 0
接收感谢: 0
联系:

#13

帖子 silon212 » 2006-11-02 1:59

1. 把Ubuntu(dapper drake)自带的JVM - gij 卸了.
2. 安装java.sun.com官方的bin版j2sdk
3. 改~/.bashrc,向其中加入
JAVA_HOME=........../jdk1.5.0_09
#.........代表你的jdk安装目录
PATH=$PATH:$JAVA_HOME/bin:$JAVA_HOME/jre/bin
CLASSPATH=$CLASSPATH:$JAVA_HOME/lib:$JAVA_HOME/jre/lib

export JAVA_HOME PATH CLASSPATH

重启一下gnome,kde等会话后,就可以在bash下运行lumaqq
你要想通过gnome双击鼠标运行,得改lumaqq这个bash脚本,参照我的:
#改lumaqq中的最后一个if块
# 则在用户主目录下找寻JRE,如果还找不到,那就是真的失败了

# modified by zy
#if [ -e $PREFIX/java ]; then
# $PREFIX/java/bin/java -Djava.library.path=$PREFIX/swt -classpath $cp #edu.tsinghua.lumaqq.LumaQQ "$HOME/.lumaqq" &

JAVA_HOME=/home/zy/tool/dev_tool/jdk1.5.0_09/jre

if [ ! -z $JAVA_HOME ]; then
$JAVA_HOME/bin/java -Djava.library.path=$PREFIX/swt -classpath $cp edu.tsinghua.lumaqq.LumaQQ "$HOME/.lumaqq" &
else
found=0
for i in `find /usr -name "java" | grep bin`; do
if [ -x "$i" ]; then
$i -Djava.library.path=$PREFIX/swt -classpath $cp edu.tsinghua.lumaqq.LumaQQ "$HOME/.lumaqq" &
found=1
break
fi
done
silon212
帖子: 16
注册时间: 2006-11-01 8:41
送出感谢: 0
接收感谢: 0
联系:

#14

帖子 silon212 » 2006-11-02 2:14

sorry,纠正我上面的错误,如果你把ubuntu自代的gij卸了,你就不用该lumaqq的bash脚本了,就是说按照1、2、3步骤就可以了。
ankey
帖子: 14
注册时间: 2006-07-18 20:36
送出感谢: 0
接收感谢: 0

#15

帖子 ankey » 2006-11-02 13:35

下载带java的不是更方便!
回复

回到 “老旧版本支持”