当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 8 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : [已解决]ubuntu6.10如何安装ati显卡的驱动啊?
帖子发表于 : 2006-10-27 11:49 

注册: 2006-03-01 23:00
帖子: 32
送出感谢: 0 次
接收感谢: 0 次
全新安装
按照6.06的方法,用6.06的源安装完进入不了X了
怎么办啊?

高手指点下,谢谢!


最后由 tonytop 编辑于 2006-10-27 14:01,总共编辑了 1 次

页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2006-10-27 12:12 

注册: 2005-11-25 15:07
帖子: 15
送出感谢: 0 次
接收感谢: 0 次
同楼主,我的显卡是x1500
按照:http://wiki.cchtml.com/index.php/Ubuntu_Dapper_Installation_Guide
的方法安装8.29.6驱动,到:sudo module-assistant build fglrx 时候提示build失败,郁闷中


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2006-10-27 12:23 

注册: 2006-08-30 11:16
帖子: 477
地址: 广东阳春
送出感谢: 0 次
接收感谢: 0 次
6.10安装6.06的源点驱动。。。。我也尝试了,结果。。。进不去X,还好有备份。


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2006-10-27 12:28 

注册: 2006-03-01 23:00
帖子: 32
送出感谢: 0 次
接收感谢: 0 次
唉,俺没备份,还得重装。郁闷
关键是新的驱动该怎么安装阿?
要不然还是解决不了问题啊。


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2006-10-27 12:43 

注册: 2006-08-30 11:16
帖子: 477
地址: 广东阳春
送出感谢: 0 次
接收感谢: 0 次
已经解决!哈哈按照这里可以搞定。
http://forum.ubuntu.org.cn/viewtopic.ph ... hlight=ati


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2006-10-27 12:54 

注册: 2006-03-01 23:00
帖子: 32
送出感谢: 0 次
接收感谢: 0 次
这就试试去。


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2006-10-27 13:33 

注册: 2006-08-12 22:00
帖子: 154
送出感谢: 0 次
接收感谢: 0 次
还好不是在我的机器上面更新,否则完蛋了。呵呵。
请问各位怎么办?下面的所有的东西都是按照原来的dapper路子走的。

yulewang@yulewang-laptop:~$ sudo apt-get install xorg-driver-fglrx fglrx-controlReading package lists... Done
Building dependency tree
Reading state information... Done
xorg-driver-fglrx is already the newest version.
fglrx-control is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

yulewang@yulewang-laptop:~$ sudo aticonfig --initial
Found fglrx primary device section
Nothing to do, terminating.

yulewang@yulewang-laptop:~$ sudo aticonfig --overlay-type=Xv
Warning: Option 'VideoOverlay' doesn't affect running session.
Warning: Option 'OpenGLOverlay' doesn't affect running session.
Using /etc/X11/xorg.conf
Saved back-up to /etc/X11/xorg.conf.fglrx-0

yulewang@yulewang-laptop:~$ sudo depmod -a

yulewang@yulewang-laptop:~$ sudo modprobe fglrx

yulewang@yulewang-laptop:~$ fglrxinfo
display: :0.0 screen: 0
OpenGL vendor string: Mesa project: www.mesa3d.org
OpenGL renderer string: Mesa GLX Indirect
OpenGL version string: 1.2 (1.5 Mesa 6.5.1)

yulewang@yulewang-laptop:~$ cat /etc/X11/xorg.conf

# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the /etc/X11/xorg.conf manual page.
# (Type "man /etc/X11/xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "ServerLayout"
Identifier "Default Layout"
Screen 0 "aticonfig-Screen[0]" 0 0
InputDevice "Generic Keyboard"
InputDevice "Configured Mouse"
InputDevice "stylus" "SendCoreEvents"
InputDevice "cursor" "SendCoreEvents"
InputDevice "eraser" "SendCoreEvents"
InputDevice "Synaptics Touchpad"
EndSection

Section "Files"

# path to defoma fonts
FontPath "/usr/share/X11/fonts/misc"
FontPath "/usr/share/X11/fonts/cyrillic"
FontPath "/usr/share/X11/fonts/100dpi/:unscaled"
FontPath "/usr/share/X11/fonts/75dpi/:unscaled"
FontPath "/usr/share/X11/fonts/Type1"
FontPath "/usr/share/X11/fonts/100dpi"
FontPath "/usr/share/X11/fonts/75dpi"
FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
Load "i2c"
Load "bitmap"
Load "ddc"
Load "dri"
Load "extmod"
Load "freetype"
Load "glx"
Load "int10"
Load "type1"
Load "vbe"
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "CoreKeyboard"
Option "XkbRules" "xorg"
Option "XkbModel" "pc104"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/input/mice"
Option "Protocol" "ExplorerPS/2"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "true"
EndSection

Section "InputDevice"
Identifier "Synaptics Touchpad"
Driver "synaptics"
Option "SendCoreEvents" "true"
Option "Device" "/dev/psaux"
Option "Protocol" "auto-dev"
Option "HorizScrollDelta" "0"
EndSection

Section "InputDevice"

# /dev/input/event
# for USB
Identifier "stylus"
Driver "wacom"
Option "Device" "/dev/wacom" # Change to
Option "Type" "stylus"
Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "InputDevice"

# /dev/input/event
# for USB
Identifier "eraser"
Driver "wacom"
Option "Device" "/dev/wacom" # Change to
Option "Type" "eraser"
Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "InputDevice"

# /dev/input/event
# for USB
Identifier "cursor"
Driver "wacom"
Option "Device" "/dev/wacom" # Change to
Option "Type" "cursor"
Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "Monitor"
Identifier "Generic Monitor"
Option "DPMS"
EndSection

Section "Monitor"
Identifier "aticonfig-Monitor[0]"
Option "VendorName" "ATI Proprietary Driver"
Option "ModelName" "Generic Autodetecting Monitor"
Option "DPMS" "true"
EndSection

Section "Device"
Identifier "ATI Technologies, Inc. ATI Default Card"
Driver "vesa"
BusID "PCI:1:0:0"
EndSection

Section "Device"
Identifier "aticonfig-Device[0]"
Driver "fglrx"
Option "VideoOverlay" "on"
Option "OpenGLOverlay" "off"
EndSection

Section "Screen"
Identifier "Default Screen"
Device "ATI Technologies, Inc. ATI Default Card"
Monitor "Generic Monitor"
DefaultDepth 24
SubSection "Display"
Depth 1
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 4
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 8
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 15
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 16
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 24
Modes "1024x768" "800x600" "640x480"
EndSubSection
EndSection

Section "Screen"
Identifier "aticonfig-Screen[0]"
Device "aticonfig-Device[0]"
Monitor "aticonfig-Monitor[0]"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
EndSubSection
EndSection

Section "DRI"
Mode 0666
EndSection

Section "Extensions"
Option "Composite" "0"
EndSection


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2006-10-27 13:59 

注册: 2006-03-01 23:00
帖子: 32
送出感谢: 0 次
接收感谢: 0 次
已解决,谢谢5楼兄弟

具体方法如下:

将原来安装的驱动卸载:sudo apt-get remove xorg-driver-fglrx

安装新驱动:

sudo gedit /etc/X11/xorg.conf

and add these lines at the end of the file:
File: /etc/X11/xorg.conf

Section "Extensions"
Option "Composite" "0"
EndSection



Installing the driver

Make sure the restricted repository is enabled in /etc/apt/sources.list or this guide will not work!

sudo apt-get update
sudo apt-get install linux-restricted-modules-$(uname -r) #Okay if it is already installed
sudo apt-get install xorg-driver-fglrx
sudo depmod -a
sudo aticonfig --initial
sudo aticonfig --overlay-type=Xv

Now Reboot your system:

sudo shutdown -r now


Confirm that it works

fglrxinfo
display: :0.0 screen: 0
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: RADEON 9600 Generic
OpenGL version string: 2.0.6011 (8.28.8)

注:安装过程中所用源:把6.06的源中的dapper改成edgy即可


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 8 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译