求助,fglrx起不来

为当前最终发行版之前的所有版本提供支持
回复
yulewang
帖子: 154
注册时间: 2006-08-12 22:00
送出感谢: 0
接收感谢: 0

求助,fglrx起不来

#1

帖子 yulewang » 2006-10-27 12:15

yulewang@yulewang-laptop:~$ sudo apt-get install xorg-driver-fglrx fglrx-controlReading package lists... Done
Building dependency tree
Reading state information... Done
xorg-driver-fglrx is already the newest version.
fglrx-control is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

yulewang@yulewang-laptop:~$ sudo aticonfig --initial
Found fglrx primary device section
Nothing to do, terminating.

yulewang@yulewang-laptop:~$ sudo aticonfig --overlay-type=Xv
Warning: Option 'VideoOverlay' doesn't affect running session.
Warning: Option 'OpenGLOverlay' doesn't affect running session.
Using /etc/X11/xorg.conf
Saved back-up to /etc/X11/xorg.conf.fglrx-0

yulewang@yulewang-laptop:~$ sudo depmod -a

yulewang@yulewang-laptop:~$ sudo modprobe fglrx

yulewang@yulewang-laptop:~$ fglrxinfo
Xlib: extension "XFree86-DRI" missing on display ":0.0".
display: :0.0 screen: 0
OpenGL vendor string: Mesa project: www.mesa3d.org
OpenGL renderer string: Mesa GLX Indirect
OpenGL version string: 1.2 (1.5 Mesa 6.5.1)
rainofchaos
帖子: 140
注册时间: 2006-10-15 12:59
送出感谢: 0
接收感谢: 0
联系:

#2

帖子 rainofchaos » 2006-10-27 18:36

一般这种情况是因为以前进行了不正确的安装,所以首先对系统进行回滚:

1。清除以前安装的驱动:
新利得软件包管理:搜索 fglrx 删除安装的
linux-restricted-*
xorg-driver-fglrx
其实搜索到的包除了xserver-xorg-driver-ati保留以外都可以删除

2。退出 gnome. 进如字符终端

代码: 全选

sudo modprobe -r fglrx
3. 重新配置xorg

代码: 全选

sudo dpkg-reconfigure xserver-xorg
除了在选择 “driver" 时注意选择 ATI 之外,其他都使用默认就行了

4。这时,系统已经返回为安装以前的状态:重新安装fglrx

代码: 全选

sudo apt-get update 
sudo apt-get install linux-restricted-modules-$(uname -r)
sudo apt-get install xorg-driver-fglrx
sudo aticonfig --initial
sudo aticonfig --overlay-type=Xv
回复

回到 “老旧版本支持”