[问题]升级失败导致包依赖关系破损,现在咋办?(已解决)

为当前最终发行版之前的所有版本提供支持
回复
头像
Ray
帖子: 387
注册时间: 2006-07-06 0:57
来自: Beijing, PRC
送出感谢: 0
接收感谢: 0
联系:

[问题]升级失败导致包依赖关系破损,现在咋办?(已解决)

#1

帖子 Ray » 2006-10-27 20:46

升级过程中报错异常退出,重新起动后进入Ubuntu 6.10。大多数东西看上去很正常,但是启动后软件更新管理器提示如下:

代码: 全选

出现一个错误,请在右键菜单中运行Package Manager或者在终端中使用apt-get查看有关错误信息。错误信息为:‘Error: BrokenCount>0’
仔细查看了一下发现是包的依赖关系出了问题。用包管理器修复包依赖关系失败。用apt-get install -f也不行

帮我看看这个怎么办:

代码: 全选

ray@ray-laptop:~$ sudo apt-get -f install
正在读取软件包列表... 完成
正在分析软件包的依赖关系树... 完成
正在更正依赖关系... 完成
将会安装下列额外的软件包:
  samba
推荐安装的软件包:
  smbldap-tools
下列的软件包将被升级:
  samba
共升级了 1 个软件包,新安装了 0 个软件包,要卸载 0 个软件包,有 2 个软件未被升级。
需要下载 0B/2904kB 的软件包。
解压缩后会消耗掉 123kB 的额外空间。
您希望继续执行吗?[Y/n]y
正在预设定软件包 ...
(正在读取数据库 ... 系统当前总共安装有 122695 个文件和目录。)
正预备替换 samba 3.0.22-1ubuntu3.1 (使用 .../samba_3.0.22-1ubuntu4_i386.deb) ...
invoke-rc.d: dangling symlink: /etc/rc2.d/K09samba
dpkg:警告 - 原先的 pre-removal 脚本 退出时返回了错误号 102
dpkg - 现转而试用新软件包所带的脚本...
invoke-rc.d: dangling symlink: /etc/rc2.d/K09samba
dpkg:处理 /var/cache/apt/archives/samba_3.0.22-1ubuntu4_i386.deb (--unpack)时出错:
 子进程·新的 pre-removal 脚本·返回了错误号·102
在处理时有错误发生:
 /var/cache/apt/archives/samba_3.0.22-1ubuntu4_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
ray@ray-laptop:~$ 
=================================
Ubuntu 12.04 LTS
Dell Vostro 1450
http://www.lirui.name
头像
Ray
帖子: 387
注册时间: 2006-07-06 0:57
来自: Beijing, PRC
送出感谢: 0
接收感谢: 0
联系:

#2

帖子 Ray » 2006-10-27 21:31

启动到 recover模式下再运行 sudo apt-get -f install 就搞定了。
=================================
Ubuntu 12.04 LTS
Dell Vostro 1450
http://www.lirui.name
回复

回到 “老旧版本支持”