[问题]本想硬盘安装6.10,没成功不说,结果现在连进XP都要用光盘引导,怎么办?[已解决

为当前最终发行版之前的所有版本提供支持
jimmin
论坛版主
帖子: 2138
注册时间: 2006-09-24 4:37
送出感谢: 0
接收感谢: 1 次

[问题]本想硬盘安装6.10,没成功不说,结果现在连进XP都要用光盘引导,怎么办?[已解决

#1

帖子 jimmin » 2006-10-27 21:47

我下载的是viewtopic.php?t=26167&highlight=%E7%A1% ... 9%E8%A3%85里的引导包
把boot文件夹和grldr文件复制到C盘,改c:\boot.ini文件为

代码: 全选

[boot loader]
timeout=30
default=multi(0)disk(0)rdisk(0)partition(3)\WINDOWS
[operating systems]
multi(0)disk(0)rdisk(0)partition(3)\WINDOWS="Microsoft Windows XP Professional" /noexecute=optin /fastdetect
c:\grldr=" Ubuntu Linux    "
,再把ubuntu-6.10-desktop-i386.iso从D盘复制到C:/edgy,重启。选择Ubuntu Linux后屏幕是花的,但能看到部分英文,大概如下:
kernel (hd0,0)/boot/edgy/vmlinuz boot gnix oag ramdisk_size 108576 root /dev/r
am rw quiet splash debian installer/locale zh_CN

Error 17: File not found
Boot ?O Back MS Win........
大概只能看到这么多文字其它地方全是花的,我点回车就变为黑屏,再回车就变回上面的花屏,再回车又黑屏,就这样重复,最后只能Ctrl+Alt+Del。
可是重启后引导系统那一步显示为

代码: 全选

Verifying DMI Pool Date ...........
Boot from ATAPI CD-ROM:Failure...
Error loading operating system_
多次重启都是这样,最后只能用番茄花园光盘的引导才进入了XP,但现在我不用光盘就进不了系统啊,怎么办?

===================================================

我后来把bhd_i386_2.6.17-10g.tar.gz的说明看了看,想找出是哪里出错,推测是以下几点,大家看看对不对:
1.是因为我把ubuntu-6.10-desktop-i386.iso放在C:/edgy里了,而本来应该放在C:/ubuntu里的?
我用光盘进入XP后又复制了一份ubuntu-6.10-desktop-i386.iso放在C:/ubuntu里,可重启后还是

代码: 全选

Verifying DMI Pool Date ...........
Boot from ATAPI CD-ROM:Failure...
Error loading operating system_
怎么办?
2.ubuntu-6.10-desktop-i386.iso文件能放在其它盘吗?因为每次都要从D盘复制到C盘很麻烦。我如果放在D盘需要注意些什么?(比如initrd.gz和vmlinuz需要也放在D盘吗?)
3.花屏是因为我使用了bhd_i386_2.6.17-10g.tar.gz里的grldr(164K)吗?因为我后来又找到了2个grldr文件,一个是grldr(164K)一个grldr(146K),而146K的那个是英文的,164K的是中文的。是不是因为我用了中文的所以花屏?
4.难道应该把initrd.gz和vmlinuz放在C盘根目录,而不是放在C:/boot\edgy里?


====================================================
我现在该怎么办?我现在手头的工具有番茄花园2.7光盘、Ubuntu6.06光盘。最后说一下我的分区,其中ext3都是用分区工具预留给ubuntu的,现在系统中只装了XP。
hda1 / ext3 7G
hda2 /home ext3 5G
hda3 /Windows vfat 5G

hda5 swap swap 0.5G
hda6 /VMWare vfat 5.5G
hda7 /VMWare+ISO ext3 11.5G
hda8 /Ghost vfat 3G
上次由 jimmin 在 2006-10-28 20:05,总共编辑 1 次。
头像
tempso
帖子: 25
注册时间: 2006-08-31 16:04
来自: 大连
送出感谢: 0
接收感谢: 0

#2

帖子 tempso » 2006-10-27 22:05

我用了那个引导文件,没有花屏问题啊。
1:就是放在edgy文件夹下面;
2:中文不影响啊,只是出来一个引导画面,两个选项,第一个启动Ubuntu,第二个返回winxp
3:内核文件就是放在c:\boot\edgy下面的

估计是你前面的ext3分区导致的吧。你把c:\boot\grub\menu.lst用记事本修改一下,把hd(0,0)用hd(0,2)替换看看。
上次由 tempso 在 2006-10-27 22:15,总共编辑 1 次。
Ubuntu edgy 6.10

TOSHIBA dynabook E8/520CME

新手上路,都让着点哈
jimmin
论坛版主
帖子: 2138
注册时间: 2006-09-24 4:37
送出感谢: 0
接收感谢: 1 次

#3

帖子 jimmin » 2006-10-27 22:13

现在怎么办?每次启动都

代码: 全选

Verifying DMI Pool Date ........... 
Boot from ATAPI CD-ROM:Failure...
Error loading operating system_
先要把这个解决了吧,要不进XP都麻烦。
jimmin
论坛版主
帖子: 2138
注册时间: 2006-09-24 4:37
送出感谢: 0
接收感谢: 1 次

#4

帖子 jimmin » 2006-10-27 22:19

tempso 写了:我用了那个引导文件,没有花屏问题啊。
1:就是放在edgy文件夹下面;
2:中文不影响啊,只是出来一个引导画面,两个选项,第一个启动Ubuntu,第二个返回winxp
3:内核文件就是放在c:\boot\edgy下面的

估计是你前面的ext3分区导致的吧。你把c:\boot\grub\menu.lst用记事本修改一下,把hd(0,0)用hd(0,2)替换看看。

代码: 全选

timeout 5
default 0
fallback 1
splashimage (hd0,0)/boot/grub/bj2008.xpm.gz
fontfile (hd0,0)/boot/grub/fonts

title Ubuntu Linux 6.10 
kernel (hd0,0)/boot/edgy/vmlinuz boot=gnix_oag ramdisk_size=1048576 root=/dev/ram rw quiet splash  debian-installer/locale=zh_CN 
initrd (hd0,0)/boot/edgy/initrd.gz  

title GO Back (MS Windwos OS)
rootnoverify (hd0,0)
makeactive
chainloader  +1
有几处(hd0,0),帮忙看看改哪里。
头像
tempso
帖子: 25
注册时间: 2006-08-31 16:04
来自: 大连
送出感谢: 0
接收感谢: 0

#5

帖子 tempso » 2006-10-27 22:24

没魄力!都改了再说! :roll:
Ubuntu edgy 6.10

TOSHIBA dynabook E8/520CME

新手上路,都让着点哈
头像
gnix_oag
帖子: 1994
注册时间: 2005-05-19 18:38
来自: 湖南永州
送出感谢: 0
接收感谢: 1 次
联系:

#6

帖子 gnix_oag » 2006-10-27 22:26

hda1 / ext3 7G
hda2 /home ext3 5G
hda3 /Windows vfat 5G

hda5 swap swap 0.5G
hda6 /VMWare vfat 5.5G
hda7 /VMWare+ISO ext3 11.5G
hda8 /Ghost vfat 3G
问题可能是在这里,你的C盘对应的是hda5
而我的grub for dos 的 menu.lst 配置是针对C盘为hda1的,
所以你要改一改 menu.lst 这个文件了
头像
gnix_oag
帖子: 1994
注册时间: 2005-05-19 18:38
来自: 湖南永州
送出感谢: 0
接收感谢: 1 次
联系:

#7

帖子 gnix_oag » 2006-10-27 22:28

把所有的 (hd0,0) 改为 (hd0,4) 试试
jimmin
论坛版主
帖子: 2138
注册时间: 2006-09-24 4:37
送出感谢: 0
接收感谢: 1 次

#8

帖子 jimmin » 2006-10-27 22:36

我(hd0,2)和(hd0,4)都试过了,可重启还是

代码: 全选

Verifying DMI Pool Date ........... 
Boot from ATAPI CD-ROM:Failure... 
Error loading operating system_
是不是第一次安装的引导失败了,怎么把第一次安装的先给删除了,现在根本就看不到XP和Ubuntu的选择画面。
头像
tempso
帖子: 25
注册时间: 2006-08-31 16:04
来自: 大连
送出感谢: 0
接收感谢: 0

#9

帖子 tempso » 2006-10-27 22:39

不知道了。。。 :oops:
Ubuntu edgy 6.10

TOSHIBA dynabook E8/520CME

新手上路,都让着点哈
jimmin
论坛版主
帖子: 2138
注册时间: 2006-09-24 4:37
送出感谢: 0
接收感谢: 1 次

#10

帖子 jimmin » 2006-10-27 22:44

我发现引导错误后很麻烦,有没有什么软件可以备份MBR的?
头像
gnix_oag
帖子: 1994
注册时间: 2005-05-19 18:38
来自: 湖南永州
送出感谢: 0
接收感谢: 1 次
联系:

#11

帖子 gnix_oag » 2006-10-27 23:43

你进入到 grub 没有啊。grub for dos 不会影响windows XP的

Microsoft Windows XP Professional
Ubuntu Linux

第一项就能进入XP的,第二项才进入到grub的,
如果没有这两个菜单,那就可能是ntldr的问题了

你好象有 linux 吧,是不是grub已经安装在MBR上了?
jimmin
论坛版主
帖子: 2138
注册时间: 2006-09-24 4:37
送出感谢: 0
接收感谢: 1 次

#12

帖子 jimmin » 2006-10-28 0:09

我用XP光盘全新安装把那个错误的引导覆盖了。

这次都改了(hd0,4),到
Microsoft Windows XP Professional
Ubuntu Linux
时选“Ubuntu Linux”,又是花屏,我心想完了,又要不能启动XP了,我回车,很高兴的看到这回出现的文字不一样

代码: 全选

   Booting  ‘Go Back (MS Windows OS)‘

rootnoverify (hd0,4)
makeactive

Error 13:  Invalid device requested
Press any key to continue...
再回车只是在黑屏和这个介面之间切换,只能Ctrl+Alt+Del了,不过这回重启没有看到
Verifying DMI Pool Date ...........
Boot from ATAPI CD-ROM:Failure...
Error loading operating system_
重启后又很顺利的看到
Microsoft Windows XP Professional
Ubuntu Linux
我想可能画屏那里有什么选项,决定再试试,选Ubuntu Linux ,到花屏那里,按小键盘的向下键,这回看到的文字又不一样,是

代码: 全选

/boot/edgy/vmlinuz boot=gnix_oag ramdisk_size=1048576 root=/dev/ram rw quiet splash  debian-installer/locale=zh_CN (这里大概是这样,我没有用笔记这一行,只是看zh_CN很眼熟,记起是改C:\boot\grub\menu.lst里看到过)

Error 19:  Cannot mountselected partition
Press any key to continue...
再回车也还是在黑屏和这个介面之间切换,Ctrl+Alt+Del重启。

总之还是没成功,怎么办啊!
jimmin
论坛版主
帖子: 2138
注册时间: 2006-09-24 4:37
送出感谢: 0
接收感谢: 1 次

#13

帖子 jimmin » 2006-10-28 0:14

gnix_oag 写了:你进入到 grub 没有啊。grub for dos 不会影响windows XP的

Microsoft Windows XP Professional
Ubuntu Linux

第一项就能进入XP的,第二项才进入到grub的,
如果没有这两个菜单,那就可能是ntldr的问题了

你好象有 linux 吧,是不是grub已经安装在MBR上了?
我也不知道怎么回事,反正按我写的那样后就看不到
Microsoft Windows XP Professional
Ubuntu Linux
停在了扫描光驱之后的那一步
Verifying DMI Pool Date ...........
Boot from ATAPI CD-ROM:Failure...
Error loading operating system_
jimmin
论坛版主
帖子: 2138
注册时间: 2006-09-24 4:37
送出感谢: 0
接收感谢: 1 次

#14

帖子 jimmin » 2006-10-28 0:34

我改成(hd0,2),把grldr换成英文的那个后,终于没有花屏,成功进入grub for dos,可是选择Ubuntu6.10后显示器就黑屏了(中间有红色的字:Input Not Supported)。硬盘安装Ubuntu怎么就那么难啊!可惜刻录机坏了。
jimmin
论坛版主
帖子: 2138
注册时间: 2006-09-24 4:37
送出感谢: 0
接收感谢: 1 次

#15

帖子 jimmin » 2006-10-28 2:40

我安装好了,原来那个Input Not Supported是障眼法,显示Input Not Supported时其实是在加载内核等。

但是安装好后开机和关机的加载(就是不断OK的那个)每次都是黑屏显示Input Not Supported,这是怎么回事?
回复

回到 “老旧版本支持”