[分享]安装最新的firfox2.0浏览器

为当前最终发行版之前的所有版本提供支持
回复
头像
dogfox
论坛版主
帖子: 5309
注册时间: 2006-09-02 14:18
来自: 汉桑城
送出感谢: 1 次
接收感谢: 1 次
联系:

[分享]安装最新的firfox2.0浏览器

#1

帖子 dogfox » 2006-10-27 21:55

代码: 全选

sudo rm -rf ~/.mozilla
sudo rm -rf /usr/lib/firefox
在官方地址下载firefox2.0

代码: 全选

sudo mv firefox-2.0.tar.gz  /usr/lib
cd /usr/lib
sudo tar zxf  firefox-2.0.tar.gz
sudo rm firefox-2.0.tar.gz
cd firefox
sudo ./firfox
全世界linux爱好者联合起来 !
一切闭源操作系统都是纸老虎 !
要斗私批修,拒绝黑屏,使用linux !
让一部分人先用起Archlinux来 !
linux是第一生产力 !
讲正气,讲开源,讲free
要坚定不移的走开源的道路 !
linux明天会更好 !

dpkg -l |grep ^rc|awk '{print $2}' |tr ["\n"] [" "]|sudo xargs dpkg -P -
ubuntu粉丝群 26660836 已满员
jimmin
论坛版主
帖子: 2138
注册时间: 2006-09-24 4:37
送出感谢: 0
接收感谢: 1 次

#2

帖子 jimmin » 2006-10-27 22:10

是否要先用新力得删除firefox,再用

代码: 全选

sudo rm -rf ~/.mozilla 
sudo rm -rf /usr/lib/firefox
或是直接用上面的命令?
头像
dogfox
论坛版主
帖子: 5309
注册时间: 2006-09-02 14:18
来自: 汉桑城
送出感谢: 1 次
接收感谢: 1 次
联系:

#3

帖子 dogfox » 2006-10-27 22:23

jimmin 写了:是否要先用新力得删除firefox,再用

代码: 全选

sudo rm -rf ~/.mozilla 
sudo rm -rf /usr/lib/firefox
或是直接用上面的命令?
按我说的做
全世界linux爱好者联合起来 !
一切闭源操作系统都是纸老虎 !
要斗私批修,拒绝黑屏,使用linux !
让一部分人先用起Archlinux来 !
linux是第一生产力 !
讲正气,讲开源,讲free
要坚定不移的走开源的道路 !
linux明天会更好 !

dpkg -l |grep ^rc|awk '{print $2}' |tr ["\n"] [" "]|sudo xargs dpkg -P -
ubuntu粉丝群 26660836 已满员
孤笑客
帖子: 102
注册时间: 2006-04-14 19:49
来自: NYC
送出感谢: 0
接收感谢: 0
联系:

#4

帖子 孤笑客 » 2006-10-28 18:57

用这个方法怎么感觉就根在WINDOWS下不用“添加删除程序”,而是直接删除一样?
这么做了以后新立得怎么办啊??还有插件们!!
头像
karron
帖子: 6226
注册时间: 2005-06-11 14:03
来自: 不明真相的群众
送出感谢: 0
接收感谢: 0
联系:

#5

帖子 karron » 2006-10-28 19:41

不要用这个方法安装,官方下载的firefox解压就可以使用,不要覆盖系统自带的。你随便解压到那里,然后把你的快捷方式指定到新的firefox即可。
我的blog,关于技术,软件,linux,vim <---- 所有博客均被河蟹.
jimmin
论坛版主
帖子: 2138
注册时间: 2006-09-24 4:37
送出感谢: 0
接收感谢: 1 次

#6

帖子 jimmin » 2006-10-28 23:20

karron 写了:不要用这个方法安装,官方下载的firefox解压就可以使用,不要覆盖系统自带的。你随便解压到那里,然后把你的快捷方式指定到新的firefox即可。
官方的Linux firefox是移动版?

PS:为什么大家都要下载安装呢?新力得里的除了多了个语言插件有什么不好的吗?
孤笑客
帖子: 102
注册时间: 2006-04-14 19:49
来自: NYC
送出感谢: 0
接收感谢: 0
联系:

#7

帖子 孤笑客 » 2006-10-29 14:12

LS的嘛…我们就是好奇想装装2。0而已嘛…呵呵。其实我觉得你说的对,我现在新立得搞不定了。还想找人问问呢…
麦田小谷
帖子: 9
注册时间: 2006-10-28 21:39
送出感谢: 0
接收感谢: 0

我按这个方法装了,可是火狐却崩溃了

#8

帖子 麦田小谷 » 2006-10-30 0:29

按这个方法装了,可是火狐却崩溃了 :shock:
zink
帖子: 5
注册时间: 2006-10-30 20:58
送出感谢: 0
接收感谢: 0

#9

帖子 zink » 2006-10-30 21:02

我按照这个方法装的,firefox界面出来后我就关闭了,然后那个快捷方式不好用,到firefox文件夹里运行也不行。然后重新下了一个安装包,按照上面的方法又装了一遍运行sudo ./firfox 时出现如下问题

./run-mozilla.sh: line 131: 6575 Segmentation fault "$prog" ${1+"$@"}

咋办呢?ubuntu 不能上网了。 :cry:
头像
karron
帖子: 6226
注册时间: 2005-06-11 14:03
来自: 不明真相的群众
送出感谢: 0
接收感谢: 0
联系:

#10

帖子 karron » 2006-10-30 22:25

一不要用sudo来运行普通程序。二出现段错误是scim与这些软件冲突。解决方法请搜索论坛。
我的blog,关于技术,软件,linux,vim <---- 所有博客均被河蟹.
回复

回到 “老旧版本支持”