aMule和火狐联不上了

为当前最终发行版之前的所有版本提供支持
回复
pipago
帖子: 131
注册时间: 2006-07-14 21:04
送出感谢: 0
接收感谢: 0

aMule和火狐联不上了

#1

帖子 pipago » 2006-10-28 9:50

装完火狐2.0,按照网上的老办法做了
amule是一个linux版本的p2p文件分享软件。由于某些原因,可能在安装amule之后,firefox并不能自动把ed2k地址关联到amule.我们可以手动完成这一工作。

在firefox地址栏中输入about:config
新建一个Boolean,名字为network.protocol-handler.external.ed2k,值为true
新建一个String,名字为network.protocol-handler.app.ed2k,值为/usr/bin/ed2k.amule或者ed2k.amule
这样就OK了。这时候点击一个ed2k链接将会出现一个启动相应应用程序的提示。点击启动后, 这个ed2k链接将会被加入下载队列。前提是amule必须是已经开启着的。

如果你想在点一个ed2k链接的时候不出现提示,那么新建一个Boolean,名字为network.protocol-handler.warn-external.ed2k,值为false

update:ed2k.amule也可能为ed2k,具体可以在命令行下输入ed2k,然后tab查看
但是这次不管用了,是因为版本的问题?
springlarry
帖子: 286
注册时间: 2006-06-08 8:53
送出感谢: 0
接收感谢: 0

#2

帖子 springlarry » 2006-10-31 13:03

顶!我正在装6.1估计也是有这样的问题
summarx
帖子: 5
注册时间: 2006-05-05 20:23
送出感谢: 0
接收感谢: 0

#3

帖子 summarx » 2006-11-01 22:17

是的,我在6.10版本下也有这个问题,有没有什么好的解决方案?
madll
帖子: 1
注册时间: 2006-11-07 12:38
送出感谢: 0
接收感谢: 0

#4

帖子 madll » 2006-11-07 12:39

安装amule utils这个包,名为network.protocol-handler.app.ed2k的字符串值设为/usr/bin/ed2k,就可以了
pipago
帖子: 131
注册时间: 2006-07-14 21:04
送出感谢: 0
接收感谢: 0

#5

帖子 pipago » 2006-11-07 18:20

madll 写了:安装amule utils这个包,名为network.protocol-handler.app.ed2k的字符串值设为/usr/bin/ed2k,就可以了
有效,多谢了。
ubuntu-er
帖子: 22
注册时间: 2007-07-13 13:31
送出感谢: 0
接收感谢: 0

#6

帖子 ubuntu-er » 2007-08-24 1:41

最终的解决办法再总结一下(在Firefox 2.0以上版本都有效):

在firefox地址栏中输入about:config
1、新建一个Boolean,名字为network.protocol-handler.external.ed2k,值为true
2、新建一个String,名字为network.protocol-handler.app.ed2k,值为/usr/bin/ed2k(此不能出错,不然无法找到ed2k程序的)
3、如果你想在点一个ed2k链接的时候不出现提示,那么新建一个Boolean,名字为network.protocol-handler.warn-external.ed2k,值为false

谢谢前人的总结
李丑男
帖子: 320
注册时间: 2007-08-29 22:44
送出感谢: 0
接收感谢: 0
联系:

#7

帖子 李丑男 » 2007-09-05 21:26

谢谢了。
回复

回到 “老旧版本支持”