如何用PCMCIA接口的CDMA上网卡上网

为当前最终发行版之前的所有版本提供支持
回复
ztkx
帖子: 9
注册时间: 2005-10-26 15:15
送出感谢: 0
接收感谢: 0

如何用PCMCIA接口的CDMA上网卡上网

#1

帖子 ztkx » 2006-10-29 16:26

我用的是ubuntu6.06,查了不少资料,以为终于可以用PCMCIA-CDMA上网了,可是最后一步还是不行,这是在我的机器上得到的信息,我用的是PCMCIA的上网卡,各位帮帮忙
1、cat /proc/bus/usb/devices

T: Bus=02 Lev=01 Prnt=01 Port=00 Cnt=01 Dev#= 2 Spd=12 MxCh= 0
D: Ver= 1.10 Cls=00(>ifc ) Sub=00 Prot=00 MxPS= 8 #Cfgs= 1
P: '''Vendor=0df7 ProdID=0620 Rev= 0.10'''
C:* #Ifs= 1 Cfg#= 1 Atr=a0 MxPwr=100mA
I: If#= 0 Alt= 0 #EPs= 3 Cls=ff(vend.) Sub=00 Prot=00 Driver=pl2303
E: Ad=81(I) Atr=03(Int.) MxPS= 10 Ivl=1ms
E: Ad=02(O) Atr=02(Bulk) MxPS= 64 Ivl=0ms
E: Ad=83(I) Atr=02(Bulk) MxPS= 64 Ivl=0ms

2、dmesg |grep usb
[4294684.498000] usbcore: registered new driver usbfs
[4294684.498000] usbcore: registered new driver hub
[4294684.811000] usb 1-2: new low speed USB device using uhci_hcd and
address 2
[4294685.172000] usb 2-1: new full speed USB device using uhci_hcd and
address 2
[4294685.296000] usbcore: registered new driver hiddev
[4294685.502000] usb 3-1: new full speed USB device using uhci_hcd and
address 2
[4294685.661000] input: USB HID v1.00 Mouse [PS/2+USB Mouse] on
usb-0000:00:1d.0-2
[4294685.661000] usbcore: registered new driver usbhid
[4294685.661000] drivers/usb/input/hid-core.c: v2.6:USB HID core driver
[4294685.681000] usb-storage: device found at 2
[4294685.681000] usb-storage: waiting for device to settle before scanning
[4294685.681000] usbcore: registered new driver usb-storage
[4294690.683000] usb-storage: device scan complete
[4294703.044000] usbcore: registered new driver usbserial
[4294703.045000] drivers/usb/serial/usb-serial.c: USB Serial support
registered for generic
'''[4294703.046000] usbcore: registered new driver usbserial_generic
[4294703.046000] drivers/usb/serial/usb-serial.c: USB Serial Driver core
[4294703.107000] drivers/usb/serial/usb-serial.c: USB Serial support
registered for pl2303
[4294703.108000] usb 2-1: pl2303 converter now attached to ttyUSB0
[4294703.108000] usbcore: registered new driver pl2303
[4294703.108000] drivers/usb/serial/pl2303.c: Prolific PL2303 USB to
serial adaptor driver'''

3、wvdial.conf

[modem0]
Modem = /dev/ttyUSB0
Baud = 115200
SetVolume = 0
Dial Command = ATDT
Init1 = ATZ
FlowControl = Hardware (CRTSCTS)
[Dialer cdma]
Phone = #777
Username = CARD
Password = CARD
Stupid Mode = 1
Inherits = Modem0

4、wvdial cdma
--> WvDial: Internet dialer version 1.55
--> '''Cannot get information for serial port.'''
--> Initializing modem.
--> Sending: ATZ
--> Sending: ATQ0

这是wvdialconf的信息
Editing `/etc/wvdial.conf'.

Scanning your serial ports for a modem.

ttyS0<Info>: Device or resource busy
Modem Port Scan<*1>: S0 S1 S2 S3
ttyS4<*1>: ATQ0 V1 E1 -- failed with 2400 baud, next try: 9600 baud
ttyS4<*1>: ATQ0 V1 E1 -- failed with 9600 baud, next try: 115200 baud
ttyS4<*1>: ATQ0 V1 E1 -- and failed too at 115200, giving up.
Modem Port Scan<*1>: S5 S6 S7 S8
Modem Port Scan<*1>: S9 S10 S11 S12 S13 S14 S15 S16
Modem Port Scan<*1>: S17 S18 S19 S20 S21 S22 S23 S24
Modem Port Scan<*1>: S25 S26 S27 S28 S29 S30 S31 S32
Modem Port Scan<*1>: S33 S34 S35 S36 S37 S38 S39 S40
Modem Port Scan<*1>: S41 S42 S43 S44 S45 S46 S47
WvModem<*1>: Cannot get information for serial port.
ttyUSB0<*1>: ATQ0 V1 E1 --
ttyUSB0<*1>: failed with 2400 baud, next try: 9600 baud
ttyUSB0<*1>: ATQ0 V1 E1 -- failed with 9600 baud, next try: 115200 baud
ttyUSB0<*1>: ATQ0 V1 E1 -- and failed too at 115200, giving up.


Sorry, no modem was detected! Is it in use by another program?
Did you configure it properly with setserial?

Please read the FAQ at http://open.nit.ca/wiki/?WvDialwvdialconf
Editing `/etc/wvdial.conf'.

Scanning your serial ports for a modem.

ttyS0<Info>: Device or resource busy
Modem Port Scan<*1>: S0 S1 S2 S3
ttyS4<*1>: ATQ0 V1 E1 -- failed with 2400 baud, next try: 9600 baud
ttyS4<*1>: ATQ0 V1 E1 -- failed with 9600 baud, next try: 115200 baud
ttyS4<*1>: ATQ0 V1 E1 -- and failed too at 115200, giving up.
Modem Port Scan<*1>: S5 S6 S7 S8
Modem Port Scan<*1>: S9 S10 S11 S12 S13 S14 S15 S16
Modem Port Scan<*1>: S17 S18 S19 S20 S21 S22 S23 S24
Modem Port Scan<*1>: S25 S26 S27 S28 S29 S30 S31 S32
Modem Port Scan<*1>: S33 S34 S35 S36 S37 S38 S39 S40
Modem Port Scan<*1>: S41 S42 S43 S44 S45 S46 S47
WvModem<*1>: Cannot get information for serial port.
ttyUSB0<*1>: ATQ0 V1 E1 --
ttyUSB0<*1>: failed with 2400 baud, next try: 9600 baud
ttyUSB0<*1>: ATQ0 V1 E1 -- failed with 9600 baud, next try: 115200 baud
ttyUSB0<*1>: ATQ0 V1 E1 -- and failed too at 115200, giving up.


Sorry, no modem was detected! Is it in use by another program?
Did you configure it properly with setserial?

Please read the FAQ at http://open.nit.ca/wiki/?WvDial
ggwang
帖子: 25
注册时间: 2008-10-03 12:34
送出感谢: 0
接收感谢: 0

Re: 如何用PCMCIA接口的CDMA上网卡上网

#2

帖子 ggwang » 2009-06-17 16:35

和我的问题一样,所不同的是我重启几次后,会碰到几次能拨上去的情形。
我的版本也是6.0.6,卡是华为EC1260!
解决了的话请再贴出来!
回复

回到 “老旧版本支持”