[问题]请问什么参数可以让apt不检查依存关系强制安装

为当前最终发行版之前的所有版本提供支持
回复
头像
xjflyttp
帖子: 281
注册时间: 2006-10-18 0:36
来自: Core
送出感谢: 0
接收感谢: 0
联系:

[问题]请问什么参数可以让apt不检查依存关系强制安装

#1

帖子 xjflyttp » 2006-10-30 23:47

[问题]请问什么参数可以让apt不检查依存关系强制安装


代码: 全选

localhost:~/vim70$ sudo apt-get install gcc g++
Reading package lists... Done
Building dependency tree
Reading state information... Done
gcc is already the newest version.
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
  g++: Depends: g++-4.0 (>= 4.0.3) but it is not going to be installed
E: Broken packages
xjflyttp@localhost:~/vim70$ sudo apt-get install gcc
Reading package lists... Done
Building dependency tree
Reading state information... Done
gcc is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
xjflyttp@localhost:~/vim70$ sudo apt-get install g++
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.

Since you only requested a single operation it is extremely likely that
the package is simply not installable and a bug report against
that package should be filed.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
  g++: Depends: g++-4.0 (>= 4.0.3) but it is not going to be installed
E: Broken packages
搞不太明白为什么会这样``````````````自从把6.06用apt-get dist-upgrade以后就到处不自在`````
T60p/T7600/2G/WD1600BJKT/BT/AR5008/V5200/15' QXGA
回复

回到 “老旧版本支持”