[教學] 在EDGY上安裝NV驅動以及beryl

为当前最终发行版之前的所有版本提供支持
头像
yanzilme
帖子: 253
注册时间: 2006-11-01 3:21
送出感谢: 0
接收感谢: 0

[教學] 在EDGY上安裝NV驅動以及beryl

#1

帖子 yanzilme » 2006-11-02 0:11

大家好,我是台灣的同胞
在這邊分享我成功安裝的經驗

以下是我參考的地方
http://wiki.beryl-project.org/index.php ... dgy/nVIDIA
about29152.html


首先我在edgy上按照以上的教學,一定都會在驅動安裝完要重啟的時候出現xserver錯誤
經過幾天的反覆研究,確定我安裝的方法無誤,可是卻無法成功
後來知道正確的方法了,現在就分享一下我成功的安裝方法

我的硬體配置
E6300
GIGA 965P DS3
創見DDR2 667 1G*2
PIONEER A08
NEC 1300A
WD 3200YS
SB LIVE
GeForce 7900gt

方法大致如同我參考的那兩個網頁
但為求方便,我把它放在這邊給大家參考一下


一.安裝NV驅動

1.編輯sudo gedit /etc/apt/sources.list
加入來源deb http://beryl-mirror.lupine.me.uk/beryl edgy beryl


2.在終端及下敲入

代码: 全选

sudo apt-get update
sudo apt-get install nvidia-glx
sudo nvidia-xconfig

3.cartl+alt+backspace
看登入的時候有沒有出現nv的logo圖


二.安裝beryl

1.加入來源

代码: 全选

sudo gedit /etc/apt/sources.list
加入deb http://media.blutkind.org/xgl/ edgy main-edgy
儲存後關閉


2.終端機中輸入

代码: 全选

wget http://media.blutkind.org/xgl/quinn.key.asc -O - | sudo apt-key add -
sudo apt-get update
sudo apt-get install xserver-xgl libgl1-mesa xserver-xorg libglitz-glx1 beryl emerald-themes

3.終端機輸入sudo gedit /etc/gdm/gdm.conf-custom
在[servers] 的後面加入

代码: 全选

1=Xgl 

[server-Xgl] 
name=Xgl server 
command=/usr/bin/Xgl -fullscreen -br -accel xv:pbuffer -accel glx:pbuffer -dpi 100 -nolisten tcp 
flexible=true

4.修改sudo gedit /etc/gdm/gdm.conf 設定檔
按CARTL+F開啟搜尋
存找"0=Standard"
將其修改成"1=Standard"

再搜尋"GdmXserverTimeout=10"
再將其修改為"GdmXserverTimeout=50"


5.加入啟動
系統 >首選項>會話>啟動程序
加入"beryl-manager"跟"beryl-xgl"這兩項
sudo reboot
gai1020
帖子: 34
注册时间: 2005-08-06 18:59
送出感谢: 0
接收感谢: 0

#2

帖子 gai1020 » 2006-11-05 23:50

我也碰到过这个问题。
windtrue
帖子: 68
注册时间: 2006-01-08 19:24
来自: 广州
送出感谢: 0
接收感谢: 0
联系:

#3

帖子 windtrue » 2006-11-06 0:56

hohho.....
Thanks a lot
I realized my cool desktop by following this tips
great,and wonderful Beryl
:lol:
cpp
帖子: 13
注册时间: 2006-11-06 13:34
送出感谢: 0
接收感谢: 0

#4

帖子 cpp » 2006-11-06 20:18

谢谢 我也安装成功了 就是发现太华丽了 印响了操作了 对了,我的小键盘不对了 灯亮的时候反而不能输入数字了 郁闷哦
nv的卡 5200
ghost0
帖子: 364
注册时间: 2006-08-11 0:28
送出感谢: 0
接收感谢: 0

#5

帖子 ghost0 » 2006-11-08 1:54

nv其实不用安装xgl反而效果会更好,xgl会导致键盘设置以及图标的一些小问题,虽然可以解决,但毕竟麻烦,还是直接用beta版驱动来支持更好,不用多余的启动脚本,什么时候想开效果了,执行一下beryl-manager就行,而切资源占用也比用xgl省
aaronbai
帖子: 163
注册时间: 2006-10-15 10:12
送出感谢: 0
接收感谢: 0

#6

帖子 aaronbai » 2006-11-08 8:37

无法下载 http://beryl-mirror.lupine.me.uk/beryl/ ... gy/Release Unable to find expected entry beryl/binary-i386/Packages in Meta-index file (malformed Release file?)
正在读取软件包列表... 完成
E: 有一些索引文件不能下载,它们可能被忽略了,也可能转而使用了旧的索引文件。
Gmail: baifh03@gmail.com
MSN:aaronminwoo@hotmail.com
喜欢LINUX的加我!
一起学习讨论!
xzymail
帖子: 513
注册时间: 2006-06-29 11:36
送出感谢: 0
接收感谢: 0

#7

帖子 xzymail » 2006-11-08 13:20

支持5楼的兄弟,我也知道咯,XGL是比较占资源的,不过,按你的方法安装了,可以,可是就窗口的边框不见了
xzymail
帖子: 513
注册时间: 2006-06-29 11:36
送出感谢: 0
接收感谢: 0

#8

帖子 xzymail » 2006-11-08 13:21

我是按http://forum.ubuntu.org.cn/viewtopic.php?t=30101的方法安装的,可以,可是就是窗口的边框不见了,好奇怪,还有,终端也是一片白色,请问有没有解决的方法
头像
milkboy_x
帖子: 431
注册时间: 2006-06-13 11:02
来自: 广东 广州
送出感谢: 0
接收感谢: 0

#9

帖子 milkboy_x » 2006-11-08 15:04

:? 还是用XGL+Beryl的方式,为什么不用NV 1.0-9629驱动+Beryl的方式呢?
feex
帖子: 85
注册时间: 2005-09-29 1:16
送出感谢: 0
接收感谢: 0
联系:

#10

帖子 feex » 2006-11-08 16:42

偶用的是 legacy 的驱动 , 用不了 9629啊 , 555
gmlbh
帖子: 406
注册时间: 2006-03-21 10:47
送出感谢: 0
接收感谢: 0

#11

帖子 gmlbh » 2006-11-08 23:30

就是咯,白白浪费了7900那么好的卡阿。
xzymail
帖子: 513
注册时间: 2006-06-29 11:36
送出感谢: 0
接收感谢: 0

#12

帖子 xzymail » 2006-11-09 0:28

gmlbh兄是7900吗??呵,我的6100按你的方法安装的,已经是很好的启动了beryl了
kofkim2003
帖子: 4
注册时间: 2007-07-03 11:34
送出感谢: 0
接收感谢: 0

这个驱动能否支持8500?

#13

帖子 kofkim2003 » 2007-07-08 17:09

这个驱动能否支持8500?
katkat
帖子: 6
注册时间: 2007-07-10 18:35
送出感谢: 0
接收感谢: 0

#14

帖子 katkat » 2007-07-10 18:41

挺难搞的吗 :shock: :shock: :shock:
775ftft
帖子: 83
注册时间: 2007-04-11 19:05
送出感谢: 0
接收感谢: 0

#15

帖子 775ftft » 2007-07-20 14:41

不错,支持
回复

回到 “老旧版本支持”