edgy下intel显卡安装beryl

为当前最终发行版之前的所有版本提供支持
头像
longxj
帖子: 215
注册时间: 2006-10-07 15:17
送出感谢: 0
接收感谢: 0

edgy下intel显卡安装beryl

#1

帖子 longxj » 2006-11-02 9:46

本帖已很长时间没有更新了,如果有什么问题,请另找其它资源,推荐上beryl官方网站
ubuntu: edgy 显卡:intel

安装步骤:
1.编辑/etc/apt/sources.list文件,添加下列任一源
deb http://www.beerorkid.com/compiz edgy main-edgy
deb http://media.blutkind.org/xgl/ edgy main-edgy
deb http://compiz-mirror.lupine.me.uk/ edgy main-edgy
deb http://ubuntu.compiz.net/ edgy main-edgy

2.加入 GPG Key

wget http://www.beerorkid.com/compiz/quinn.key.asc -O - | sudo apt-key add -
wget http://media.blutkind.org/xgl/quinn.key.asc -O - | sudo apt-key add -
wget http://compiz-mirror.lupine.me.uk/quinn.key.asc -O - | sudo apt-key add -
wget http://ubuntu.compiz.net/quinn.key.asc -O - | sudo apt-key add -
3.sudo apt-get update

4.安裝 Beryl

sudo apt-get install beryl-core beryl-plugins beryl-plugins-data emerald beryl-settings beryl-manager beryl beryl-dev emerald-themes

5.修改 /etc/X11/xorg.conf

Device 敘述部份, 加上

Option "XAANoOffscreenPixmaps" "true"

文件最后加上:

Section "Extensions"
Option "Composite" "true"
EndSection

6.系统->首选项->会话->启动程序 添加/usr/bin/beryl-manager

7.Reboot

注意:在完成6以后,千万不要运行beryl-manager,否则会出错。
如果运行beryl时,窗口标题栏闪烁,左击红宝石,选择退出,就不会闪烁了。

在/etc/environment里加上: AWT_TOOLKIT="MToolkit",可以让原本不能显示的java程序也能正常显示

beryl-svn install methods reference:

1./etc/apt/sources.list :
deb http://3v1n0.tuxfamily.org edgy beryl-svn
deb-src http://3v1n0.tuxfamily.org edgy beryl-svn

2.wget http://3v1n0.tuxfamily.org/EDD1E155.gpg -O- | sudo apt-key add -


或者

1.http://3v1n0.tuxfamily.org/pool/edgy/beryl-svn/

下载那些包,dpkg手动安装试试看。
上次由 longxj 在 2007-04-23 15:54,总共编辑 6 次。
go2debug
帖子: 13
注册时间: 2006-01-15 16:47
送出感谢: 0
接收感谢: 0

#2

帖子 go2debug » 2006-11-02 16:15

对于intel显卡无须修改xorg.conf就可以用beryl了。
xcity
帖子: 135
注册时间: 2006-09-20 17:11
送出感谢: 0
接收感谢: 0

#3

帖子 xcity » 2006-11-02 23:03

好像还是需要修改xorg.conf的吧,要不然不能composite啊!
wchcastle
帖子: 78
注册时间: 2005-08-20 20:56
送出感谢: 0
接收感谢: 0

#4

帖子 wchcastle » 2006-11-03 0:19

我也是今天装的
显卡是intel 915
参考的是 http://wiki.beryl-project.org/index.php ... pper/AiGLX

完成后竟然是白屏
然后翻了前面有个帖子
装了intel的显卡驱动才解决了
头像
longxj
帖子: 215
注册时间: 2006-10-07 15:17
送出感谢: 0
接收感谢: 0

#5

帖子 longxj » 2006-11-03 11:34

4.安裝 Beryl

sudo apt-get install beryl-core beryl-plugins beryl-plugins-data emerald beryl-settings beryl-manager beryl beryl-dev emerald-themes

命令中不能有换行,请注意哦!(复制时请注意)
头像
longxj
帖子: 215
注册时间: 2006-10-07 15:17
送出感谢: 0
接收感谢: 0

#6

帖子 longxj » 2006-11-03 14:37

5.修改 Xorg.conf

Device 敘述部份, 加上

Option "XAANoOffscreenPixmaps“ "true"

修改为:
Option "XAANoOffscreenPixmaps" "true"
以前的双引号输错了。
aBiNg
帖子: 1331
注册时间: 2006-07-09 12:22
来自: 南京
送出感谢: 0
接收感谢: 2 次

#7

帖子 aBiNg » 2006-11-03 19:46

edgy下xserver是xorg7.1版本的,对于Intel系列显卡已自动开启加速驱动,因而无须对xorg.conf作任何修改!
故,安装beryl只需三步:

1.添加源
2.$sudo apt-get update && sudo apt-get install beryl emerald-themes //依赖包自动安装
2.$sudo reboot
happyrbbit
帖子: 4
注册时间: 2006-10-29 10:54
送出感谢: 0
接收感谢: 0

出错了 ,不懂该如何解决

#8

帖子 happyrbbit » 2006-11-14 19:18

命中 http://cn.archive.ubuntu.com dapper-backports/multiverse Sources
下载 5596B,耗时 2m47s (33B/s)
无法下载 http://www.beerorkid.com/compiz/dists/dapper/Release Unable to find ex pected entry main-dapper/binary-i386/Packages in Meta-index file (malformed Rel ease file?)
正在读取软件包列表... 完成
E: 有一些索引文件不能下载,它们可能被忽略了,也可能转而使用了旧的索引文件。
root@zzly:~# sudo apt-get install beryl-core beryl-plugins beryl-plugins-data emerald beryl-settings beryl-manager beryl beryl-dev emerald-themes

当我 update后 就出现上面的提示 !!我是个超级菜鸟,请高手指点一二,还有我忽略了这步继续往下装,在安装软件时
它又提示:
root@zzly:~# sudo apt-get install beryl-core beryl-plugins 正在读取软件包列表... 完成
正在分析软件包的依赖关系树... 完成
E: 无法找到软件包 beryl-core
root@zzly:~# sudo apt-get install beryl-plugins
正在读取软件包列表... 完成
正在分析软件包的依赖关系树... 完成
E: 无法找到软件包 beryl-plugins

??这又是怎么回事阿???高手 帮帮忙阿 !!
Andrewlinux
帖子: 3
注册时间: 2006-11-02 10:32
送出感谢: 0
接收感谢: 0

楼主,请问这是怎回事?谢谢!!

#9

帖子 Andrewlinux » 2006-11-16 12:30

root@ubuntu:~# beryl-manager
beryl-manager: /lib/tls/i686/cmov/libc.so.6: version `GLIBC_2.4' not found (required by beryl-manager)
root@ubuntu:~# apt-get install glibc_2.4
正在读取软件包列表... 完成
正在分析软件包的依赖关系树... 完成
E: 无法找到软件包 glibc_2.4
:cry:
狂客
帖子: 30
注册时间: 2006-01-05 11:02
送出感谢: 0
接收感谢: 0
联系:

#10

帖子 狂客 » 2006-11-19 13:34

这里是正确的安装方法, Ubuntu 6.10 默认已经支持 AiGLX
http://wiki.beryl-project.org/index.php ... Edgy/AiGLX
头像
longxj
帖子: 215
注册时间: 2006-10-07 15:17
送出感谢: 0
接收感谢: 0

#11

帖子 longxj » 2006-11-19 15:40

8楼 ,你的版本是dapper吗?
我看 你的源是dapper的源呢
头像
TualatriX
帖子: 359
注册时间: 2006-11-17 20:07
来自: 杭州/宁波
送出感谢: 0
接收感谢: 0
联系:

#12

帖子 TualatriX » 2006-11-24 13:47

wget http://compiz-mirror.lupine.me.uk/quinn.key.asc -O - | sudo apt-key add -
这个出现404错误啊。找不到了。
erniu
帖子: 18
注册时间: 2005-04-11 16:20
送出感谢: 0
接收感谢: 0

#13

帖子 erniu » 2006-11-25 21:32

我也是照着这个帖子的步骤作的,也参考了http://wiki.beryl-project.org/index.php/Install/Ubuntu/Dapper/AiGLX,但还是不行。
我的系统是hiweed1.0,intel 855集成显卡。
在终端上输入
luopeng@luopeng-laptop:~$ beryl-manager
luopeng@luopeng-laptop:~$ libGL warning: 3D driver claims to not support visual 0x4b
XGL Absent, assuming AIGLX
compiz: Another window manager is already running on screen: 0
compiz: No manageable screens found on display :0.0
请问是什么原因呢?
我自由,我选择
----------------------------------------------------------------
windows xp+ubuntu
viooo笔记本
pentium-M 1.2G
256M
40G
intel 855GM
8xDVD
头像
bricksun
帖子: 85
注册时间: 2006-05-13 8:17
来自: 比京
送出感谢: 0
接收感谢: 0

#14

帖子 bricksun » 2006-12-02 9:23

按照楼主的帖子配置成功,谢谢。发帖庆祝。
lukefury
帖子: 138
注册时间: 2006-06-03 15:41
送出感谢: 0
接收感谢: 0

#15

帖子 lukefury » 2006-12-18 15:57

现在的问题是我的窗口标题栏闪烁,怎么 办?
回复

回到 “老旧版本支持”