为什么不能用apt-get呢,每次用都会出现下面的错误,是怎么回事?

为当前最终发行版之前的所有版本提供支持
回复
dotboy
帖子: 37
注册时间: 2006-11-01 15:10
送出感谢: 0
接收感谢: 0

为什么不能用apt-get呢,每次用都会出现下面的错误,是怎么回事?

#1

帖子 dotboy » 2006-11-02 18:28

E: 无法获得锁 /var/lib/dpkg/lock - open (11 Resource temporarily unavailable)
E: Unable to lock the administration directory (/var/lib/dpkg/), is another process using it?
但是我用软件更新包就能从上海交通大学的源下载东西,在终端下就是不可以,这是为什么?
pipago
帖子: 131
注册时间: 2006-07-14 21:04
送出感谢: 0
接收感谢: 0

#2

帖子 pipago » 2006-11-02 18:34

新立德和终端不能同时打开
dotboy
帖子: 37
注册时间: 2006-11-01 15:10
送出感谢: 0
接收感谢: 0

#3

帖子 dotboy » 2006-11-02 18:35

那我没有打开新立德的时候也是会出现这个消息的啊?
pipago
帖子: 131
注册时间: 2006-07-14 21:04
送出感谢: 0
接收感谢: 0

#4

帖子 pipago » 2006-11-02 18:56

dotboy 写了:那我没有打开新立德的时候也是会出现这个消息的啊?
你确定?看看新利得的进程有没有关闭。
dotboy
帖子: 37
注册时间: 2006-11-01 15:10
送出感谢: 0
接收感谢: 0

#5

帖子 dotboy » 2006-11-02 19:03

make: *** 没有指明目标并且找不到 makefile。 停止。
这是什么原因呢?
pipago
帖子: 131
注册时间: 2006-07-14 21:04
送出感谢: 0
接收感谢: 0

#6

帖子 pipago » 2006-11-02 20:00

dotboy 写了:make: *** 没有指明目标并且找不到 makefile。 停止。
这是什么原因呢?
一般是configure没有完成,看看终端给你的提示信息。
pure
帖子: 69
注册时间: 2006-10-20 1:03
送出感谢: 0
接收感谢: 0

#7

帖子 pure » 2006-11-02 20:10

这个不是很清楚的。
pipago
帖子: 131
注册时间: 2006-07-14 21:04
送出感谢: 0
接收感谢: 0

#8

帖子 pipago » 2006-11-02 20:13

pure 写了:这个不是很清楚的。
把./configure之后的信息复制,然后你可以贴在这里。

问题通常是缺少某些库文件造成的。
dotboy
帖子: 37
注册时间: 2006-11-01 15:10
送出感谢: 0
接收感谢: 0

#9

帖子 dotboy » 2006-11-02 20:31

什么都没有去的情况下,./configure (对GCC的安装时)又成功了,不知道怎么回事,我再试试其它的!呵呵
dotboy
帖子: 37
注册时间: 2006-11-01 15:10
送出感谢: 0
接收感谢: 0

#10

帖子 dotboy » 2006-11-02 20:36

: Illegal seek
make[1]: *** [genautomata.o] 错误 1
make[1]: Leaving directory `/home/dotboy/Work/gcc-3.4.1/gcc'
make: *** [all-gcc] 错误 2
这是刚才装GCC时最后出现的问题,怎么弄?
cx191
帖子: 1
注册时间: 2012-03-15 21:51
送出感谢: 0
接收感谢: 0

Re: 为什么不能用apt-get呢,每次用都会出现下面的错误,是怎么回事?

#11

帖子 cx191 » 2012-03-15 21:59

发现了一个解决办法
本人用的是ubuntu 10.04
1.终端输入sudo gedit //启动gedit
2.用gedit打开/var/lib/dpkg/lock
3.在lock文件里随便输入了几个字母,保存,退出gedit
4. 终端输入 sudo apt-get update,顺利执行并成功更新应用程序

PS:本人不知道什么原因,算是歪打正着,楼主你看看这个方法是否适用于你。
期盼高手帮忙解释下原理
回复

回到 “老旧版本支持”