请教问题<stdio.h>早不到啊

为当前最终发行版之前的所有版本提供支持
回复
jasonzou
帖子: 21
注册时间: 2006-11-01 14:45
送出感谢: 0
接收感谢: 0

请教问题<stdio.h>早不到啊

#1

帖子 jasonzou » 2006-11-02 23:04

我需要gcc一个.c格式的东西,在终端输入

代码: 全选

gcc -o io_fltr io_fltr.c
然后提示的是

代码: 全选

stdio.h: No such file or directory
以前在其他的linux下编译这个文件不可能出这样问题啊,同时我查询文件时没有查到stdio.h这个,可这不是c语言最标准的东西吗。
我按照C/C++编译环境安装配置介绍中的

代码: 全选

sudo apt-get install gcc g++ libgcc1 libg++ make gdb
然后它出现如下信息

代码: 全选

正在读取软件包列表... 完成
正在分析软件包的依赖关系树       
Reading state information... 完成      
gcc 已经是最新的版本了。
libgcc1 已经是最新的版本了。
注意,我选了 libg++2.8.1.3-glibc2.2 而非 libg++
make 已经是最新的版本了。
gdb 已经是最新的版本了。
有一些软件包无法被安装。如果您用的是不稳定(unstable)发行版,这也许是
因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件
包尚未被创建或是它们还在新到(incoming)目录中。
下列的信息可能会对解决问题有所帮助:

下列的软件包有不能满足的依赖关系:
  g++: 依赖: g++-4.0 (>= 4.0.3) 但是它将不会被安装
E: 无法安装的软件包

然后我再次gcc结果一样,stdio.h: No such file or directory,我的shell是csh
aBiNg
帖子: 1331
注册时间: 2006-07-09 12:22
来自: 南京
送出感谢: 0
接收感谢: 2 次

#2

帖子 aBiNg » 2006-11-02 23:24

代码: 全选

~$ dpkg -S stdio.h   //查找提供stdio.h头文件的软件包,即只要安装下列包其中之一,stdio.h这个头文件就定会存在的
libc6-dev: /usr/include/bits/stdio.h
perl: /usr/lib/perl/5.8.8/CORE/nostdio.h
libglib2.0-dev: /usr/include/glib-2.0/glib/gstdio.h
libc6-dev: /usr/include/stdio.h
如果楼主已经正确安装了编译环境,那么在*.c源程序中定要申明这个头文件:

代码: 全选

#include <stdio.h>
这是新版gcc的"正规"法则.
jasonzou
帖子: 21
注册时间: 2006-11-01 14:45
送出感谢: 0
接收感谢: 0

#3

帖子 jasonzou » 2006-11-02 23:45

感谢楼上的解答:
还有个问题,我的csh里面设置完了,却没有.cshrc,我的软件需要配置些启动变量,我只有以前写好的.cshrc,bash我不会啊,请教该怎么办啊
ShareDuck
帖子: 14
注册时间: 2006-10-16 13:40
送出感谢: 0
接收感谢: 0

#4

帖子 ShareDuck » 2006-11-02 23:51

C我就不清楚了。
但如果是C++的话,所有标准C++的头文件都是没有后缀的。

但这个是C的,所以偶也郁闷了。
回复

回到 “老旧版本支持”