[问题重新编辑过了] apt-get提示依赖关系出错 & 无法安装和删除程序

为当前最终发行版之前的所有版本提供支持
回复
扎怀俩怀
帖子: 14
注册时间: 2006-09-16 20:48
送出感谢: 0
接收感谢: 0

[问题重新编辑过了] apt-get提示依赖关系出错 & 无法安装和删除程序

#1

帖子 扎怀俩怀 » 2006-11-03 18:48

抱歉,那么一堆东西,谁都不愿意看下去了吧。于是,把问题整理一下。

新利得提示我说有依赖关系出错,无法更新程序,不能装,也不能删了。

于用新利得的“修复依赖关系”,即apt-get -f -install,得到以下错误

代码: 全选

E: /var/cache/apt/archives/gaim_1%3a2.0.0+svn20061006.1-1hiweed1_i386.deb: 正试图覆盖“/usr/lib/gaim/libqq.la”,它属于软件包 openq
即使我将/usr/lib/gaim/目录下的文件都移走了,也还是出现这个问题。实在是搞不定了XD

请知者不惜教导在下
上次由 扎怀俩怀 在 2006-11-04 20:41,总共编辑 2 次。
扎怀俩怀
帖子: 14
注册时间: 2006-09-16 20:48
送出感谢: 0
接收感谢: 0

#2

帖子 扎怀俩怀 » 2006-11-04 20:04

没人能够帮助我吗?

请能者帮帮我吧。

这个问题我自己没有办法啊
扎怀俩怀
帖子: 14
注册时间: 2006-09-16 20:48
送出感谢: 0
接收感谢: 0

#3

帖子 扎怀俩怀 » 2006-11-04 20:08

软件现在装也有问题了。如下,而且,beryl也删不了
为了装beryl,用disc-update(好像是这个)更新了系统,会不会是这个原因?
root@liang-desktop:/home/liang# sudo apt-get install tuxkart
正在读取软件包列表... 完成
正在分析软件包的依赖关系树... 完成
您可能需要运行“apt-get -f install”来纠正下列错误:
下列的软件包有不能满足的依赖关系:
gaim: 依赖: gaim-data (= 1:1.5.0+1.5.1cvs20051015-1ubuntu10)
tuxkart: 依赖: plib1.8.4c2 但是它将不会被安装
依赖: tuxkart-data (= 0.4.0-4.1build1) 但是它将不会被安装
E: 有未能满足的依赖关系。请尝试不指明软件包的名字来运行“apt-get -f install”(也可以指定一个解决办法)。

代码: 全选

root@liang-desktop:/home/liang# sudo apt-get install tuxkart
正在读取软件包列表... 完成
正在分析软件包的依赖关系树... 完成
您可能需要运行“apt-get -f install”来纠正下列错误:
下列的软件包有不能满足的依赖关系:
  gaim: 依赖: gaim-data (= 1:1.5.0+1.5.1cvs20051015-1ubuntu10)
  tuxkart: 依赖: plib1.8.4c2 但是它将不会被安装
           依赖: tuxkart-data (= 0.4.0-4.1build1) 但是它将不会被安装
E: 有未能满足的依赖关系。请尝试不指明软件包的名字来运行“apt-get -f install”(也可以指定一个解决办法)。
扎怀俩怀
帖子: 14
注册时间: 2006-09-16 20:48
送出感谢: 0
接收感谢: 0

#4

帖子 扎怀俩怀 » 2006-11-05 14:05

出错啊,软件都装不了啊!

代码: 全选

正在设置 heimdal-kdc (0.7.1-1ubuntu3) ...
kstash: writing key to `/var/lib/heimdal-kdc/m-key'
kstash: writing master key file: unable to find realm of host liang-desktop
dpkg:处理 heimdal-kdc (--configure)时出错:
 子进程·post-installation script·返回了错误号·1
在处理时有错误发生:
 [color=red]heimdal-kdc[/color]
E: Sub-process /usr/bin/dpkg returned an error code (1)
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#5

帖子 eexpress » 2006-11-05 14:46

找到破损的包,先全部卸载。
另外,使用sudo aptitude install xxxx,软件可以提供多种的方案可选择。比较智能些。当然不是万能的。
● 鸣学
头像
karron
帖子: 6226
注册时间: 2005-06-11 14:03
来自: 不明真相的群众
送出感谢: 0
接收感谢: 0
联系:

#6

帖子 karron » 2006-11-05 15:59

你安装了openq?把这个卸载掉吧
我的blog,关于技术,软件,linux,vim <---- 所有博客均被河蟹.
charlies
帖子: 32
注册时间: 2006-11-05 1:59
送出感谢: 0
接收感谢: 0

#7

帖子 charlies » 2006-11-05 16:49

这个问题很晕..出现这种问题的时候也不能卸栽..破损包往往也不能修复...
扎怀俩怀
帖子: 14
注册时间: 2006-09-16 20:48
送出感谢: 0
接收感谢: 0

#8

帖子 扎怀俩怀 » 2006-11-05 22:12

感谢楼上各位,终于有人帮忙了

不过,很不幸,正如楼上所言,不能卸栽,也不能修复...

gaim有问题,却总是没法装- -b

另外,我没有装过openq这个东东哗
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#9

帖子 eexpress » 2006-11-05 22:39

不能卸载啊。aptitude remove xxxx也不行?
使用dselect就可以卸载了。只是这个软件太猛了。小心点使用。
● 鸣学
头像
SuperWar3Fan
帖子: 1263
注册时间: 2006-05-20 6:25
来自: 山东淄博
送出感谢: 0
接收感谢: 0
联系:

#10

帖子 SuperWar3Fan » 2006-11-06 8:22

用aptitude安装一下,应该可以自动降级,或者自动解决依赖问题。
扎怀俩怀
帖子: 14
注册时间: 2006-09-16 20:48
送出感谢: 0
接收感谢: 0

#11

帖子 扎怀俩怀 » 2006-11-06 19:12

不行啊,各位提供的方法我都试过了,gaim还是删不了,也重新装不了

dselect 怎么用啊,我的说明全是乱码- -b

问个笨问题,怎么查看到底是哪个依赖关系出错了啊?

p.s.问题依旧
dpkg:处理 heimdal-kdc (--configure)时出错:
子进程·post-installation script·返回了错误号·1
在处理时有错误发生:
heimdal-kdc
回复

回到 “老旧版本支持”