高手请教:./configure错误!

为当前最终发行版之前的所有版本提供支持
回复
wjjcml1982
帖子: 38
注册时间: 2005-10-26 8:46
来自: China
送出感谢: 0
接收感谢: 0

高手请教:./configure错误!

#1

帖子 wjjcml1982 » 2006-11-04 8:37

使用./configure出现如下错误:
......
checking for libjpeg... -ljpeg
checking for Qt... configure: error: Qt (>= Qt 2.2.2) (headers and libraries) not found. Please check your installation!
For more details about this problem, look at the end of config.log.

请问如何解决阿?
aBiNg
帖子: 1331
注册时间: 2006-07-09 12:22
来自: 南京
送出感谢: 0
接收感谢: 2 次

#2

帖子 aBiNg » 2006-11-04 9:03

~$ dpkg -S libqt //查找提供qt的lib&&headers的软件包,并安装之
libqt3-mt: /usr/share/doc/libqt3-mt/README.immodule
libqt3-mt: /usr/share/doc/libqt3-mt/changelog.Debian.gz
libarts1-dev: /usr/lib/libqtmcop.so
libqt3-mt: /usr/share/doc/libqt3-mt/README.Debian.gz
libqt4-sql: /usr/share/doc/libqt4-sql/copyright
libqt4-gui: /usr/share/doc/libqt4-gui
libqthreads-12: /usr/lib/libqthreads.so.12.3.1
libqt4-gui: /usr/share/lintian/overrides/libqt4-gui
libqt4-core: /usr/share/doc/libqt4-core/copyright
libqt3-mt: /usr/share/doc/libqt3-mt/changelog.gz
libqt3-mt: /usr/share/doc/libqt3-mt/PLATFORMS
libqt3-mt-dev: /usr/share/doc/libqt3-mt-dev/README.immodule
libqt3-mt: /usr/share/doc/libqt3-mt/README-QT.TXT
libqthreads-12: /usr/share/doc/libqthreads-12/changelog.Debian.gz
libqt4-gui: /usr/lib/qt4/plugins/accessible/libqtaccessiblewidgets.so
libqt3-mt: /usr/share/doc/libqt3-mt/README
libqt3-mt: /usr/lib/libqt-mt.so.3.3.6
libqt3-mt-mysql: /usr/share/doc/libqt3-mt-mysql
libqt4-sql: /usr/share/doc/libqt4-sql/changelog.gz
libqt3-mt-dev: /usr/lib/libqt-mt.la
libqt4-qt3support: /usr/share/doc/libqt4-qt3support
libqt3-mt: /usr/share/qt3/lib/libqt-mt.so.3
libqt3-mt: /usr/lib/libqt-mt.so.3.3
libqt3-mt: /usr/share/doc/libqt3-mt/copyright
libqt3-mt-mysql: /usr/share/doc/libqt3-mt-mysql/changelog.Debian.gz
libqt3-mt-dev: /usr/share/doc/libqt3-mt-dev/PLATFORMS
libqt3-mt-dev: /usr/share/doc/libqt3-mt-dev
libqt3-mt-dev: /usr/share/qt3/lib/libqt-mt.la
libqt3-mt-dev: /usr/lib/libqt-mt.so
libqt4-core: /usr/share/doc/libqt4-core
libqthreads-12: /usr/share/doc/libqthreads-12
libqt4-qt3support: /usr/share/doc/libqt4-qt3support/changelog.gz
libqt4-sql: /usr/share/doc/libqt4-sql
libarts1c2a: /usr/lib/libqtmcop.so.1.0.0
libqt4-sql: /usr/share/lintian/overrides/libqt4-sql
libqt3-compat-headers: /usr/share/doc/libqt3-compat-headers/changelog.Debian.gz
libqt4-sql: /usr/share/doc/libqt4-sql/changelog.Debian.gz
libqt3-headers: /usr/share/doc/libqt3-headers/copyright
libqt4-qt3support: /usr/share/doc/libqt4-qt3support/README
libqt3-mt-mysql: /usr/share/doc/libqt3-mt-mysql/changelog.gz
libqt3-headers: /usr/share/doc/libqt3-headers
libqt3-mt-dev: /usr/share/qt3/lib/libqt-mt.so
libqt3-mt-dev: /usr/share/doc/libqt3-mt-dev/changelog.gz
libqt4-core: /usr/share/doc/libqt4-core/changelog.gz
libqt4-core: /usr/share/lintian/overrides/libqt4-core
libqt3-mt-dev: /usr/share/doc/libqt3-mt-dev/changelog.Debian.gz
libqt3-compat-headers: /usr/share/doc/libqt3-compat-headers
libqt3-mt-dev: /usr/share/doc/libqt3-mt-dev/copyright
libqt4-gui: /usr/share/doc/libqt4-gui/changelog.gz
libqt4-gui: /usr/share/doc/libqt4-gui/copyright
libqt3-mt-mysql: /usr/share/doc/libqt3-mt-mysql/copyright
libqt4-core: /usr/share/doc/libqt4-core/README
libqt3-compat-headers: /usr/share/doc/libqt3-compat-headers/attic.tar.gz
libqthreads-12: /usr/share/doc/libqthreads-12/copyright
libqt3-mt: /usr/share/qt3/lib/libqt-mt.so.3.3
libqt4-gui: /usr/lib/qt4/plugins/codecs/libqtwcodecs.so
libqt3-mt-dev: /usr/share/doc/libqt3-mt-dev/README-QT.TXT
libqt3-mt: /usr/share/doc/libqt3-mt
libqt4-sql: /usr/share/doc/libqt4-sql/README
libqt3-mt: /usr/lib/libqt-mt.so.3
libqt4-gui: /usr/share/doc/libqt4-gui/README
libqt3-compat-headers: /usr/share/doc/libqt3-compat-headers/copyright
libqt4-qt3support: /usr/share/doc/libqt4-qt3support/copyright
libqt3-mt-dev: /usr/share/doc/libqt3-mt-dev/README.Debian.gz
libqt4-qt3support: /usr/share/lintian/overrides/libqt4-qt3support
libqt4-gui: /usr/lib/qt4/plugins/accessible/libqtaccessiblecompatwidgets.so
libqthreads-12: /usr/lib/libqthreads.so.12
libqt4-qt3support: /usr/share/doc/libqt4-qt3support/changelog.Debian.gz
libqt3-mt-dev: /usr/share/qt3/lib/libqt-mt.prl
libqt3-mt-dev: /usr/share/doc/libqt3-mt-dev/README
libqt3-compat-headers: /usr/share/doc/libqt3-compat-headers/changelog.gz
libqt4-core: /usr/share/doc/libqt4-core/changelog.Debian.gz
libqt3-mt-dev: /usr/lib/libqt-mt.prl
libarts1c2a: /usr/lib/libqtmcop.so.1
libqt4-gui: /usr/share/doc/libqt4-gui/changelog.Debian.gz
libarts1-dev: /usr/lib/libqtmcop.a
libqt3-headers: /usr/share/doc/libqt3-headers/changelog.gz
libarts1-dev: /usr/lib/libqtmcop.la
libqt3-headers: /usr/share/doc/libqt3-headers/changelog.Debian.gz

代码: 全选

$sudo apt-get install libqt3-headers libqt3-mt-dev
或者使用auto-apt去编译:

代码: 全选

$sudo apt-get install auto-apt
$auto-apt run ./configure
wjjcml1982
帖子: 38
注册时间: 2005-10-26 8:46
来自: China
送出感谢: 0
接收感谢: 0

#3

帖子 wjjcml1982 » 2006-11-05 8:49

还是未解决嘛!还是一样的错误阿!
checking for Qt... configure: error: Qt (>= Qt 2.2.2) (headers and libraries) not found. Please check your installation!
For more details about this problem, look at the end of config.log.
aBiNg
帖子: 1331
注册时间: 2006-07-09 12:22
来自: 南京
送出感谢: 0
接收感谢: 2 次

#4

帖子 aBiNg » 2006-11-05 9:25

~$apt-cache search --names-only qt|grep headers
libavahi-qt3-dev - Development headers for the Avahi QT3 integration library
libavahi-qt4-dev - Development headers for the Avahi QT4 integration library
libqt3-compat-headers - Qt 1.x and 2.x compatibility includes
libqt3-headers - Qt3 header files
libqttelepathy-dev - Qt bindings for Telepathy - library headers

所以,顶多再执行:
$sudo apt-get install libqt4-dev
或者安装auto-apt,然后:
$auto-apt run ./configure

再编译不通过,就不知道你安装的软件包依赖关系究竟怎么样的了...
wjjcml1982
帖子: 38
注册时间: 2005-10-26 8:46
来自: China
送出感谢: 0
接收感谢: 0

#5

帖子 wjjcml1982 » 2006-11-06 13:49

呵呵!还是不行!555555 ..........
k_f
帖子: 93
注册时间: 2006-09-28 14:17
送出感谢: 0
接收感谢: 0

#6

帖子 k_f » 2006-11-06 15:14

lz你的问题就是编译时找不到qt库的header文件,请用软件包管理器检查需要的qt库dev包是否安装,版本是否2.2.2,包的路径是否正确(这个出问题的可能性最大)。
回复

回到 “老旧版本支持”