MPlayer-1.0rc1.tar.bz2的安装问题

为当前最终发行版之前的所有版本提供支持
回复
wyhejp
帖子: 59
注册时间: 2006-10-28 14:43
送出感谢: 0
接收感谢: 0
联系:

MPlayer-1.0rc1.tar.bz2的安装问题

#1

帖子 wyhejp » 2006-11-04 15:17

我下载MPlayer-1.0rc1.tar.bz2后,把它解压然后安装怎么出现错误呢,应该如何安装呢?


/tmp/MPlayer-1.0rc1$ ./configure
Detected operating system: Linux
Detected host architecture: i386
Checking for cc version ... 4.1.2, ok
Checking for host cc ... cc
Checking for cross compilation ... yes
Checking for CPU vendor ... GenuineIntel (15:4:1)
Checking for CPU type ... Intel(R) Celeron(R) CPU 2.40GHz
Checking for GCC & CPU optimization abilities ... CPU optimization disabled. CPU not recognized or your compiler is too old.
error
Checking for kernel support of mmx ... failed
It seems that your kernel does not correctly support mmx.
To use mmx extensions in MPlayer, you have to upgrade/recompile your kernel!
Checking for kernel support of mmxext ... failed
It seems that your kernel does not correctly support mmxext.
To use mmxext extensions in MPlayer, you have to upgrade/recompile your kernel!
Checking for kernel support of sse ... failed
It seems that your kernel does not correctly support sse.
To use sse extensions in MPlayer, you have to upgrade/recompile your kernel!
Checking for kernel support of sse2 ... failed
It seems that your kernel does not correctly support sse2.
To use sse2 extensions in MPlayer, you have to upgrade/recompile your kernel!
Checking for mtrr support ... yes
Checking for assembler support of -pipe option ... no
Checking for compiler support of named assembler arguments ... yes
Checking for assembler (as 2.17) ... ok
Checking for .align is a power of two ... no
Checking for Linux kernel version ... 2.6.17-10-generic, ok
Checking for MPlayer binary name ... mplayer
Checking for awk ... mawk
Checking for extra headers ... none
Checking for extra libs ... none
Checking for -lposix ... no
Checking for -lm ... no
Checking for langinfo ... no
Checking for language ... using en (man pages: en)
Checking for enable sighandler ... yes
Checking for runtime cpudetection ... no
Checking for restrict keyword ... none
Checking for __builtin_expect ... no
Checking for kstat ... no
Checking for posix4 ... no
Checking for lrintf ... no
Checking for round ... no
Checking for nanosleep ... no
Checking for socklib ... no
Checking for inet_pton() ... no (trying inet_aton next)
Checking for inet_aton() ... no (network support disabled)
Checking for inttypes.h (required) ... no
Checking for bitypes.h (inttypes.h predecessor) ...
Error: Cannot find header either inttypes.h or bitypes.h (see DOCS/HTML/en/faq.html).

Check "configure.log" if you do not understand why it failed.
aBiNg
帖子: 1331
注册时间: 2006-07-09 12:22
来自: 南京
送出感谢: 0
接收感谢: 2 次

#2

帖子 aBiNg » 2006-11-04 17:07

~$dpkg -S inttypes.h
libc6-dev: /usr/include/inttypes.h

~$dpkg -S bitypes.h
libc6-dev: /usr/include/sys/bitypes.h

so we should run the following first:
$sudo apt-get install libc6-dev

注:可能楼主连编译环境都还没有安装的吧... :roll:
头像
BigSnake.NET
帖子: 12522
注册时间: 2006-07-02 11:16
来自: 廣州
送出感谢: 0
接收感谢: 7 次
联系:

#3

帖子 BigSnake.NET » 2006-11-04 17:48

1.将你下载的所有mplayer源码删掉
2.
sudo apt-get update
sudo apt-get install mplayer
^_^ ~~~
要理解递归,首先要理解递归。

地球人都知道,理论上,理论跟实际是没有差别的,但实际上,理论跟实际的差别是相当大滴。
aBiNg
帖子: 1331
注册时间: 2006-07-09 12:22
来自: 南京
送出感谢: 0
接收感谢: 2 次

#4

帖子 aBiNg » 2006-11-04 19:20

BigSnake.NET 写了:1.将你下载的所有mplayer源码删掉
2.
sudo apt-get update
sudo apt-get install mplayer
是不是武断了点呢?为什么不能让所谓"新手"多学一点知识呢?
在初学编译的时候,总会遇到问题,谁当时不也是这样呢?但是正所谓"会者不难",当我们熟悉了处理问题的方法之后,自然会有思路去解决它.
大禹治水,用"引"而不用"堵"的方法,我觉得很有实现意义.所以没有必要一上来就吓退所谓"新手"们,说:
"这么喜欢编译么?源里有的是!$sudo apt-get install packagename..."
不过,我觉得,人总要有点上进心,虽然不能因为整天研究这些东西而荒废了所谓"正业",但有谁能保证所谓"正业"真的就比"业余爱好"更加有价值呢?有谁能保证学点编译知识对于使用或学习linux就完全没有必要呢?

说多了,不好意思,包涵一下! :wink:
头像
karron
帖子: 6226
注册时间: 2005-06-11 14:03
来自: 不明真相的群众
送出感谢: 0
接收感谢: 0
联系:

#5

帖子 karron » 2006-11-04 19:55

在连apt-get都不会用的时候让他编译?如果连走都没有学会,还是不要想着跑吧。
我的blog,关于技术,软件,linux,vim <---- 所有博客均被河蟹.
wyhejp
帖子: 59
注册时间: 2006-10-28 14:43
送出感谢: 0
接收感谢: 0
联系:

#6

帖子 wyhejp » 2006-11-04 21:15

谢谢前辈们的赐教,我只是才这几天刚接触linux,对于linux还是一片空白.....
请多多包含...
头像
karron
帖子: 6226
注册时间: 2005-06-11 14:03
来自: 不明真相的群众
送出感谢: 0
接收感谢: 0
联系:

#7

帖子 karron » 2006-11-04 21:50

楼上的没有关系。你如果用的是6.10 ,可以试试本区置顶的一站式设置脚本。可以帮你解决问题。在ubuntu里面安装软件,不需要自己下载源代码自己编译,直接apt-get install 就好了。
我的blog,关于技术,软件,linux,vim <---- 所有博客均被河蟹.
回复

回到 “老旧版本支持”