当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 12 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 请问如何卸载ubuntu6.1自带的java?
帖子发表于 : 2006-11-04 21:37 

注册: 2006-07-11 9:17
帖子: 59
送出感谢: 0 次
接收感谢: 0 次
现在运行java命令的时候,会这样:

kevin@ubuntu:/$ java
Usage: gij [OPTION] ... CLASS [ARGS] ...
to invoke CLASS.main, or
gij -jar [OPTION] ... JARFILE [ARGS] ...
to execute a jar file
Try `gij --help' for more information.


我想先卸载这个java,然后安装sun的java包,请问如何卸载?


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2006-11-04 21:51 
头像

注册: 2005-06-11 14:03
帖子: 6226
地址: 不明真相的群众
送出感谢: 0 次
接收感谢: 0 次
直接安装就好,自带的不要卸载。


_________________
我的blog,关于技术,软件,linux,vim <---- 所有博客均被河蟹.


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2006-11-04 22:19 

注册: 2006-07-11 9:17
帖子: 59
送出感谢: 0 次
接收感谢: 0 次
谢谢!
还有个问题,ubuntu下 可以安装rpm 格式的软件吗?


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2006-11-04 22:24 
头像

注册: 2006-07-02 11:16
帖子: 12522
地址: 廣州
送出感谢: 0 次
接收感谢: 8
不推荐用rpm,情愿用预编译的bz2包直接解压


_________________
^_^ ~~~
要理解递归,首先要理解递归。

地球人都知道,理论上,理论跟实际是没有差别的,但实际上,理论跟实际的差别是相当大滴。


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2006-11-05 11:40 

注册: 2006-07-11 9:17
帖子: 59
送出感谢: 0 次
接收感谢: 0 次
为什么不推荐呢? 解压了需要/可以编译安装吗?


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2006-11-05 12:50 
头像

注册: 2005-06-11 14:03
帖子: 6226
地址: 不明真相的群众
送出感谢: 0 次
接收感谢: 0 次
一般来说源里面就有你所需的软件。不用到处下载。


_________________
我的blog,关于技术,软件,linux,vim <---- 所有博客均被河蟹.


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2006-11-05 15:18 

注册: 2006-07-11 9:17
帖子: 59
送出感谢: 0 次
接收感谢: 0 次
找不到啊.是不是需要更改sources.list的地址??请问哪个地址是含有java jdk的??谢谢!


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2006-11-05 21:15 
头像

注册: 2006-01-17 14:39
帖子: 274
地址: Nanking
送出感谢: 0 次
接收感谢: 0 次
surroad 写道:
谢谢!
还有个问题,ubuntu下 可以安装rpm 格式的软件吗?


apt-get install rpm

然后建个目录,/var/lib/rpm

接着和rh下一样,rpm -ivh *.rpm


_________________
ID:死乘把口, Matrix Chou
寨本网 山寨笔记本大本营


页首
 用户资料  
 
9 楼 
 文章标题 :
帖子发表于 : 2006-11-05 23:25 

注册: 2006-07-11 9:17
帖子: 59
送出感谢: 0 次
接收感谢: 0 次
郁闷,安装失败:
$ sudo rpm -ivh jdk-1_5_0_09-linux-i586.rpm
error: Failed dependencies:
glibc >= 2.1.2-11 is needed by jdk-1.5.0_09-fcs.i586
sh-utils >= 2.0-1 is needed by jdk-1.5.0_09-fcs.i586
fileutils >= 4.0-8 is needed by jdk-1.5.0_09-fcs.i586
gawk >= 3.0.4-1 is needed by jdk-1.5.0_09-fcs.i586
textutils >= 2.0-2 is needed by jdk-1.5.0_09-fcs.i586
/bin/sh is needed by jdk-1.5.0_09-fcs.i586


页首
 用户资料  
 
10 楼 
 文章标题 :
帖子发表于 : 2006-11-06 8:55 
头像

注册: 2006-01-17 14:39
帖子: 274
地址: Nanking
送出感谢: 0 次
接收感谢: 0 次
surroad 写道:
郁闷,安装失败:
$ sudo rpm -ivh jdk-1_5_0_09-linux-i586.rpm
error: Failed dependencies:
glibc >= 2.1.2-11 is needed by jdk-1.5.0_09-fcs.i586
sh-utils >= 2.0-1 is needed by jdk-1.5.0_09-fcs.i586
fileutils >= 4.0-8 is needed by jdk-1.5.0_09-fcs.i586
gawk >= 3.0.4-1 is needed by jdk-1.5.0_09-fcs.i586
textutils >= 2.0-2 is needed by jdk-1.5.0_09-fcs.i586
/bin/sh is needed by jdk-1.5.0_09-fcs.i586


漏了个参数。。
rpm -ivh *.rpm --nodeps


_________________
ID:死乘把口, Matrix Chou
寨本网 山寨笔记本大本营


页首
 用户资料  
 
11 楼 
 文章标题 :
帖子发表于 : 2006-11-06 9:25 
头像

注册: 2005-10-16 13:24
帖子: 958
地址: 四川成都
送出感谢: 2
接收感谢: 0 次
安装 sun-jre5
然后在update-alternatives --config java
选择sun 的jre


_________________
Thank you Ubuntu Team!!!!
I still can't belive this is free...


页首
 用户资料  
 
12 楼 
 文章标题 :
帖子发表于 : 2006-11-06 17:43 

注册: 2006-07-11 9:17
帖子: 59
送出感谢: 0 次
接收感谢: 0 次
现在装好了jdk,但是发现eclipse3.2使用不正常,键盘无法输入文字,但鼠标可以用!


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 12 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 5 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译