Ubuntu 10.10 如何安装版本号带下划线的deb包

为当前最终发行版之前的所有版本提供支持
回复
xingyun321
帖子: 10
注册时间: 2010-07-23 13:11
送出感谢: 0
接收感谢: 0

Ubuntu 10.10 如何安装版本号带下划线的deb包

#1

帖子 xingyun321 » 2010-11-03 13:04

今天看到一个Ubuntu的小问题,就是以前能在10.04上安装的软件但是到了10.10上无法安装,看了log发现是因为版本号上有一个“_”(下划线)。
现在说是不认这个下划线了,,请问如何可以解决这个问题呢?

最好不好改这个版本号,有没有从系统级别解决的方法?
头像
tenzu
论坛版主
帖子: 36913
注册时间: 2008-11-21 20:26
送出感谢: 0
接收感谢: 21 次

Re: Ubuntu 10.10 如何安装版本号带下划线的deb包

#2

帖子 tenzu » 2010-11-03 14:19

找10.10的包
xingyun321
帖子: 10
注册时间: 2010-07-23 13:11
送出感谢: 0
接收感谢: 0

Re: Ubuntu 10.10 如何安装版本号带下划线的deb包

#3

帖子 xingyun321 » 2010-11-03 15:52

这个包默认应该是都通用的,

但是现在因为这个问题装不了
xingyun321
帖子: 10
注册时间: 2010-07-23 13:11
送出感谢: 0
接收感谢: 0

Re: Ubuntu 10.10 如何安装版本号带下划线的deb包

#4

帖子 xingyun321 » 2010-11-04 10:23

再次的顶起,,有没有知道呢??
头像
astolia
论坛版主
帖子: 3103
注册时间: 2008-09-18 13:11
送出感谢: 1 次
接收感谢: 512 次

Re: Ubuntu 10.10 如何安装版本号带下划线的deb包

#5

帖子 astolia » 2010-11-04 12:57

既然你一直藏着掖着就是不说是哪个包,那么只有告诉你最麻烦的方法了

代码: 全选

sudo dpkg-deb -x 包名 pkg
sudo dpkg-deb -e 包名 pkg/DEBIAN
cd pkg/DEBIAN
sudo gedit control #自己修改Version那行
cd ../..
sudo dpkg-deb -b pkg 包名
xingyun321
帖子: 10
注册时间: 2010-07-23 13:11
送出感谢: 0
接收感谢: 0

Re: Ubuntu 10.10 如何安装版本号带下划线的deb包

#6

帖子 xingyun321 » 2010-11-04 14:29

我的意思是不要修改包的verison number,有没有可以从系统级别让他屏蔽下划线的方法,

就像10.04的那样,,
头像
astolia
论坛版主
帖子: 3103
注册时间: 2008-09-18 13:11
送出感谢: 1 次
接收感谢: 512 次

Re: Ubuntu 10.10 如何安装版本号带下划线的deb包

#7

帖子 astolia » 2010-11-04 18:38

本来版本号里带_就是不符合规范的,以前容忍这么做并不说明这么做是对的。
你非要破坏规范的话,去安装旧版本的dpkg包
回复

回到 “老旧版本支持”