当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 12 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 装软件怎么那么难呢?
帖子发表于 : 2010-11-07 18:42 

注册: 2010-06-30 16:23
帖子: 381
送出感谢: 0 次
接收感谢: 0 次
ubuntu10.04,想装个中文的DeaDBeeF,不是源里面的,下了深度汉化的版本,提示我 错误: 依赖关系没有满足:libgdk-pixbuf2.0-0 (>= 2.21.6),源里面的是1.8的,也没法升级,只好到网上找了一个ubuntu的Download Page for libgdk-pixbuf2.0-0_2.22.0-0ubuntu1_i386.deb on Intel x86 machines,安装,错误: 依赖关系没有满足:libglib2.0-0 (>= 2.25.9),这,ubuntu装个软件咋这么难啊?这些什么依赖关系,包,一般新手根本没法分辨,是不是新手就只能装装源里面的软件?起码windows各种改版软件运行都不会有问题,ubuntu这各种升级,各种桌面,前端,简直头都大了,看来要把ubuntu玩到windows那种水平需要天赋


页首
 用户资料  
 
2 楼 
 文章标题 : Re: 装软件怎么那么难呢?
帖子发表于 : 2010-11-07 18:54 

注册: 2007-09-02 20:23
帖子: 46
送出感谢: 0 次
接收感谢: 0 次
它提示你缺什么你就下载什么来安装,没有捷径,这就是linux的现实,很无奈。
我之前装epsxe时也是跟你差不多,有些关联文件好难找。


页首
 用户资料  
 
3 楼 
 文章标题 : Re: 装软件怎么那么难呢?
帖子发表于 : 2010-11-07 18:55 
头像

注册: 2009-04-12 13:20
帖子: 542
送出感谢: 0 次
接收感谢: 0 次
这个是编译.. 编译确实挺麻烦的
不过除此之外 安装deb或者从源里安装 每种方法都很简单安全 而且还不需要从下载网站里识别哪个是真的下载按钮.


_________________

look to the master
follow the master
walk with the master
see through the master
become the master


Follow me : @xvellyx
以后做一个好人


页首
 用户资料  
 
4 楼 
 文章标题 : Re: 装软件怎么那么难呢?
帖子发表于 : 2010-11-08 8:13 

注册: 2010-10-31 19:42
帖子: 1
送出感谢: 0 次
接收感谢: 0 次
慢慢就会习惯的 :em01


页首
 用户资料  
 
5 楼 
 文章标题 : Re: 装软件怎么那么难呢?
帖子发表于 : 2010-11-08 8:52 
头像

注册: 2007-06-13 15:57
帖子: 12635
地址: 在他乡
送出感谢: 53
接收感谢: 90
依赖没有满足就安装依赖嘛
即然是DEB包,让它自动安装依赖就是
代码:
sudo apt-get install -f


页首
 用户资料  
 
6 楼 
 文章标题 : Re: 装软件怎么那么难呢?
帖子发表于 : 2010-11-08 9:02 

注册: 2010-06-30 16:23
帖子: 381
送出感谢: 0 次
接收感谢: 0 次
狗了一圈,libglib2.0-0在10.04就支持到2.24,libglib2.0-0没法装2.25就装不了libgdk-pixbuf2.0-0 2.21,也就装不了DeaDBeeF中文版,晕啊,这下明白了linux为什么不怕木马了,我自己装个软件都这么难,木马就别想进得了


页首
 用户资料  
 
7 楼 
 文章标题 : Re: 装软件怎么那么难呢?
帖子发表于 : 2010-11-08 9:14 

注册: 2009-04-03 15:10
帖子: 1831
送出感谢: 0 次
接收感谢: 0 次
linux的特点就是不重复发明轮子
例如a软件需要适用b功能,通常情况下a软件的作者会找那个软件提供了b功能,如果他发现没有那个软件提供b,那么他有两个选择,要么抱怨一番然后写一个b软件来提供b功能,然后对外宣布a软件依赖于b,要么直接在a软件中实现b功能……通常他会选择前者;如果他发现有另一个软件c提供了b功能,那a的作者就把c的作者爱死了……他会直接适用c的功能,然后对外说a依赖于c……
这样导致的好处就是linux下软件大小很小,很多软件只有1MB到几个MB,我很少很少见到上100MB的,坏处就是依赖问题,新立德(还是新德利?)包管理器就是希望有机器而不是用人来解决这种依赖问题的……
lz是遇到特例了,一般不会这样,这说明貌似ubuntu源里没有包含这个软件,所以不能自动解决依赖问题。
这也算是linux的一个特点吧,有好处有坏处,不能一概而论的。

PS:楼主,其实最恶心的是循环依赖问题,编译安装时候的循环依赖会让你有把电脑砸了的冲动……


页首
 用户资料  
 
8 楼 
 文章标题 : Re: 装软件怎么那么难呢?
帖子发表于 : 2010-11-08 13:42 

注册: 2006-09-11 22:47
帖子: 2841
送出感谢: 0 次
接收感谢: 4
dshbusiness 写道:
PS:楼主,其实最恶心的是循环依赖问题,编译安装时候的循环依赖会让你有把电脑砸了的冲动……


把循环依赖的各个元素,都在同一个 apt-get install 命令中同时安装,即可解决循环依赖的问题。


页首
 用户资料  
 
9 楼 
 文章标题 : Re: 装软件怎么那么难呢?
帖子发表于 : 2010-11-08 17:57 

注册: 2009-04-03 15:10
帖子: 1831
送出感谢: 0 次
接收感谢: 0 次
poet 写道:
dshbusiness 写道:
PS:楼主,其实最恶心的是循环依赖问题,编译安装时候的循环依赖会让你有把电脑砸了的冲动……


把循环依赖的各个元素,都在同一个 apt-get install 命令中同时安装,即可解决循环依赖的问题。

我说的是编译安装!通过编译安装……


页首
 用户资料  
 
10 楼 
 文章标题 : Re: 装软件怎么那么难呢?
帖子发表于 : 2010-11-08 19:37 

注册: 2010-09-12 19:46
帖子: 197
送出感谢: 0 次
接收感谢: 0 次
尽量别自己装软件,容易发疯。


页首
 用户资料  
 
11 楼 
 文章标题 : Re: 装软件怎么那么难呢?
帖子发表于 : 2010-11-08 19:43 
头像

注册: 2005-10-16 8:26
帖子: 1937
地址: 地球
送出感谢: 0 次
接收感谢: 1
lily3978 写道:
ubuntu10.04,想装个中文的DeaDBeeF,不是源里面的,下了深度汉化的版本,提示我 错误: 依赖关系没有满足:libgdk-pixbuf2.0-0 (>= 2.21.6),源里面的是1.8的,也没法升级,只好到网上找了一个ubuntu的Download Page for libgdk-pixbuf2.0-0_2.22.0-0ubuntu1_i386.deb on Intel x86 machines,安装,错误: 依赖关系没有满足:libglib2.0-0 (>= 2.25.9),这,ubuntu装个软件咋这么难啊?这些什么依赖关系,包,一般新手根本没法分辨,是不是新手就只能装装源里面的软件?起码windows各种改版软件运行都不会有问题,ubuntu这各种升级,各种桌面,前端,简直头都大了,看来要把ubuntu玩到windows那种水平需要天赋


根据提示安装libglig先

http://www.pandabang.info/ubuntu/system/software.html


_________________
http://www.pandabang.info


页首
 用户资料  
 
12 楼 
 文章标题 : Re: 装软件怎么那么难呢?
帖子发表于 : 2010-11-08 21:27 

注册: 2010-06-30 16:23
帖子: 381
送出感谢: 0 次
接收感谢: 0 次
我现在想明白了,其实这是个兼容性问题,我想装的这个包是人家编译打包的,他的电脑上库文件版本跟我的不同,这就不能用,也就是说即使我学会了自己从源代码编译软件,编译出来的软件也只能我自己用,这对于linux的普及是个不低的门槛呢
说实话ubuntu在普及上已经做的很不错,汉化,包管理已经让ubuntu很容易入门,就像我,从装系统,装驱动到装软件,似乎没遇到什么麻烦(当然,电脑属于大众货也是一种优势),但等我想再进一步玩系统才发现,我只能从源代码,协议开始,这就让我有点知难而退了,这点上,商业化的微软很早就开始建立行业标准还是很有眼光的


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 12 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:243750496 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译