当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 10 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 无法安装pps,这个错误怎么办?
帖子发表于 : 2010-11-09 22:12 

注册: 2009-01-15 11:51
帖子: 51
送出感谢: 0 次
接收感谢: 0 次
我是个新手,闲来无事想折腾一下PPS,我用的是10.10,按照官方的方法:sudo apt-get install libqt4-core libqt4-dbus libqt4-gui libqt4-network libqt4-webkit libqt4-xml libfuse2 mplayer出现下列:
代码:
下列软件包有未满足的依赖关系:
 libqt4-core : 依赖: libqtcore4 (= 4:4.7.0-0ubuntu4) 但是 4:4.7.0-0ubuntu4.1 正要被安装
               依赖: libqt4-network (= 4:4.7.0-0ubuntu4) 但是 4:4.7.0-0ubuntu4.1 正要被安装
               依赖: libqt4-script (= 4:4.7.0-0ubuntu4) 但是 4:4.7.0-0ubuntu4.1 正要被安装
               依赖: libqt4-xml (= 4:4.7.0-0ubuntu4) 但是 4:4.7.0-0ubuntu4.1 正要被安装
               依赖: libqt4-dbus (= 4:4.7.0-0ubuntu4) 但是 4:4.7.0-0ubuntu4.1 正要被安装
               依赖: libqt4-test (= 4:4.7.0-0ubuntu4) 但是它将不会被安装
 libqt4-gui : 依赖: libqtgui4 (= 4:4.7.0-0ubuntu4) 但是 4:4.7.0-0ubuntu4.1 正要被安装
              依赖: libqt4-svg (= 4:4.7.0-0ubuntu4) 但是 4:4.7.0-0ubuntu4.1 正要被安装
              依赖: libqt4-opengl (= 4:4.7.0-0ubuntu4) 但是 4:4.7.0-0ubuntu4.1 正要被安装
              依赖: libqt4-designer (= 4:4.7.0-0ubuntu4) 但是它将不会被安装
E: 破损的软件包
还有QT库, 4.4.0及以上版本
* libFuse库, 2.7.2及以上版本这两个东东怎么查看自己的版本,这个和我安装出错有关系吧?也尝试sudo apt-get install libqtcore4这样一个一个解决依赖但还是不行,这到底是怎么回事啊?


页首
 用户资料  
 
2 楼 
 文章标题 : Re: 无法安装pps,这个错误怎么办?
帖子发表于 : 2010-11-09 22:40 

注册: 2009-01-15 11:51
帖子: 51
送出感谢: 0 次
接收感谢: 0 次
难道没有人知道怎么解决吗?


页首
 用户资料  
 
3 楼 
 文章标题 : Re: 无法安装pps,这个错误怎么办?
帖子发表于 : 2010-11-10 7:46 
头像

注册: 2010-06-16 1:05
帖子: 14668
地址: Tencent
系统: Mac OS X
送出感谢: 1
接收感谢: 153
哈哈,我还以为没人和我一样遇见
这问题呢。我也不知道怎么搞,难得折腾了。去下deb的qt试试


_________________
twitter求fo:http://twitter.com/maplebeats
博客求踩:http://maplebeats.com


页首
 用户资料  
 
4 楼 
 文章标题 : Re: 无法安装pps,这个错误怎么办?
帖子发表于 : 2010-11-10 10:58 

注册: 2009-01-15 11:51
帖子: 51
送出感谢: 0 次
接收感谢: 0 次
枫叶饭团 写道:
哈哈,我还以为没人和我一样遇见
这问题呢。我也不知道怎么搞,难得折腾了。去下deb的qt试试
你下过了?试过了吗?我也不想折腾了


页首
 用户资料  
 
5 楼 
 文章标题 : Re: 无法安装pps,这个错误怎么办?
帖子发表于 : 2010-11-10 17:38 

注册: 2008-12-25 10:37
帖子: 14
送出感谢: 0 次
接收感谢: 0 次
我试过了,直接下载安装包deb,然后安装,不用apt-get,可以用


页首
 用户资料  
 
6 楼 
 文章标题 : Re: 无法安装pps,这个错误怎么办?
帖子发表于 : 2010-11-10 18:05 

注册: 2009-08-29 14:44
帖子: 206
送出感谢: 1
接收感谢: 0 次
用新立得,强制安装libqtcore4 (= 4:4.7.0-0ubuntu4) 即可。我试过。


页首
 用户资料  
 
7 楼 
 文章标题 : Re: 无法安装pps,这个错误怎么办?
帖子发表于 : 2010-11-10 20:01 
头像

注册: 2005-09-30 14:59
帖子: 454
送出感谢: 0 次
接收感谢: 0 次
npxywml 写道:
用新立得,强制安装libqtcore4 (= 4:4.7.0-0ubuntu4) 即可。我试过。



我这么干了,但是要装不少依赖包,有些还可显卡有关系,我没敢搞 :em06 :em06


_________________
我的天真太早遗失,而我的成熟又蹒跚不至.......


页首
 用户资料  
 
8 楼 
 文章标题 : Re: 无法安装pps,这个错误怎么办?
帖子发表于 : 2010-11-10 20:23 
头像

注册: 2010-10-21 18:22
帖子: 97
送出感谢: 0 次
接收感谢: 0 次
要装QT库 还有PPS要调用mplayer 都需要一起安装 不用apt-get的话可以直接在新立得里面强制安装 也可以使用


_________________
http://www.iptables.me
尼玛别乱点,点了剁手
Email:alinuxsa#gmail.com
点此注册dropbox,机不可失啊亲!


页首
 用户资料  
 
9 楼 
 文章标题 : Re: 无法安装pps,这个错误怎么办?
帖子发表于 : 2010-11-11 10:12 
头像

注册: 2010-06-16 1:05
帖子: 14668
地址: Tencent
系统: Mac OS X
送出感谢: 1
接收感谢: 153
CAO知道问题了,你是不是也安了smplayer。smplayer的libqtcore4和pps的libqt4-core有冲突。把libqt4core卸载就行了。。。悲剧


_________________
twitter求fo:http://twitter.com/maplebeats
博客求踩:http://maplebeats.com


页首
 用户资料  
 
10 楼 
 文章标题 : Re: 无法安装pps,这个错误怎么办?
帖子发表于 : 2010-11-15 23:10 

注册: 2009-01-15 11:51
帖子: 51
送出感谢: 0 次
接收感谢: 0 次
枫叶饭团 写道:
CAO知道问题了,你是不是也安了smplayer。smplayer的libqtcore4和pps的libqt4-core有冲突。把libqt4core卸载就行了。。。悲剧
是啊我安装了SMPLAYER和他冲突?就是无法安装解决不了依赖!真不想折腾了~


附件:
Screenshot.png
Screenshot.png [ 58.79 KiB | 被浏览 1362 次 ]

页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 10 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:Google [Bot] 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译