如何让 pkg-config 找到通过 rpm 方式安装的软件

为当前最终发行版之前的所有版本提供支持
回复
rainbow702
帖子: 2
注册时间: 2010-11-10 16:05
送出感谢: 0
接收感谢: 0

如何让 pkg-config 找到通过 rpm 方式安装的软件

#1

帖子 rainbow702 » 2010-11-12 9:22

大家好,我想请教一个问题,恳请大家给点建议,谢谢:
我在安装virt-viewer时,遇到了
checking for pkg-config... /usr/bin/pkg-config
checking pkg-config is at least version 0.9.0... yes
checking for GTK2... configure: error: Package requirements (gtk+-2.0 >= 2.10.0) were not met:

No package 'gtk+-2.0' found

但我使用 rpm -qa | grep gtk2 命令,可以得到如下结果:
gtk2-2.10.4-16.el5
gtk2-2.10.4-16.el5
pygtk2-libglade-2.10.1-8.el5
gtk2-engines-2.8.0-3.el5
pygtk2-2.10.1-8.el5
gtk2-engines-2.8.0-3.el5

但是,使用 pkg-config --list-all | grep gtk 命令,却只得到:
gtk-demo gtk-query-immodules-2.0-32 gtk-query-immodules-2.0-64 gtk-update-icon-cache

我想,会不会因为 gtk 是通过 rpm 方式安装的,导致在 /usr/lib/pkgconfig 路径下面没有生相应的 .pc 文件,这样的话,我应该怎么样做才能让 pkg-config来找到我的 gtk 库呢?
头像
poweroff
帖子: 395
注册时间: 2008-12-13 15:03
送出感谢: 0
接收感谢: 1 次

Re: 如何让 pkg-config 找到通过 rpm 方式安装的软件

#2

帖子 poweroff » 2010-11-12 9:38

一条狗的马甲!
对不起,我承认我是一只穿着马甲的狗!
回复

回到 “老旧版本支持”