6.10中安装NVIDIA显卡驱动出现怪事

为当前最终发行版之前的所有版本提供支持
回复
4504569
帖子: 91
注册时间: 2006-10-22 15:20
送出感谢: 0
接收感谢: 0

6.10中安装NVIDIA显卡驱动出现怪事

#1

帖子 4504569 » 2006-11-06 18:39

安装 nvidia-glx和nvidia-settings互相冲突。。。。。安装glx的时候要提示卸载settigs,安装settings的时候有提示卸载glx。。。。。这可怎么搞啊永远安装不下去了。。。










yx@yyx:~$ sudo apt-get install nvidia-glx
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
Reading state information... 完成
The following packages were automatically installed and are no longer required:
nvidia-settings
使用 'apt-get autoremove' 来删除它们。
建议安装的软件包:
nvidia-kernel-source
下列软件包将被【卸载】:
nvidia-settings
下列【新】软件包将被安装:
nvidia-glx
共升级了 0 个软件包,新安装了 1 个软件包,要卸载 1 个软件包,有 0 个软件未被升级。
需要下载 0B/4059kB 的软件包。
解压缩后会消耗掉 11.5MB 的额外空间。
您希望继续执行吗?[Y/n]y
(正在读取数据库 ... 系统当前总共安装有 97835 个文件和目录。)
正在删除 nvidia-settings ...
选中了曾被取消选择的软件包 nvidia-glx。
(正在读取数据库 ... 系统当前总共安装有 97822 个文件和目录。)
正在解压缩 nvidia-glx (从 .../nvidia-glx_1.0.8762+2.6.15.11-5_i386.deb) ...
正在设置 nvidia-glx (1.0.8762+2.6.15.11-5) ...
ldconfig: /usr/lib/libgaim-client.so.0 is not a symbolic link

ldconfig: /usr/lib/libgaim.so.0 is not a symbolic link


yyx@yyx:~$ sudo apt-get install nvidia-glx
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
Reading state information... 完成
nvidia-glx 已经是最新的版本了。
共升级了 0 个软件包,新安装了 0 个软件包,要卸载 0 个软件包,有 0 个软件未被升级。
yyx@yyx:~$ sudo apt-get install nvidia-settings
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
Reading state information... 完成
The following packages were automatically installed and are no longer required:
nvidia-glx
使用 'apt-get autoremove' 来删除它们。
下列软件包将被【卸载】:
nvidia-glx
下列【新】软件包将被安装:
nvidia-settings
共升级了 0 个软件包,新安装了 1 个软件包,要卸载 1 个软件包,有 0 个软件未被升级。
需要下载 0B/504kB 的软件包。
解压缩后将会空出 11.5MB 的空间。
您希望继续执行吗?[Y/n]y
(正在读取数据库 ... 系统当前总共安装有 97866 个文件和目录。)
正在删除 nvidia-glx ...
ldconfig: /usr/lib/libgaim-client.so.0 is not a symbolic link

ldconfig: /usr/lib/libgaim.so.0 is not a symbolic link

选中了曾被取消选择的软件包 nvidia-settings。
(正在读取数据库 ... 系统当前总共安装有 97822 个文件和目录。)
正在解压缩 nvidia-settings (从 .../nvidia-settings_1.0-3ubuntu7_i386.deb) ...
正在设置 nvidia-settings (1.0-3ubuntu7) ...

yyx@yyx:~$
yyx@yyx:~$ sudo apt-get install nvidia-settings
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
Reading state information... 完成
nvidia-settings 已经是最新的版本了。
共升级了 0 个软件包,新安装了 0 个软件包,要卸载 0 个软件包,有 0 个软件未被升级。
yyx@yyx:~$ sudo apt-get install nvidia-glx
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
Reading state information... 完成
The following packages were automatically installed and are no longer required:
nvidia-settings
使用 'apt-get autoremove' 来删除它们。
建议安装的软件包:
nvidia-kernel-source
下列软件包将被【卸载】:
nvidia-settings
下列【新】软件包将被安装:
nvidia-glx
共升级了 0 个软件包,新安装了 1 个软件包,要卸载 1 个软件包,有 0 个软件未被升级。
需要下载 0B/4059kB 的软件包。
解压缩后会消耗掉 11.5MB 的额外空间。
您希望继续执行吗?[Y/n]
(正在读取数据库 ... 系统当前总共安装有 97835 个文件和目录。)
正在删除 nvidia-settings ...
选中了曾被取消选择的软件包 nvidia-glx。
(正在读取数据库 ... 系统当前总共安装有 97822 个文件和目录。)
正在解压缩 nvidia-glx (从 .../nvidia-glx_1.0.8762+2.6.15.11-5_i386.deb) ...
正在设置 nvidia-glx (1.0.8762+2.6.15.11-5) ...
ldconfig: /usr/lib/libgaim-client.so.0 is not a symbolic link

ldconfig: /usr/lib/libgaim.so.0 is not a symbolic link


yyx@yyx:~$ sudo apt-get install nvidia-glx
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
Reading state information... 完成
nvidia-glx 已经是最新的版本了。
共升级了 0 个软件包,新安装了 0 个软件包,要卸载 0 个软件包,有 0 个软件未被升级。
yyx@yyx:~$ sudo nvidia-glx-config enable
Error: unable to load nvidia kernel driver! Be sure to have installed
the nvidia driver for your running kernel.
yyx@yyx:~$ sudo apt-get install nvidia-glx
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
Reading state information... 完成
nvidia-glx 已经是最新的版本了。
共升级了 0 个软件包,新安装了 0 个软件包,要卸载 0 个软件包,有 0 个软件未被升级。
yyx@yyx:~$ sudo apt-get install nvidia-settings
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
Reading state information... 完成
The following packages were automatically installed and are no longer required:
nvidia-glx
使用 'apt-get autoremove' 来删除它们。
下列软件包将被【卸载】:
nvidia-glx
下列【新】软件包将被安装:
nvidia-settings
共升级了 0 个软件包,新安装了 1 个软件包,要卸载 1 个软件包,有 0 个软件未被升级。
需要下载 0B/504kB 的软件包。
解压缩后将会空出 11.5MB 的空间。
您希望继续执行吗?[Y/n]Y
(正在读取数据库 ... 系统当前总共安装有 97866 个文件和目录。)
正在删除 nvidia-glx ...
ldconfig: /usr/lib/libgaim-client.so.0 is not a symbolic link

ldconfig: /usr/lib/libgaim.so.0 is not a symbolic link

选中了曾被取消选择的软件包 nvidia-settings。
(正在读取数据库 ... 系统当前总共安装有 97822 个文件和目录。)
正在解压缩 nvidia-settings (从 .../nvidia-settings_1.0-3ubuntu7_i386.deb) ...
正在设置 nvidia-settings (1.0-3ubuntu7) ...

yyx@yyx:~$ sudo nvidia-glx-config enable
sudo: nvidia-glx-config: command not found
yyx@yyx:~$ sudo apt-get install nvidia-settings
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
Reading state information... 完成
nvidia-settings 已经是最新的版本了。
共升级了 0 个软件包,新安装了 0 个软件包,要卸载 0 个软件包,有 0 个软件未被升级。
yyx@yyx:~$
yyx@yyx:~$ sudo apt-get install nvidia-glx
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
Reading state information... 完成
The following packages were automatically installed and are no longer required:
nvidia-settings
使用 'apt-get autoremove' 来删除它们。
建议安装的软件包:
nvidia-kernel-source
下列软件包将被【卸载】:
nvidia-settings
下列【新】软件包将被安装:
nvidia-glx
共升级了 0 个软件包,新安装了 1 个软件包,要卸载 1 个软件包,有 0 个软件未被升级。
需要下载 0B/4059kB 的软件包。
解压缩后会消耗掉 11.5MB 的额外空间。
您希望继续执行吗?[Y/n]n
中止执行。
yyx@yyx:~$ sudo apt-get install nvidia-kernel-source
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
Reading state information... 完成
有一些软件包无法被安装。如果您用的是不稳定(unstable)发行版,这也许是
因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件
包尚未被创建或是它们还在新到(incoming)目录中。

您仅要求对单一软件包进行操作,这极有可能是因为该软件包安装不上,同时,
您最好提交一个针对这个软件包的故障报告。
下列的信息可能会对解决问题有所帮助:

下列的软件包有不能满足的依赖关系:
nvidia-kernel-source: 依赖: debhelper (> 4.0.0) 但是它将不会被安装
E: 无法安装的软件包
yyx@yyx:~$ sudo apt-get install nvidia-glx
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
Reading state information... 完成
The following packages were automatically installed and are no longer required:
nvidia-settings
使用 'apt-get autoremove' 来删除它们。
建议安装的软件包:
nvidia-kernel-source
下列软件包将被【卸载】:
nvidia-settings
下列【新】软件包将被安装:
nvidia-glx
共升级了 0 个软件包,新安装了 1 个软件包,要卸载 1 个软件包,有 0 个软件未被升级。
需要下载 0B/4059kB 的软件包。
解压缩后会消耗掉 11.5MB 的额外空间。
您希望继续执行吗?[Y/n]y
(正在读取数据库 ... 系统当前总共安装有 97835 个文件和目录。)
正在删除 nvidia-settings ...
选中了曾被取消选择的软件包 nvidia-glx。
(正在读取数据库 ... 系统当前总共安装有 97822 个文件和目录。)
正在解压缩 nvidia-glx (从 .../nvidia-glx_1.0.8762+2.6.15.11-5_i386.deb) ...
正在设置 nvidia-glx (1.0.8762+2.6.15.11-5) ...
ldconfig: /usr/lib/libgaim-client.so.0 is not a symbolic link

ldconfig: /usr/lib/libgaim.so.0 is not a symbolic link


yyx@yyx:~$ sudo nvidia-glx-config enable
Error: unable to load nvidia kernel driver! Be sure to have installed
the nvidia driver for your running kernel.
yyx@yyx:~$ sudo apt-get install nvidia
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
Reading state information... 完成
E: 无法找到软件包 nvidia
yyx@yyx:~$
liangkou
帖子: 5
注册时间: 2006-11-05 21:10
来自: Nankai U
送出感谢: 0
接收感谢: 0
联系:

#2

帖子 liangkou » 2006-11-06 22:10

把源设置对(dapper),然后用新立得软件管理搜索nvidia然后安装看看
头像
我思故我在
帖子: 101
注册时间: 2006-08-17 1:13
送出感谢: 0
接收感谢: 2 次

#3

帖子 我思故我在 » 2006-11-06 22:28

  这是ubuntu本身的问题,如果你只要驱动安装
sudo apt-get install nvidia-glx就可以了。它可以支持Rotate部分功能。
如果你要用nvidia-settings的颜色及加速能其他功能可以安装
sudo apt-get install nvidia-glx-legacy nvidia-settings但是这个驱动不支持Rotate功能。
另外两种安装都不能实现XRanR功能。
  原来在6.06就已经有这个问题了,没想到6.10依然存在。我的显卡是nvidia gefoce 3 ti 200,改成quardo专业显卡的情况也是依然存在。
  还有最彻底的解决办法,可以实现所有功能,下载对就linux内核源码包编译新内核,到nvidia官方网下载linux驱动。(这个方法不建议你用,比较复杂,主要是为了实现屏幕旋转90度的功能。)
头像
karron
帖子: 6226
注册时间: 2005-06-11 14:03
来自: 不明真相的群众
送出感谢: 0
接收感谢: 0
联系:

#4

帖子 karron » 2006-11-06 22:32

nvidia-glx 里面已经包含了setting,所以不需要了.
我的blog,关于技术,软件,linux,vim <---- 所有博客均被河蟹.
头像
我思故我在
帖子: 101
注册时间: 2006-08-17 1:13
送出感谢: 0
接收感谢: 2 次

#5

帖子 我思故我在 » 2006-11-06 22:36

karron 写了:nvidia-glx 里面已经包含了setting,所以不需要了.
我狂晕,果然如此,犯了如此一个低级错误。
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#6

帖子 eexpress » 2006-11-06 22:53

使用svn版本吧。
● 鸣学
回复

回到 “老旧版本支持”