当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 4 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : nas开机自启动 10.10版本中的问题. ubuntu开机自启动全过程
帖子发表于 : 2010-11-15 12:09 

注册: 2010-11-15 11:52
帖子: 4
送出感谢: 0 次
接收感谢: 0 次
因为在我写的qt代码中.需要nas支持qt声音模块. 所以.必须开机自启动nas服务.

在ubuntu9.10版本中.因为我的qt代码也是自启动运行的("系统-首选项-会话" 添加开机自启动).
所以在qt代码的最开始.执行了system("nasd -aa &")语句.经过N次的实验.完全没有问题!

但是在ubuntu10.10中. qt代码自启动运行.竟然无视了system这条语句. 在root权限下查看ps -jax 没有nasd -aa进程的存在.

于是我改在/etc/rc.local中添加"nasd -aa &". 很开心的qt代码运行起来有声音了.但是经过N次测试.有20%开机无声.但是nas进程已经启动了.

这到底是什么原因???

谁能帮助我一下?

是ubuntu开机自启动? 还是nas?


页首
 用户资料  
 
2 楼 
 文章标题 : Re: nas开机自启动 10.10版本中的问题. ubuntu开机自启动全过程
帖子发表于 : 2010-11-15 14:08 

注册: 2010-11-15 11:52
帖子: 4
送出感谢: 0 次
接收感谢: 0 次
:em03 因为是第一次发贴.可能发错了地方.嘿嘿.
不过问题已经解决了.因为用户权限的问题.不知为什么10.10普通用户就是不能搞起nas来.
当我开机启动时是root用户. nas就随便搞起来了.
($ sudo vi /etc/gdm/custom.conf 把/etc/gdm/custcom.conf 的普通用户名改为root.开机就是root身份)

感谢ubuntu 其他论坛的答案.感谢google.

嘿嘿...


页首
 用户资料  
 
3 楼 
 文章标题 : Re: nas开机自启动 10.10版本中的问题. ubuntu开机自启动全过程
帖子发表于 : 2010-11-15 15:04 
头像

注册: 2010-08-27 15:53
帖子: 803
送出感谢: 0 次
接收感谢: 1
nnd,在新手论坛发个nas, :em20


_________________
基础问题,请看入门手册http://people.ubuntu.com/~happyaron/udc-cn/lucid-html/

Acer aspire 4736G / Ubuntu 10.04LTS
Asus eeepc900 / Xandros
Nokia N900 / Maemo 1.2.12


页首
 用户资料  
 
4 楼 
 文章标题 : Re: nas开机自启动 10.10版本中的问题. ubuntu开机自启动全过程
帖子发表于 : 2010-11-16 14:19 

注册: 2010-11-15 11:52
帖子: 4
送出感谢: 0 次
接收感谢: 0 次
:em06 各大linux网站经常潜水的. 所以.不知道具体发贴的地方.看到新手位置.就发来了.嘿嘿.见谅哈.以后改正过来..

加油! :em11


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 4 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 5 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译